Jump to content
  • 0

Loss of Saves


Question

Recommended Posts

  • 0

Hello. I am very sorry that your save game files seem to have disappeared. We ask that anyone affected by this issue to please attach your DxDiag file, and also any output files that the game created, to this post. This would help us determine if there is a common thread and find a way to resolve the issue. In the meantime, thank you for your patience and any assistance you can provide us in narrowing this issue down.

 

--Doug. 

Attached are the files I have.  I hope these help.   Thank you for checking on this.

output_log.zip

DxDiag.txt

Link to post
Share on other sites
  • 0

If you lost your save check these two locations:

C:\Users\Username\Saved Games\Pillars of Eternity II

C:\Users\Username\AppData\LocalLow\Obsidian Entertainment\Pillars of Eternity II

I recommend backing saved game folders up with a scheduled task script to a Cloud Backup folder or use folder replication. Steam Cloud isn't very good and will often overwrite/delete your save file hosted on the server.

Here is the command I use: Robocopy "C:\Users\USERNAME\Saved Games" "C:\Users\USERNAME\OneDrive\Saved Games" /MIR /XA:H /LOG+:"C:\Users\USERNAME\OneDrive\Scripts\Logs\Save Back.txt"

You can add multiple lines for various Save Game folders stashed in your APPDATA folder.

Tutorial:
http://caughtinpixels.com/how-to-create-a-backup-script-using-robocopy/

Edited by syphonhail
Link to post
Share on other sites
  • 0

Yes, I do. It makes the game unplayable for me. Tired to do the same thing in the game, save and when I want to load a game it load a game few hours before.

 

The only workaround I found is chek if the game is saved after each save (trying to load it) and even with that, when I think it's ok, it's not...

Try to launch the game as administrator, no effect. I've disable steam cloud and checked the games files with no result...

 

As  a youtuber that maked people buy the game, I'm not really comfortable either... Really disapointing...

Link to post
Share on other sites
  • 0

I have been having issues w save files disappearing.

 

About 10 hours into the game, save files just keep disappearing.

 

I have seen other posts for this. please address this issues

 

 

thanks

If you can post the relevant files to this message that will help them get to the bottom of it.

Link to post
Share on other sites
  • 0

The first game had an issue, which may have carried over, where a "temp" file got corrupted and as a result no saves could be loaded, even though they were all still present in the save directory.

 

If your saves all vanish from the game, but are still present in the save directory, maybe it's that same bug?

 

Fix for that but in the first game was to 

 

First delete the folder C:\Users\username\AppData\LocalLow\Obsidian Entertainment

Then delete the folder C:\Users\username\AppData\Local\Temp\Obsidian Entertainment

 

then reboot and restart the game; game will create new directories and temp files; etc. 

 

Don't know if this will fix this issue in new game but it may be a similar issue carrying over.

Link to post
Share on other sites
  • 0

The first game had an issue, which may have carried over, where a "temp" file got corrupted and as a result no saves could be loaded, even though they were all still present in the save directory.

 

If your saves all vanish from the game, but are still present in the save directory, maybe it's that same bug?

 

Fix for that but in the first game was to 

 

First delete the folder C:\Users\username\AppData\LocalLow\Obsidian Entertainment

 

Then delete the folder C:\Users\username\AppData\Local\Temp\Obsidian Entertainment

 

then reboot and restart the game; game will create new directories and temp files; etc. 

 

Don't know if this will fix this issue in new game but it may be a similar issue carrying over.

For me the autosaves are still there and those have saved me ;) a few times.  It seems to only be the saves I do that disappear.  But could be those are the only ones I noticed.

 

I even checked the save folder and all saves were there but mine.  And its not every time, sometimes they disappear and sometimes they don't. 

Link to post
Share on other sites
  • 0

I'm so glad I found this thread!  I'm not alone! :'D

 

So, it appears that on launch, the game actively clears the contents of the "C:\Users\username\AppData\LocalLow\Obsidian Entertainment\Pillars of Eternity II\CurrentGame" folder.  When I first found this folder, it was empty.  Not really sure what kind of file it expected, I made an assumption and grabbed my copied my latest save file into it.  The game was already running, and nothing changed in the menu -- normal, given it probably only checks on launch.  So I exited and restarted the game, and the "Load" and "Continue" menus were still grey.  When I alt-tabbed and checked that folder, my save file was gone.

 

The actual save files are safe in the "C:\users\username\Saved games\Pillars of Eternity II" folder, but this CurrentGame folder keeps clearing itself out for some reason.

 

I hope that's helpful!

 

 

*EDIT* Added my dxdiag from last night's troubleshooting.  Also, one other observation:  I didn't think to mention this before, but I never could successfully import my PoE 1 saved game.  No matter what I did, or where I put the GameComplete file, PoE 2 simply wouldn't see it, even after multiple exit/restarts and much tinkering.  Related, perhaps?

20180521_dxdiag.txt

Edited by Pharsalus
Link to post
Share on other sites
  • 0

I'm so glad I found this thread!  I'm not alone! :'D

 

So, it appears that on launch, the game actively clears the contents of the "C:\Users\username\AppData\LocalLow\Obsidian Entertainment\Pillars of Eternity II\CurrentGame" folder.  When I first found this folder, it was empty.  Not really sure what kind of file it expected, I made an assumption and grabbed my copied my latest save file into it.  The game was already running, and nothing changed in the menu -- normal, given it probably only checks on launch.  So I exited and restarted the game, and the "Load" and "Continue" menus were still grey.  When I alt-tabbed and checked that folder, my save file was gone.

 

The actual save files are safe in the "C:\users\username\Saved games\Pillars of Eternity II" folder, but this CurrentGame folder keeps clearing itself out for some reason.

 

I hope that's helpful!

Yeah you are certainly not alone, if you can upload your files (Support requested his earlier in thread) it might help them determine whats happened.  I know a few of us have been able to do it. 

 

Thanks for posting as well, since the more that post in here hopefully the more information they have and the maybe the more attention it will get.

Link to post
Share on other sites
  • 0

I'm also having problems with disappearing saves.

 

In my case, it seems like when I have a manual save made while on the over-world and then make a save after it that is also on the over-world, that latter save will overwrite the former. If I make a save between the two that is in a close-up location like in the ship, a city, an encounter location, etc., the latter won't overwrite the former then. I'm not sure if auto-saves may overwrite saves in this manner as well, though it doesn't seem to happen with quick-saves.

 

I'm not sure if anyone else has experienced this specific case, and I haven't found any posts about it, but maybe it's one possible cause for disappearing saves.

Link to post
Share on other sites
  • 0

I'm also having problems with disappearing saves.

 

In my case, it seems like when I have a manual save made while on the over-world and then make a save after it that is also on the over-world, that latter save will overwrite the former. If I make a save between the two that is in a close-up location like in the ship, a city, an encounter location, etc., the latter won't overwrite the former then. I'm not sure if auto-saves may overwrite saves in this manner as well, though it doesn't seem to happen with quick-saves.

 

I'm not sure if anyone else has experienced this specific case, and I haven't found any posts about it, but maybe it's one possible cause for disappearing saves.

Well that's just crazy talk. ;)   I haven't noticed this but to be honest don't think I would be observant enough to. :)  Next time I get to play I will try this.   Thank you for posting to the thread. 

Link to post
Share on other sites
  • 0

I have repeatedly experienced this problem on the Mac version of Deadfire, but I do not know what a DxDiag file is or where to find it. I searched my filesystem, but it didn't find any matches by that name.

 

The pattern appears to be that whenever I boot up the game, my most recent save file has disappeared.

 

This is different than the pattern I encountered with PoE1. In the first game, the save files disappeared whenever I saved multiple files with the same timestamp (as far as I could tell) -- but it based it on the in-game timestamp, not the real system time. That meant that if I paused the game and saved two files, the second one would always delete the first (because within-game, the time hadn't advanced any since it was paused). And since I typically always pause the game before doing anything, then anytime I did any management of my save files that included saving two copies (because neither PoE1 or Deadfire send any message to the console that your save was successful) and deleting what I thought was an unnecessary copy, I would generally end up deleting the only recent copy (because the game had already deleted the other copy). I haven't tried replicating this pattern in Deadfire, because the Deadfire bug is so much worse I get too frustrated to continue playing.

 

Another Deadfire bug that may or may not be related to the save files getting deleted: Twice now, I've encountered an issue where it split my current character's save files into two different characters with the same name. So I have one copy of "Bob" with maybe an autosave from the current day, and a completely separate character also named "Bob" who has all the historical save files from the day before.

Link to post
Share on other sites
  • 0

I experienced the issue for 3 times, 30+hours playing just gone after restart steam. I will not play deadfire unless they fix the bug.

so you lost all your saves?  I havent lost any Auto saves yet, just the ones where I save and name them.

Link to post
Share on other sites
  • 0

 

I experienced the issue for 3 times, 30+hours playing just gone after restart steam. I will not play deadfire unless they fix the bug.

so you lost all your saves?  I havent lost any Auto saves yet, just the ones where I save and name them.

 

I was keeping the Autosaving on, I lost the saves 3 times and they all just coming back when I turned on cloud service. But today they have gone again and I'm trying to get them back now.

Link to post
Share on other sites
  • 0

I have this bug as well. What I've noticed however is that the savegame files themselves haven't actually gone anywhere, they are still in my savegame folder. What seems to be the problem is when you start up the game a random number of saved games appear on the load menu, never all of them and often missing the latest one.

Link to post
Share on other sites
  • 0

I have this bug as well. What I've noticed however is that the savegame files themselves haven't actually gone anywhere, they are still in my savegame folder. What seems to be the problem is when you start up the game a random number of saved games appear on the load menu, never all of them and often missing the latest one.

 

Remove (BACKUP them before) all the save from the folder then add just the vanished one and manually rename it, 

  Last time i solved in this way

When solved ofc put again the other working save in your folder

Edited by kilay
Link to post
Share on other sites
  • 0

Got the GoG version of the game, all my save files seem to be lost.

 

I can't find it either in "saved games" windows folder, nor in the game folder. Any idea where i should look for it elsewhere or how i can download it from GoG Galaxy cloud ?

 

 

Plz fix this devs this bug is gamebreaking, and loosing 30hours saves is just extremely frustrating : /

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...