Jump to content
  • 0

Can't continue/load save games


Question

Hello,

 

The game doesn't allow me to load saves games anymore.

The first few times it happened I had to exit and restart the game a few times and at some point the "continue" button was returning clickable, but now even this isn't working anymore.

The saves are there in my user\Saved Games\Pillars of Eternity II folder, but the game doesn't see them.

 

I checked the output log it has a couple entries with access denied to AppData\Local\Temp\Obsidian Entertainment\Pillars of Eternity II\TempSaveData

 

I tried deleting the folder, recreating it, running the game as admin etc. Nothing works.

Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

Hello !

So here is my issue: I cannot load my saves. Only the "New game button" is active when I start the game. I did play the game for 6 hours, and I do have saves in my %USERPROFILE%\Saved Games\Pillars of Eternity II

 

The first time, I installed the game on my E:/ drive, which I do for steam game that do not benefit too much from SSD.

 

When that happened, I uninstalled the game and installed again on my C:/ (just to make sure).

 

I got access to my save game then.

 

Then I logged off, started the game later, same issue: can't continue. This time I just rebooted the computer to make sure: I had access to my save game again (for no reason).

 

Tonight, I want to play again, and here I am again, same issue, can't load previous saves. I tried to reboot my computer multiple times, run Steam in admin mode, nothing.

 

Is this a known issue ? Is there a fix for that ? 

Thank you,

 

Melo

post-213343-0-30246500-1526334428_thumb.png

post-213343-0-49213600-1526334433_thumb.png

  • Like 1
Link to post
Share on other sites
  • 0

As in title i cant continue and load a game. Both buttons are jus grey (unclicable) and thats all.
Sometimes, after few restarts of game i can use load/continue but in 90% of cases i cant.
Somebody had same problem and know how to fix it?

 

 

*sorry for my english

Link to post
Share on other sites
  • 0

Since I see some people has the same problem I described in the OP, I'll tell you what I found out.

 

It waa my antivirus (Windows Defender in my case) that prevented Pillars to read the folder with save files.

I tried to add exceptions to the antivirus but I didn't manage to solve the issue, so when I launch the game I have to disable the antivirus, load the game then alt-tab to desktop and re-enable the AV.

 

It sucks but at least I can play.

Link to post
Share on other sites
  • 0

Yeah thats not my problem. I looked at the output log and it says that my zip file is corrupt like this

 

(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

UnauthorizedAccessException: Access to the path "C:/Users/Andrew/AppData/Local/Temp/Obsidian Entertainment/Pillars of Eternity II/loadedSave.zip" is denied.
  at System.IO.File.Delete (System.String path) [0x00000] in <filename unknown>:0
  at Game.SaveLoadManager.LoadSaveGameMetadata (System.String filename, SizeStyle sizeStyle) [0x00000] in <filename unknown>:0
UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
UnityEngine.DebugLogHandler:LogException(Exception, Object)
UnityEngine.Logger:LogException(Exception, Object)
UnityEngine.Debug:LogException(Exception)
Game.SaveLoadManager:LoadSaveGameMetadata(String, SizeStyle)
Game.SaveLoadManager:LoadAllSaveGameMetadatas(SizeStyle, Boolean&)
Game.SaveLoadManager:CacheSaveGameInfoThreadFunc()
 
(Filename:  Line: -1)

ZIP FILE WAS CORRUPT! C:/Users/Andrew/Saved Games/Pillars of Eternity II/Wulfie (454d8c06-607f-44b8-8190-1e39bbafa9e6) autosave_0.savegame

 

I have erase my old save files and try new game  few times.

Link to post
Share on other sites
  • 0

Just trying it today. Not fixed in my case. I'm going to try to install it (again !) one last time, see if it fixes things.

 

A lot of people seem to have had this problem for a lot of different reasons, some of which weren't fixed by the patch. (In my case, it turned out that a security program was preventing the game from working.) Unfortunately, the result of multiple threads on the same topic is that it can be hard to find advice that actually works.

 

Here's the longest thread on the subject I've come across.

Here's another one that offers a few different solutions.

I hope that one of those will help.

Link to post
Share on other sites
  • 0

Same problem. New patch did not fixed it !!

Rebooted my computer , sometime it worked , sometime it didn’t.

Developer please help us poor watcher T^T .

May be our computers were cursed by some gods ??

 

I don’t know how can you get log file, any idea?

Edited by Luvsucklonewolf
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...