Jump to content
  • 0
Jeff-66

consistent, self-correcting freezes

Question

during gameplay, the game hangs and what seems like random times, but it is consistent. i'd guess it happens around every 10-15 minutes. it appears to be a hard freeze, but I found that if i wait it out (10 to 30 seconds), it will unfreeze and I can go back to playing. Just before unfreezing, i think i hear the sound drop out and restart. once it recovers both audio and video are back to normal.

 

This also happens 100% of the time on exiting the game. the screen freezes for about 30 seconds, then will 'release' to the desktop. 

 

attached save game, output log, dxdiag report, zipped

 

edit: this definitely seems to be tied to vsync on (for me). when I disabled vsync, the problem went away, including on exiting. With vsync on, exiting the game had always resulted in 60 to 70 secs of hard freeze before releasing. With it off, the game exited in about 4 seconds. No in-game freezes either, so far.

bug_report.zip

Edited by Jeff-66
  • Like 1

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

Similar problem here. Played all evening yesterday without problems, but today the game freezes every few minutes for a few seconds and then resumes. Sound still plays. Disabling vsync hasn't helped.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Hello Jeff-66,

 

Thanks for your post! I will get that information added to our system.

 

Bread-a-tester, if you could provide info for your computer to help us assess the issue it would be greatly appreciated.

 

Best,

 

-Caleb


I like big bugs and I cannot lie...

Share this post


Link to post
Share on other sites
  • 0

I can also confirm this problem. However, my does not self correct. It simply hangs until I shut down the program via task manager.

 

Other things I have noticed is that I can still move the cursor and that it reacts to its position (switching for a pointer to the "can't move here" mark)

 

Sound still plays and conversations will still go. I can even pick new conversation options with keys.

 

Turning off vsync seemed to reduce the frequency of the crashes.

 

Specs:

 

ATI R9 290x Graphics Card

AMD Vishera 8-Core 4.0 Ghz processor

8 GB Ram

Windows 10

 

Share this post


Link to post
Share on other sites
  • 0

Hello Jeff-66,

 

Thanks for your post! I will get that information added to our system.

 

Bread-a-tester, if you could provide info for your computer to help us assess the issue it would be greatly appreciated.

 

Best,

 

-Caleb

 

This has been resolved for me, see https://forums.obsidian.net/topic/97832-game-stutterslags-every-minute-or-so/, with diagnostics attached there.

Share this post


Link to post
Share on other sites
  • 0

Just wanted to add a "me too!"

 

At (seemingly) random times, maybe about every minute or two, the game just freezes - screen locks up, no input allowed, nothing (though the cursor still moves). Just frozen. Then after about 30 seconds it all of a sudden starts up again and runs fine. This is infuriating because while I can play, I keep having to wait for it to un-freeze.

I *know* it isn't anything to do with my PC.  It isn't load times or memory because the game is installed on my SSD and I have 16GB of RAM. All other games - Divinty: Original Sin 2 and everything else work just dandy, even very graphics-intensive ones.  All other apps work fine.  I have the latest drivers installed.  The computer does not do this when not running the game.

 

I can submit any diagnostics you want, just ask.

I'm at my wits end.  I really want to play, but playing this way makes me want to smash the monitor.  Thanks!

Share this post


Link to post
Share on other sites
  • 0

Pillars of Eternity II: Deadfire screen freezes out-of-the-blue with no pattern for me. But, lately they have become more frequent and I feel as if I have exhausted every possible solution. It is assuredly not my PC's fault as it is a brand new gaming PC and I tested a dozen different games after troubleshooting Deadfire to make sure that it was exclusive to Deadfire. PoE I even still works with no freezes. Can someone please help and grant me a reliable solution? I'll try anything, as long as it works for sure. I really do enjoy this game, but It's literally unplayable right now. 

Share this post


Link to post
Share on other sites
  • 0

I can also confirm this problem. However, my does not self correct. It simply hangs until I shut down the program via task manager.

 

Other things I have noticed is that I can still move the cursor and that it reacts to its position (switching for a pointer to the "can't move here" mark)

 

Sound still plays and conversations will still go. I can even pick new conversation options with keys.

 I am experiencing the same issue since the turn-based patch, though my Game only crashes when entering any cutscene or forced dialogue (as in not started by me). The screen freezes and sound hitches for a second. Sound then continues, i can move the cursor and it will react and I can advance conversations but nothing happens in terms of visual display.

 

Radeon WattMan also then reports an "unexpected failure", so assume it has something to do with graphics. I am running an R9 390, which usually does not run into any problems.

 

So far I have:

1) Turned Vsync On/Off

2) Turned GoG overlay On/off

3) Tried Windowed/Fullscreen

4) Updated Graphics Driver

5) Clean Re-Install of Graphics Driver

6) Clean Re-Install of PoE II

7) Tried running the game with my 2nd screen unplugged.

 

I am really at a loss here. I restarted my playthrough in turn-based mode and it worked fine for a good long while. First crash happened with the cutscene after finishing the Questline with the feuding families in Neketaka. I thought it might be a problem with that specific moment, reloaded and moved on. Now I am at Fort Deadlight at can't go up to the smithy, because the game crashes once the guard talks to me. On my previous, non turn-based, save this cutscene worked fine.

 

I'm grateful for any ideas on what I could do, because I really want to play through this game.

Share this post


Link to post
Share on other sites
  • 0

Radeon WattMan also then reports an "unexpected failure", so assume it has something to do with graphics. I am running an R9 390, which usually does not run into any problems.

This sounds like a driver crash. Do you get any other wattman notes? Any custom settings? I have an undervolted/overclocked Vega 64 and on any other game it's fine (my go to examples are maxed out HDR assassin's creed odyssey or 4k high settings shadow of the tomb raider), but until I really amped up the fans *only* in Deadfire would I get "safe temps exceeded" errors in wattman, so "usually does not run into problems" doesn't appear to be a good enough criteria because Deadfire's engine is unusually heavy-hitting.

Share this post


Link to post
Share on other sites
  • 0

 

Radeon WattMan also then reports an "unexpected failure", so assume it has something to do with graphics. I am running an R9 390, which usually does not run into any problems.

This sounds like a driver crash. Do you get any other wattman notes? Any custom settings? I have an undervolted/overclocked Vega 64 and on any other game it's fine (my go to examples are maxed out HDR assassin's creed odyssey or 4k high settings shadow of the tomb raider), but until I really amped up the fans *only* in Deadfire would I get "safe temps exceeded" errors in wattman, so "usually does not run into problems" doesn't appear to be a good enough criteria because Deadfire's engine is unusually heavy-hitting.

 

 I haven't messed with any settings regarding overclocking/volting or anything. Temps are looking fine and aside from the "unexpected failure" report, Wattman doesn't have anything to say. During normal gameplay the card runs smoothly.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...