Jump to content
  • 0
Sign in to follow this  
Naborg

Recruited adventurers lose their voice when dismissed

Question

Whenever you dismiss your custom made recruited adventurer in your stronghold, they lose their voice when you recruit them again. Happened to both of my custom companions :(

 

Is there a workaround/fix for this?

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

Whenever you dismiss your custom made recruited adventurer in your stronghold, they lose their voice when you recruit them again. Happened to both of my custom companions :(

 

Is there a workaround/fix for this?

 

 

It also seems to influence new custom made recruits, as I have made three of them just a moment ago for testing, and none had a voice. It's irritating, since I have two of them in my group.

 

Edit: It seems the thing that did it was that I had no empty slot in the group at the time - simple being in the rooster causes them to become silent.

 

Edit2: I have the last patched game on Steam

Edited by Azradun

Share this post


Link to post
Share on other sites
  • 0

This bug has been plaguing the game since day 1 and still remains unfixed.

 

It's a serious flaw that breaks immersion and ruins custom parties. 

 

Pity it doesn't seem to be high on the devs' fix list (they acknowledged the bug's existence in a recent hotfix, but did nothing about it).

Share this post


Link to post
Share on other sites
  • 0

Yes, just read the newly published notes for 1.04:

 

  • Sound Sets from hired companions will now be properly restored when adding them to the party from the stronghold.

Share this post


Link to post
Share on other sites
  • 0
Guest Matt Sheets

Did you have the adventurer's in the Stronghold for 1.03 and then pulled them out for 1.04?

 

We fixed the issue so if you have an adventurer with a voice set and you put them in the Stronghold, they won't lose their voice sets but we're working on the ability to be able to update voice sets at any time for our next patch.  When that change gets in, you'll be able to set the voice set yourself.

 

Thanks,

 

Matt

Share this post


Link to post
Share on other sites
  • 0

Did you have the adventurer's in the Stronghold for 1.03 and then pulled them out for 1.04?

 

We fixed the issue so if you have an adventurer with a voice set and you put them in the Stronghold, they won't lose their voice sets but we're working on the ability to be able to update voice sets at any time for our next patch.  When that change gets in, you'll be able to set the voice set yourself.

 

Thanks,

 

Matt

Fresh game started yesterday.  Custom party member's voices disappeared after dismissing and recalling party members in different inns.

Edited by L9000

Share this post


Link to post
Share on other sites
  • 0

I can confirm the bug was not fixed. Lost voice sets on adventurers recruited both before and after I installed 1.04.

Edited by norolim

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...