Jump to content

Welcome to Obsidian Forum Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

Recruited adventurers lose their voice when dismissed

voice sound adventurers companions

  • Please log in to reply
9 replies to this topic

#1
Naborg

Naborg

    (0) Nub

  • Initiates
  • 1 posts
  • Steam:riddarn_bg

Whenever you dismiss your custom made recruited adventurer in your stronghold, they lose their voice when you recruit them again. Happened to both of my custom companions :(

 

Is there a workaround/fix for this?



#2
Azradun

Azradun

    (2) Evoker

  • Members
  • 53 posts
  • Location:Poland

Whenever you dismiss your custom made recruited adventurer in your stronghold, they lose their voice when you recruit them again. Happened to both of my custom companions :(

 

Is there a workaround/fix for this?

 

 

It also seems to influence new custom made recruits, as I have made three of them just a moment ago for testing, and none had a voice. It's irritating, since I have two of them in my group.

 

Edit: It seems the thing that did it was that I had no empty slot in the group at the time - simple being in the rooster causes them to become silent.

 

Edit2: I have the last patched game on Steam


Edited by Azradun, 11 April 2015 - 08:55 AM.


#3
Lord Vicious

Lord Vicious

    (2) Evoker

  • Members
  • 65 posts

This bug has been plaguing the game since day 1 and still remains unfixed.

 

It's a serious flaw that breaks immersion and ruins custom parties. 

 

Pity it doesn't seem to be high on the devs' fix list (they acknowledged the bug's existence in a recent hotfix, but did nothing about it).



#4
Matt516

Matt516

    (8) Warlock

  • Members
  • 1159 posts
  • Steam:Pungent Raindeer King
  • Pillars of Eternity Backer
  • Kickstarter Backer
  • Lords of the Eastern Reach Backer

I think that fix is coming up, no? Was it not in patch 1.04? If not, surely 1.05...



#5
Lord Vicious

Lord Vicious

    (2) Evoker

  • Members
  • 65 posts

Yes, just read the newly published notes for 1.04:

 

  • Sound Sets from hired companions will now be properly restored when adding them to the party from the stronghold.


#6
Striped_Wolf

Striped_Wolf

    (3) Conjurer

  • Members
  • 120 posts

I just got 1.04 0540

And this issue was now introduced for me.
 



#7
L9000

L9000

    (0) Nub

  • Initiates
  • 3 posts

I just got 1.04 0540

And this issue was now introduced for me.
 

Same here. 



#8
Guest_Matt Sheets_*

Guest_Matt Sheets_*
  • Guests

Did you have the adventurer's in the Stronghold for 1.03 and then pulled them out for 1.04?

 

We fixed the issue so if you have an adventurer with a voice set and you put them in the Stronghold, they won't lose their voice sets but we're working on the ability to be able to update voice sets at any time for our next patch.  When that change gets in, you'll be able to set the voice set yourself.

 

Thanks,

 

Matt



#9
L9000

L9000

    (0) Nub

  • Initiates
  • 3 posts

Did you have the adventurer's in the Stronghold for 1.03 and then pulled them out for 1.04?

 

We fixed the issue so if you have an adventurer with a voice set and you put them in the Stronghold, they won't lose their voice sets but we're working on the ability to be able to update voice sets at any time for our next patch.  When that change gets in, you'll be able to set the voice set yourself.

 

Thanks,

 

Matt

Fresh game started yesterday.  Custom party member's voices disappeared after dismissing and recalling party members in different inns.


Edited by L9000, 16 April 2015 - 06:42 PM.


#10
norolim

norolim

    (4) Theurgist

  • Members
  • 229 posts
  • Pillars of Eternity Backer
  • Kickstarter Backer

I can confirm the bug was not fixed. Lost voice sets on adventurers recruited both before and after I installed 1.04.


Edited by norolim, 29 April 2015 - 09:56 AM.






Also tagged with one or more of these keywords: voice, sound, adventurers, companions

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users