Jump to content
  • 0
LiquidThunder

[issue] Scrolling with dual-monitors

Question

So far, I am loving this game.  However, one problem did jump out at me at the start.  I use a dual-monitor set up and unlike in most games, having Pillars of Eternity full-screen does not appear to "lock" my cursor on to my left screen (where I play my games).  This makes it very difficult, if not impossible, to scroll right by moving my cursor to the edge of the screen as it simply moves into my other monitor.

 

This is a rather minor issue, but I would greatly appreciate it if it was fixed at some point.  Thanks!

  • Like 3

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Hi LiquidThunder, we have a Cage Cursor function in Game Options > Graphics.

 

Also as an ease of use tip, you can use the middle mouse button to drag the camera for quicker more precise control.

 

Thanks!

  • Like 2

- Refer to this thread if you are having trouble finding any information I requested http://forums.obsidi...eport-an-issue/

Share this post


Link to post
Share on other sites
  • 0

Hi LiquidThunder, we have a Cage Cursor function in Game Options > Graphics.

 

Also as an ease of use tip, you can use the middle mouse button to drag the camera for quicker more precise control.

 

Thanks!

That's not working for me on Linux.  I've tried turning it off and on multiple times.

Share this post


Link to post
Share on other sites
  • 0

Hi LiquidThunder, we have a Cage Cursor function in Game Options > Graphics.

 

Also as an ease of use tip, you can use the middle mouse button to drag the camera for quicker more precise control.

 

Thanks!

Hey,

 

It's that setting that is bugging out, at least for me. Regularly I need go into Options and toggle it off and back on so cursor stays caged.

 

There isn't any clear trigger for bug as I have gotten it after random conversation, after random battle, during exploring etc. It just stops working and cursor goes wandering to 2nd monitor. Then I need go toggle setting off and back on to prevent cursor from wandering to 2nd monitor.

 

Edit: Running game through Steam on W8.1

Edited by Tovarisc
  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Cage Cursor does not always work properly.  I have the option enabled but it has only worked one time.  Most of the time (3 hours by Steam counting) it has not worked.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Hi LiquidThunder, we have a Cage Cursor function in Game Options > Graphics.

 

Also as an ease of use tip, you can use the middle mouse button to drag the camera for quicker more precise control.

 

Thanks!

 

Middle Mouse Button is good to know, but the Cage Mouse function is NOT working for Dual Screen monitors either.

Share this post


Link to post
Share on other sites
  • 0

I am having the same issue with cage cursor being buggy.  It will work for awhile and then just stops working and I have a heck of time scrolling since it keeps wanting to go over onto my other monitor.  I have not narrowed down what causes this but I will keep an eye out to see if I can figure it out.

 

Besides that I have had no other issues with the game and I am absolutely loving it!

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

We are now aware of an issue causing the Cage Cursor option to stop functioning. I've added it to our database and sent it off to be looked at.

We are still trying to hammer out 100% repro steps at the moment and any help would be greatly appreciated. 

 

I've had the most luck reproing this issue by alt+tabbing during loading screens, what have you guys been doing?

 

Thanks!

  • Like 1

- Refer to this thread if you are having trouble finding any information I requested http://forums.obsidi...eport-an-issue/

Share this post


Link to post
Share on other sites
  • 0

This keeps happening to me no matter what I'm doing.

 

Battle Starts -> Stops working

Battle Ends -> Stops working

Conversation -> Stops working

Exploring -> Stops working at random times

Opening any Character Tab -> Stops working

 

It's not gamebreaking by any means but it's a little annoying.

  • Like 1

"How was I supposed to know it was that stone that held the dragons at bay... I mean it just stood there looking dull anyway"

Share this post


Link to post
Share on other sites
  • 0

Gah...

 

I reported this issue two or three beta revisions ago. Annoying it wasn't already in the bugbase.

 

I've found that toggling cage cursor isn't necessary to (temporarily) fix it for me. Just alt-tabbing to desktop and back will reset the cage.

Edited by Flow
  • Like 1

Share this post


Link to post
Share on other sites
  • 0

I too am having the same issue with the cage cursor. Its seems that every time I enter a map the game "forgets" I have enabled caged cursor. I have to disable and re-enable the caged cursor option for it to work properly once again. 

Share this post


Link to post
Share on other sites
  • 0

I reported this in the last backer beta, for me It happens when I alt-tab on loading screens, alt-tab and don't click IN the game window, but on the border and sometimes when I load a save.

 

Alt-tabbing in and out doesn't work for me - have to untick and re-tick the option.

Edited by Sensuki

Share this post


Link to post
Share on other sites
  • 0

We are now aware of an issue causing the Cage Cursor option to stop functioning. I've added it to our database and sent it off to be looked at.

 

We are still trying to hammer out 100% repro steps at the moment and any help would be greatly appreciated. 

 

I've had the most luck reproing this issue by alt+tabbing during loading screens, what have you guys been doing?

 

Thanks!

 

Ok this just happened again for me.  Been playing quite awhile with no issues and came across a scripted event where some townsfolk talk to you.  Once the event was done the cage cursor was broke.  I had to go into settings uncheck, save, go back into settings and re-check and save.

Share this post


Link to post
Share on other sites
  • 0

This also occurs to me pretty much constantly. It seems to happen the most reliably after a conversation - the option will cease working unless I turn it off and back on, OR change another option which causes the settings to be saved (e.g. changing scroll speed). I haven't tried alt-tabbing to get the cursor cage to work again, will see if that works.

Share this post


Link to post
Share on other sites
  • 0

Hello, just adding to the voices of others.

 

Confirming that it happens when any dialogue is opened, also any menu access, and upon battle starting and ending.

 

Glad to see this is being looked at, loving the game so far, don't want this to detract from the experience!

Thanks!

Share this post


Link to post
Share on other sites
  • 0

One way I have found that lets me temporarily fix this issue to is set the resolution to a different size in the game, then set it back.  This generally works until whatever is triggering it to fail in the first place happens again.

Share this post


Link to post
Share on other sites
  • 0

Cage cursor works until a forced conversation or cut scene activates and then it stops working..... If you turn it off close out of the options then turn it back on it works until the next forced convo/cut scene/animation

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Cage cursor works until a forced conversation or cut scene activates and then it stops working..... If you turn it off close out of the options then turn it back on it works until the next forced convo/cut scene/animation

 

This is exactly what I am experiencing and the only time it appears to break.

Share this post


Link to post
Share on other sites
  • 0

Is there any way to force the game to use a real fullscreen mode instead of the borderless window mode it uses by default?

 

Reason: I might want to use DSR (Dynamic Super Resolution) and/or GSync. Both of which are only available in fullscreen mode. 

Share this post


Link to post
Share on other sites
  • 0

Cage cursor works until a forced conversation or cut scene activates and then it stops working..... If you turn it off close out of the options then turn it back on it works until the next forced convo/cut scene/animation

Seems to be the case for me.

 

Cage Cursor not working is really, really, really annoying.

 

Edit: OK  so I load the game (Win7 64bits, mixed resolution dual screen, display through latest stable AMD Omega drivers)), click Continue, Appear at my last save (in the street, doing nothing) and Cage Cursor does not work. I have to go into options, disable it and re-enable it to make it work a little while. I Alt tab to write this message and Cage Cursor still works, for now.

Edited by BlackyNoir

Share this post


Link to post
Share on other sites
  • 0

+1 on this.

Only played for an hour yesterday but this happened from the beginning.

Caged cursor didn't work at all for me.

Win7 64Bit, Nvidia 540m GPU, 16GB Ram, Asus N53SV Laptop with screen connected via VGA port.

Share this post


Link to post
Share on other sites
  • 0

Same issue as those above. Cage cursor option only appears to work until I enter dialogue, combat, leave combat, ect. 

 

Windows 7, 64bit

Intel i3-2120 CPU

8GB RAM

NVIDIA GeForce GTX 560 Ti

Share this post


Link to post
Share on other sites
  • 0

I'm having the same issue. It appears to work on the main menu screen, but not work within actual gameplay.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...