Jump to content

Low framerates on 8800 GT


Recommended Posts

Hi all!

 

I have this computer: (copy from everest)

 

Computer

Computer Type ACPI x86-based PC

Operating System Microsoft Windows Vista Ultimate

OS Service Pack -

Internet Explorer 7.0.6000.16546

DirectX DirectX 10.0

Date / Time 2007-12-05 / 17:24

 

Motherboard

CPU Type DualCore Intel Core 2 Duo E4500, 2800 MHz (11 x 255)

Motherboard Name Asus P5K (3 PCI, 2 PCI-E x1, 2 PCI-E x16, 4 DDR2 DIMM, Audio, Gigabit LAN, IEEE-1394)

Motherboard Chipset Intel Bearlake P35

System Memory 2048 MB (DDR2-800 DDR2 SDRAM)

BIOS Type AMI (06/22/07)

Communication Port Communications Port (COM1)

 

Display

Video Adapter NVIDIA GeForce 8800 GT (512 MB)

Video Adapter NVIDIA GeForce 8800 GT (512 MB)

3D Accelerator nVIDIA GeForce 8800 GT

Monitor Samsung SyncMaster 717MB/757MB/MagicSyncMaster CD177D(P) [17" CRT] (HVDWA36302)

 

Multimedia

Audio Adapter Realtek ALC883 @ Intel 82801IB ICH9 - High Definition Audio Controller

 

Storage

IDE Controller Intel® ICH9 2 port Serial ATA Storage Controller 1 - 2921

IDE Controller Intel® ICH9 2 port Serial ATA Storage Controller 2 - 2926

Storage Controller JMicron JMB36X Controller

Storage Controller Microsoft iSCSI Initiator

Disk Drive SAMSUNG HD501LJ ATA Device (500 GB, 7200 RPM, SATA-II)

Disk Drive SAMSUNG SP2504C ATA Device (250 GB, 7200 RPM, SATA-II)

Optical Drive PIONEER DVD-RW DVR-108 SCSI CdRom Device (DVD+R9:4x, DVD+RW:16x/4x, DVD-RW:16x/4x, DVD-ROM:16x, CD:32x/24x/40x DVD+RW/DVD-RW)

SMART Hard Disks Status OK

 

Partitions

C: (NTFS) 476937 MB (271961 MB free)

D: (NTFS) 238472 MB (7911 MB free)

Total Size 698.6 GB (273.3 GB free)

 

I have the latest driver, i applied kotor 2 official patch, i tried swkotor2.ini hack, the problem is, sometimes i have framerate slowdowns, i attached some schreenshot, so you can see it, i use v-sync on. This is the first level. You can see, if i stand in front of that place, frame rate is between 10-30, but other time, always 70-85. I tried disable aniso filtering, and anti aliasing, but it didn't affect the frame rate. I tried every combination in Nvidia control panel setting, nothing helped :blink: I think i have high end pc, i can run most modern games at very high graphic setting, even Crysis playable at very high detail, but K.O.T.O.R. 2 isn't :)

I read Intel dual core thread here, but it didn't help either.

 

Do you have any suggestion, what should i do now, or what the problem is?

Any help is greatly appreciated.

 

post-22680-1196872150_thumb.jpg

post-22680-1196872157_thumb.jpg

post-22680-1196872164_thumb.jpg

Link to comment
Share on other sites

"Size means nothing to the Force!"

 

It's probably due to the dual core processor rather than the 8800GT. Try setting CPU affinity for 1 on task manager. Since I don't have a dual core processor (yet) I'm not sure what else you could try. Someone in here should be able to offer you more help.

Link to comment
Share on other sites

It's probably the volumetric fog that just wasn't well optimized. Try getting closer to one of the other clouds and see what happens.

"My hovercraft is full of eels!" - Hungarian tourist
I am Dan Quayle of the Romans.
I want to tattoo a map of the Netherlands on my nether lands.
Heja Sverige!!
Everyone should cuffawkle more.
The wrench is your friend. :bat:

Link to comment
Share on other sites

First of all, thanks for the quick responses!

 

I tried what you told to me. I already tried CPU affinity, but i tried it once again :lol:

Here are the results:

 

Volumetric fog closely:

 

post-22680-1196889054_thumb.jpg

 

This orange glassy thing made 17 fps :lol:

 

post-22680-1196889069_thumb.jpg

 

Another fog:

 

post-22680-1196889083_thumb.jpg

 

Another orange glassy object, with normal fps

 

post-22680-1196889100_thumb.jpg

 

Same place, but this time, i turned off a core, in CPU affinity settings

 

post-22680-1196889111_thumb.jpg

 

So, i really don't understand it. If anyone can try it at the same place(i am at the mines, at the first level, after i met the guy) it would be a great help! Or if you have another idea, please tell me

Link to comment
Share on other sites

Try turning off V Sync, but I really have no idea, and find this extremely odd...

"My hovercraft is full of eels!" - Hungarian tourist
I am Dan Quayle of the Romans.
I want to tattoo a map of the Netherlands on my nether lands.
Heja Sverige!!
Everyone should cuffawkle more.
The wrench is your friend. :bat:

Link to comment
Share on other sites

Just play the game. 15 fps at a few rare locations isn't all that important in a game like KOTOR2.

"My hovercraft is full of eels!" - Hungarian tourist
I am Dan Quayle of the Romans.
I want to tattoo a map of the Netherlands on my nether lands.
Heja Sverige!!
Everyone should cuffawkle more.
The wrench is your friend. :bat:

Link to comment
Share on other sites

I tried Nvidia newest 169.12 driver, it didn't change anything.

I overclock my processor, so i tried the run on base frequency. It made it worse :lol:

I think, the problem is with the game engine. If you remember kotor 1, on Dantooine, it was so slow, i couldn't do anything. I'm still curious if anyone has the same problem, at the same place, it would be appreciated if anyone else can post screenshots too.

Link to comment
Share on other sites

It depends on the type of compter you use. There are many different types of compters.

"My hovercraft is full of eels!" - Hungarian tourist
I am Dan Quayle of the Romans.
I want to tattoo a map of the Netherlands on my nether lands.
Heja Sverige!!
Everyone should cuffawkle more.
The wrench is your friend. :bat:

Link to comment
Share on other sites

Kotor and Kotor2 have a really bad way of rendering smoke. It does so by using the CPU instead of the GPU, which is made for tasks like that. The best thing you could try is shutting one core off, add the "Disable Vertex Buffer Shaders=1" line at the correct place, and then hope for the best...

^

 

 

I agree that that is such a stupid idiotic pathetic garbage hateful retarded scumbag evil satanic nazi like term ever created. At least top 5.

 

TSLRCM Official Forum || TSLRCM Moddb || My other KOTOR2 mods || TSLRCM (English version) on Steam || [M4-78EP on Steam

Formerly known as BattleWookiee/BattleCookiee

Link to comment
Share on other sites

Kotor and Kotor2 have a really bad way of rendering smoke. It does so by using the CPU instead of the GPU, which is made for tasks like that. The best thing you could try is shutting one core off, add the "Disable Vertex Buffer Shaders=1" line at the correct place, and then hope for the best...

 

That did fix Dantooine for me before


 

Link to comment
Share on other sites

Thanks for all help again. I put Disable Vertex Buffer Shaders=1 in swkotor2.ini after [Graphics Options], but it didn't change anything. If you would like, i can post another screenshots.

Cpu affinity setting make the entire game so slow, it ruins the game. Unfortunately it doesn't help here :thumbsup:

 

I discovered something new, if i change swkotor2.exe priority to realtime, it runs a better than in normal mode. The place, where i made the screenshots, it still have low framerate, but it doesn't lock the graphics like in normal priority.

 

This lock, if you want to imagine, it's like, the animation stops for a moment, when you move the came, it's not continuous. If i change priority to realtime, this lock disappear, i still have 20-30 fps at certain place(example: screenshot), but it's continuous

Edited by hondala
Link to comment
Share on other sites

Hi all again!

 

I didn't give up, i tried several things today. I though, i made something in the wrong way. So i tried different applications, for example: Sysinternals ProcessXP. I tried this cpu affinity settings, however i didn't believe that it would work, because i tried cpu affinity several times. ProcessXP didn't help at the 1st time, but second time, by accident, i set affinity at the beginning after i launched swkotor2.exe. I always tried affinity settings, when i was inside the game.

 

It worked :grin: I got constant 40+ fps at the place, where you can see 20 fps.

 

So i tried to run this way again, i couldn't, it didn't work :) I looked for another method to start swkotor2.exe with only 1 core. So i googled, and i found this software: Get and Set CPU Affinity

This program can run programs with 1 core, from the beginning, and this is what kotor2 needs for dual core processors :)

It solved all my problems i think.

If anyone has the same problem, try this program, set swkotor2.exe cpu affinity, check auto set affinity, and run kotor2

I never thought, i have to set affinity from the program start, i though, if i set inside i game is enough, i was wrong, but fortunately here is the help.

 

Thanks for all help again!

Link to comment
Share on other sites

Thanks for posting the solution when you found it - a lot of people forget to do that, but it really helps the community and future visitors. :grin:

 

The link in your post is broken - I'm assuming you're talking about this site. I notice they don't recommend using their software with Vista - has that been a problem for you at all?

"An electric puddle is not what I need right now." (Nina Kalenkov)

Link to comment
Share on other sites

They don't recommend it, but it works perfectly with Vista, since i use it, i don't notice any slowdowns, it's perfect :) Maybe the writer of the program though, on XP works perfectly with all software, but Vista has some problems with some program. The most important thing is, it works with Kotor2. i don't use it with any other software :)

Sorry for broken link, it seemed to work in preview, i forgot to check it after post :)

 

This is the link: http://www.geocities.com/edgemeal_software...inity/index.htm

Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...