Jump to content

Pure Pazaak

Recommended Posts

As a matter of fact ... I have o:)


The problem is that Vista does not come shipped with DirectX 8, which is what Pure Pazaak and a lot of other homemade VB games use for sound.


Here are the steps if you want to play it in Vista.

1. Google up and download dx8vb.dll

2. If you are on Vista 32-bit (most would be I'm assuming), then copy it to Windows\System32, and run "regsvr32 dx8vb.dll". If you are on Vista 64-bit then use the Windows\SysWOW64 folder instead.


If you don't understand this then just do some quick searching. You'll probably come across more detailed instructions on how to "install" this file when you search it up to download anyway.


*** This is in violation of the EULA. Microsoft takes no responsibility blah blah blah ***




As a general post/update, about a month before I started fulltime work, I got "semi-motivated" to do a bit of a PP revamp with some changes. At this stage don't expect anything yet though. I'm still settling down to working life, etc. and yet to get normal/regular free time where I can game or work on Pazaak, etc. o:)

Had some big changes in mind too; perhaps too big/too many which might make it never happen overall:

- automatically temporarily register the above file so it works with Vista. For those wondering I still standby my decision not to use those VB installer packages/deployers you can use. I hate installers for things that don't need installing! :down:

- change campaign mode where you "clean out" your opponent instead

- (toughest/most impossible) Multiplayer server game program (think Game lobby, etc.) so still uses DirectIP/Winsock, but it goes through the server.

- On a similar vein, more than 2 players in a match, i.e. observer mode.


Pure Pazaak - The Stand-alone Multiplayer Pazaak Game (link to Obsidian board thread)

Pure Pazaak website (big thank you to fingolfin)

Link to comment
Share on other sites

  • 2 months later...

I hate to be a nuisance, but I am having a problem...


I'm trying to play Pazaak with one of my friends, and we cannot establish a connection. On his side, it will not let him click the host button. On my side, when I try to host, he gets the following error:


Connection Problem (Err No: 10061 - Connection is forcefully rejected)


I've tried both forwarding the 6000 port to my PC, and I have also tried using the router's DMZ option to this PC's internal network IP address. I can't figure it out... I can get a connection between any of my other LAN computers using the internal IP's and this one, but people cannot connect to this or any other PC on my LAN from the internet. I even tried disabling my firewall for this test, with no effect. When I try to connect through the external IP from one of my LAN computers, I get the same error. Any ideas on how to fix the problem? All of the computers in question are running XP SP2, and the most current version of Pure Pazaak. Is there another port I have to forward besides 6000?

Link to comment
Share on other sites

  • 1 month later...


How're you!? ^^

I introduce myself, im JBantha, and i'm from Costa Rica...

look, i been playing Pazaak since kotor, me and my frinds even print the cards and i play it online since the second version of Pure Pazaak but here in costa rica almost nobody playes it besides me! T_T

SO.... is there somewhere or somehow where I can find another players online either for Pure Pazaak or Pazaak Cantina... i think like a forum or a "Find a opponent" button or somethig?! T_T


thank you1 ^^

Link to comment
Share on other sites

  • 2 weeks later...

I seem to be having some trouble, you see. I have done everything as the .readme file commands. And yet every time I try to run the program, it tell me this: Could not find file sounds/accept.wav.


And before that, it told me that MCWINSCK.OCX was misplaced, or something like that.


Any help would be appreciated.

Link to comment
Share on other sites

  • 2 months later...
  • 1 month later...

I downloaded this almost a year ago, but after that my computer crashed and I had to get a new one. I'm only recently getting interested in playing pazzak again but every time I click on the link to the website I get an error page just as fast as if I wasn't connected to the internet. Since everything else works fine it isn't that, but I would like to know why I can't get to the website on all three of my browsers.

Link to comment
Share on other sites

  • 1 month later...

Hey guys, I have found a working link for v.1.2.4, it took a little searching but here it is:




And I've got PP to work on Vista, however, none of the images show. I tried the comctl32 fix, but it still doesn't work.


EDIT- Never mind, running it as an Administrator fixed that.

Edited by Karlika
Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

How to get Pure Pazaak to work on Windows Vista 32 Bit


Since everyone seems to still be a little lost i will try and clear it up for anyone who doesn't understand. It is only fair that everyone can enjoy this incredibly made game. Thank you Dufflover for giving us Pure Pazaak!


I am assuming you already have downloaded the game and you are getting a number of errors. Dont worry yet. Heres what you need to do.


Step one: Download "dx8vb.dll" found here: http://www.dlldump.com/download-dll-files_...0/download.html


Step two: Move the dll file into your System32 folder. Located in your Windows folder.


Step three: run "regsvr32 dx8vb.dll"


However it must only be done this way...


Click Start > Start Search, type cmd


You'll find command prompt at the top of the start menu now, right click it and choose Run as Administrator


Now type in "regsvr32 dx8vb.dll" in the cmd and press Enter.


Step four: Find PurePazaak.exe and RUN AS ADMIN. Otherwise you will get limited textures.


Step five: Enjoy :-

Link to comment
Share on other sites

I did exactly what you said and, when I was in regsvr, it gave me this error:


"The module 'dx8vb.dll' was loaded but the call to DllRegisterServer failed with error code 0x8007005. For more information about this problem, search online using the error code as a search term."


Then, when I tried to run Pure Pazaak as admin, it said:


"Run-time error '429': ActiveX component can't create object"


That was on my mom's x32 Vista. How can I get it to work on her x32 vista and my x64 Vista computer?

Link to comment
Share on other sites

  • 4 weeks later...
  • 11 months later...

I've downloaded it and couldn't get the thing to run. Something about the .ocx not running. I've checked and it is apparently an activeX control. But I can't see what to do next.

"It wasn't lies. It was just... bull****"."

             -Elwood Blues


tarna's dead; processing... complete. Disappointed by Universe. RIP Hades/Sand/etc. Here's hoping your next alt has a harp.

Link to comment
Share on other sites

Awesome application! A million 'thank you's to those who worked on it!



I'm not sure if anyone is making any sort of adjustments at this point, but...One thing I noticed that I think might be a bug. The green 1+-T card doesn't give you the win over the tie when it is played as a minus 1, only when played as an add 1.

Link to comment
Share on other sites

  • 8 months later...
  • 3 years later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...