Jump to content
  • 0
Loub

[1.2] Behavior Editor is Broken

Question

The latest patch seems to have introduced a myriad issues with the Behavior Editor subwindows in the game, making it impossible to customize any aspect of AI behavior through them.

 

What happens is as follows:

 

-Bringing up conditions or ability triggers in the Behavior Editor brings up the subwindows as it should, however, they are 100% uninteractable, clicking anything in them (even the "cancel button) does absolutely nothing - the only way to close them is pressing "Esc".

-Additionally, clicking anywhere where there should be another trigger for bringing up conditions or ability triggers will spawn duplicate subwindows, which can only be closed by pressing "Esc".

 

The following images should help describe what happens more accurately:

vDck4Nk.jpg- One cannot interact in any way with this subwindow, not even mousescrolling works, additionally, clicking anywhere in the screen where there would be another subwindow spawn will result the following:qTVo2fC.jpg

-Which results in two or more overlapping, uninteractable subwindows which won't go away in any manner aside from Escing.

 

This bug was tested, reported and reproduced in both the Beta and Live versions of Patch 1.2, no mods installed, on a clean installation of the game. Verifying the game installation showed no issues, and reinstalling did not fix it either.

  • Like 1

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

Subbed.


"Time is not your enemy. Forever is."

— Fall-From-Grace, Planescape: Torment

"It's the questions we can't answer that teach us the most. They teach us how to think. If you give a man an answer, all he gains is a little fact. But give him a question, and he'll look for his own answers."

— Kvothe, The Wise Man's Fears

My Deadfire mods: Brilliant Mod | Faster Deadfire | Deadfire Unnerfed | Helwalker Rekke

Share this post


Link to post
Share on other sites
  • 0

oh my god i thought it was just me. i didnt mess with the behavior editor until 1.2 and now its all broken :( Thank you for posting this

Share this post


Link to post
Share on other sites
  • 0

Damn, I also have this bug as well... it's really annoying. Someone also post this bug when 1.2 is still Beta and yet they haven't solved it... Someone also post this bug on Steam Discussion. It's really annoying since this Custom AI is one of my favorite features.

Share this post


Link to post
Share on other sites
  • 0

I normally don't pay attention to the forums of anything, but thought this one was important to be a part of so it gained notice. I just leveled up my character and went to setup her new ability, when low and behold I experienced this behavior window bug that everyone else is reporting.

 

This is a major issue as I heavily use the behavior editor. Until this is fixed it's virtually pointless to level up my characters as they won't be using any new abilities I give them. Very surprised to see a bug of this size being pushed to the live version.

 

On a related note, prior to this patch I also had a more minor issue with the behavior editor. When opening the window to select an ability, if I right clicked it in the window to see the detailed information on it, the new window would have the text from the previous window bleed through it, making the new window unreadable.

Share this post


Link to post
Share on other sites
  • 0

Also i think auto attacking is busted too. You have to tell companions to attack after every little thing they do or they just sit there chilling

Share this post


Link to post
Share on other sites
  • 0

Also i think auto attacking is busted too. You have to tell companions to attack after every little thing they do or they just sit there chilling

 

Do they have gear icons over their heads while they're "chilling"? If so that's been happening since launch, and very disappointing it hasn't been fixed yet.

Share this post


Link to post
Share on other sites
  • 0

For those who has this bug, you could try to access the Custom AI Screen directly, by right-clicking the icon on the bottom left of the screen (three icons where you could choose between AI: Off, Auto Attack Only, and Custom AI), not from Character Sheet or Inventory Screen.

 

I just tried that and it works. I just remembered that the character sheet is sometimes broken by not showing attribute breakdown.

 

If you guys could also do this than the real culprit is the menu screen which can't deliver AI screen correctly.

Edited by zilbest
  • Like 3

Share this post


Link to post
Share on other sites
  • 0

For those who has this bug, you could try to access the Custom AI Screen directly, by right-clicking the icon on the bottom left of the screen (three icons where you could choose between AI: Off, Auto Attack Only, and Custom AI), not from Character Sheet or Inventory Screen.

 

I just tried that and it works. I just remembered that the character sheet is sometimes broken by not showing attribute breakdown.

 

If you guys could also do this than the real culprit is the menu screen which can't deliver AI screen correctly.

That totally works!  You are the best!

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

For those who has this bug, you could try to access the Custom AI Screen directly, by right-clicking the icon on the bottom left of the screen (three icons where you could choose between AI: Off, Auto Attack Only, and Custom AI), not from Character Sheet or Inventory Screen.

 

I just tried that and it works. I just remembered that the character sheet is sometimes broken by not showing attribute breakdown.

 

If you guys could also do this than the real culprit is the menu screen which can't deliver AI screen correctly.

Thank you for this post. I have this issue entered seeing it reported by others, but this helps greatly while we look for a fix in a future patch.

 

Best Regards,

 

-Caleb

  • Like 1

I like big bugs and I cannot lie...

Share this post


Link to post
Share on other sites
  • 0

I think here is the appropriate place to post this, since I can't find anything related to this and I think it might be connected to the AI behaviour (though not the Custom AI per se).

 

Since I can't figure out how to cast specific spells on specific characters using the custom AI thing (is that even possible? I would like if it was), I'm casting certain buffs every fight. I noticed a problem (not all the time but frequent enough that I'm now micromanaging that character with every cast of that buff to be sure it doesn't fail) with Xoti (probably Priest in general, I don't know, haven't tested) and the casting of Champion's Boon (I haven't noticed this problem with any other spell).

 

Selecting Xoti and casting Champion's Boon on another character will very often fail, and she will end up casting on herself with no warning or indication as to why. She starts casting on someone else and when the spell is "launched" it "lands" on her instead of the target.

I thought it might be an issue with the target moving out of the spell range, but it happened a few times when the target character was stationary and right next to her.

 

Again, just this spell has this weird glitch. It seems to not happen if I stay on Xoti, with her selected, until the spell cast is finished.

 

It seems weird and oddly specific, so apologies if this is not a bug and I'm missing something or if it doesn't qualify for reporting.

 

Cheers!

Edited by Kian

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...