Jump to content
  • 0
Arsene Lupin

CONSTANT RANDOM CRASHES -- An Unplayable Game

Question

CONSTANT RANDOM CRASHES -- An Unplayable Game
 
Hello Obsidian. I am revising this post because the "bug" I originally wrote about is much, much worse than I originally thought. I am getting constant random crashes. They occur 100% of the time. They make the game completely unplayable. If the opening PoE1 recap isn't skipped, the game will freeze/crash before the introduction cinematic (narrated by Eder) can play. If I skip the recap, the intro movie plays (Deadfire has not yet crashed mid-intro) and the first area--the In Between--loads and the game appears playable and stable. However it will always freeze/crash before the Watcher/Soul character makes it all the way to the Adra Pillar at the far right of the screen. Often the audio will cut-out, or seem to, a few moments prior to the freeze/crash. Exactly one time an audio line played to the end after the game froze, however.
 
I have attempted everything I can possibly do on my end to diagnose and/or workaround the problem, including but not limited to:
 
  • Windows compatibility mode (Win7, Win8, even WinXP) settings.
  • Administrator privileges off/on.
  • Countless possible Deadfire configurations--windowed, fullscreen, every quality preset, every available resolution, multiple vfx enabled/disabled combination. The gamut.
  • Steam did, of course, verify the integrity of the game cache.
  • I also redownloaded the game, multiple times, after manually purging it from my system (not a fun thing to do when you suffer from bandwidth caps)
  • Oh, and I've also tried running the game off of an SSD, off an HDD, from the default Steam install directory and from a unique Steam install directory.
 
I was able to get the game to run off of an old laptop, with an integrated GPU, albeit very poorly (10fps are far from optimal; combat is impossible) that doesn't even come close to the minimum recommended specs... but it doesn't crash. Using Steam cloud saves to load saves from the laptop to my PC (in the starting island, the world map and inside the cave) and... you guessed it, Deadfire still crashes on me, usually a few seconds after loading up the area. Sometimes I have time to move my party, but the game usually crashes before anyone can make a it a half-dozen steps.
 
To be perfectly honest, I've been a PC gamer for a very long time and I haven't had this much trouble with a game since I bought a copy of Daikatana out a bargain bin for $0.99, and that game was quickly re-purposed into a Frisbee.
 
My PC specs are as follows:
  • 3.55ghz quad-core i5 CPU
  • 16gb memory
  • 2gb HD6870 GPU
  • Windows 10 x64

 

(Note that this is a PC that ran Pillars of Eternity perfectly. And also note, as I've proved, that Deadfire is capable of running on a toaster.)

 

My working theory is that this may be a compatibility problem between whichever version of Unity Deadfire is using and my GPU drivers, but only because ATI drivers are typically the cause of my headaches (whenever I upgrade, I'm going nVidia and never touching ATI again). But at the same time, the game does load and appear to render properly, so I have no idea. No ideas, just lots of frustration.
 
 
....
 
NOTE I originally posted about this problem here, but am reposting it now because my initial assumptions about what was happening were incorrect. I will request moderators lock/delete the original thread.
 
....
 
EDIT1 I am experiencing greatly improved stability after patch 1.02. I can now play the game for 20 minutes--sometimes longer--before seeing a crash! And, now, when the game crashes a window pops up informing me of the creation of the output log, which is handy. I've attached the new output log file to this post.

output_log.txt

Edited by Arsene Lupin
  • Like 1

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Hi all I too was suffering from Pillars constant crashes, until I moved the game to my SSD HDD, the game now no longer crashes for me. I have been suffering these issues from day 1 and tried everything to resolve it. It seems that pillars is IO sensitive in some way. The following are my drive results (winsat):

 

Original drive:

 

> Disk  Random 16.0 Read                       1.51 MB/s          4.0
> Disk  Sequential 64.0 Read                   102.01 MB/s          6.6
> Disk  Sequential 64.0 Write                  97.94 MB/s          6.5
> Average Read Time with Sequential Writes     5.194 ms          5.9
> Latency: 95th Percentile                     36.850 ms          2.5
> Latency: Maximum                             124.570 ms          7.6
> Average Read Time with Random Writes         10.079 ms          4.5

 

 

SSD drive:

 

> Disk  Random 16.0 Read                       2.83 MB/s          4.5
> Disk  Sequential 64.0 Read                   106.30 MB/s          6.7
> Disk  Sequential 64.0 Write                  125.91 MB/s          7.0
> Average Read Time with Sequential Writes     4.141 ms          6.3
> Latency: 95th Percentile                     8.521 ms          5.9
> Latency: Maximum                             18.335 ms          7.9
> Average Read Time with Random Writes         4.223 ms          6.2

Share this post


Link to post
Share on other sites
  • 0

Game crashes at:

 

 

2019-02-18_161554 next to game executable

 

 

 

 

-common man! This group is level 20 maxed out, I finished this dungeon and tried 3x to exit this dungeon, but it always crashes!!! I don't know how to attach files but this is what the box says to report. 

Share this post


Link to post
Share on other sites
  • 0

I'm getting crashes every 15 minutes. I've been saving like crazy and rebooting my laptop to try to make a little bit of progress.

 

I've attached an example crash report from the latest one, caused by clicking on an Exceptional Rod in the party stash. 

 

It's possible that it's some problem with my laptop configuration, but I'm not sure where I would even begin to troubleshoot it. 

 

I'm going to take a break from the game in the hopes that a patch will fix this. 

2019-02-18_205844.zip

Share this post


Link to post
Share on other sites
  • 0

game still crashes same place:

 

2019-02-22-153814 near executable file.....

 

It seems they're more intent on getting turn base running rather than fixing all the crashes...As I paid a premium for this game it is very disappointing. At least with Origens Dragon Age you can call and talk to someone who will help you through the fix....here we are just left hoping for a patch........and waiting, and waiting.................

Share this post


Link to post
Share on other sites
  • 0

I'm getting crashes every 15 minutes. I've been saving like crazy and rebooting my laptop to try to make a little bit of progress.

 

I've attached an example crash report from the latest one, caused by clicking on an Exceptional Rod in the party stash. 

 

It's possible that it's some problem with my laptop configuration, but I'm not sure where I would even begin to troubleshoot it. 

 

I'm going to take a break from the game in the hopes that a patch will fix this. 

 

Following up on my earlier post. Uninstalling and reinstalling the game seems to have fixed my CTD problems. 

Share this post


Link to post
Share on other sites
  • 0

I have random crashes to report in.

They always lead to a hard reset, and sometimes i get a glimpse of Windows BSoD, I'm not sure but recalling the error name i'll guess it something like this whea_uncorrectable_error  the error is rarely seen.

For the trigger of this crashes ill be really vague about them since i don't know what triggers them, i can tell that Crookspur was terrible it cost me 7 hard resets or more and quit the game that day out of frustration.

Also did the old chants and dances we all know to no avail.

 

Now PC aspects:

 

Hardware:

CPU: AMD FX 8350.

MOBO: Asus M5A97PRO.

RAM: Corsair Vengeance DDR3 16GB 3200MHZ.

GPU: Radeon RX 480 8192 Mbb GDDR5.

ROM: HDD Seagate Barracuda 1TB and SSD Kingston 512GB.

 

Software:

OS: Windows 10 x64 Build 17134.

Running the game on Steam.

 

I can made my self clear that this is not an OS problem, since i use my PC for work most of the day and i never run on a BSoD.

This is really saddening, i find the game way better in general to the first one but this constants crashes are really mod dampening.

I'll wait for a future update that will reduce the amount of random crashes and for the time being i'll let the game on the shelf collecting dust and keep wondering what was Eothas doing with the Adra Giant of Caed Nua.

 

Otherwise seems like a really good game.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...