Jump to content

Welcome to Obsidian Forum Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

Loading screens a bit too often and too long - also cannot turn off Autosaves?

feedback immersion break

  • Please log in to reply
5 replies to this topic

#1
stage

stage

    (1) Prestidigitator

  • Members
  • 25 posts

Hello guys,

 

I kinda remember we could turn off Autosaves in PoE 1, and that helped with the loading times a bit. Is that still possible to make? As I cannot see any such options in the Settings.

 

Other that, as in the title of the thread - I feel that the loading screens are way too often and wait too long, and this really breaks my immersion. Even very small part of a house, loads for quite a while. Maybe I remember wrong, but the Areas in PoE 1 were  more big and open, so you really had more stuff to explore before having to load into anything.

 

Thanks for any input



#2
Havelok

Havelok

    (3) Conjurer

  • Members
  • 107 posts
  • Pillars of Eternity Backer
  • Kickstarter Backer
  • Deadfire Backer
  • Fig Backer

Easy fix for Load times is to install the game on an SSD. Load times will be atrocious in most games if you are still using an old hard drive. 



#3
rjshae

rjshae

    Arch-Mage

  • Members
  • 5055 posts
  • Location:Seattle, WA
  • Pillars of Eternity Backer
  • Kickstarter Backer
  • Deadfire Backer
  • Fig Backer

Load time is still fairly slow with an SSD; not horribly so, but definitely not speedy. The fade in/fade out is also pretty sluggish.



#4
anathanielh

anathanielh

    (5) Thaumaturgist

  • Members
  • 429 posts

So far all of my load times have been under 15-20 seconds on an SSD, so it’s not awful for me.

 

EDIT:

Timed the transitions between 10 different areas. Around 4-6 seconds. I vastly overestimated. 

Honestly, OP, I doubt turning off autosaves will help considering how quickly the game saves compared to PoE1, at least in my experience (Went from a 5 second screen freeze to no delay when quicksaving or regular saving at all)

Try providing your pc specs in tech support and see if that helps you out


Edited by anathanielh, 09 May 2018 - 09:59 PM.


#5
stage

stage

    (1) Prestidigitator

  • Members
  • 25 posts

So far all of my load times have been under 15-20 seconds on an SSD, so it’s not awful for me.

Not sure but am not talking about the main load to the Menu. And 15-20 seconds load between areas is ginormous.

Also please stop mentioning SSD's. That does not really solve any of the two points from the OP.

 

Also I finally got my flashbacks. We had to use a mod in PoE1 to disable the autosave. Cannot believe they still did not implement it in Deadfire.


Edited by stage, 09 May 2018 - 09:17 PM.

  • tinysalamander likes this

#6
Emeus

Emeus

    (2) Evoker

  • Members
  • 69 posts
  • Steam:Macro Tofu

It's a game engine problem after all, we can't do much about it. Still, the prologue to create a new character is too long, I hope there will be a skip option of it.







Also tagged with one or more of these keywords: feedback, immersion, break

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users