Jump to content
  • 0

Bug: Hundreds (300+) of lost treasures and certain cards no longer unlocking in Gallery



I noticed today while opening some treasures that I hit a fairly high priority bug, since I've effectively lost a ton of paid content in the game. Well over a hundred chests worth of content.


On Android, logged into GooglePlayGames and Repro as follows:


Went to store and opened treasure chests until the game soft locked. Chest animation froze and went to title screen, back to store and animation froze again. Relaunched the game. And repeat. Was able to open a few chests before hitting the lock again.


Go to gallery. Attempt to salvage Greatclub card. Noticed that the tool tip regarding how salvaging worked popped up. Upon clicking "yes", nothing happened. Repeated this three or four times, then tried salvaging a different item, Ranseur. This works. Back to Greatclub. Nothing.


Quit and relaunch game an hour later or so. Notice my inventory dropped from ~1650 to 1320. After navigating through my cards, dozens of them, maybe more, are completely missing from my collection.


Relaunch several times to no avail.


Just to test something, I note what cards are missing that I know for sure I had. (some are on characters in my quest mode)


Got a Smith, Fox and Shortbow +1 in the first pack I open.


Renavigate to my gallery and sort by treasures. The Smith, Fox and Shortbow +1 cards are still grayed out.


So it seems the game just decided to remove many of these cards from my collection completely or this patch has made them 'invisible' to us.


PF ID is 3742EE9866E7037F

Link to comment
Share on other sites

7 answers to this question

Recommended Posts

  • 0

I've been able to temporarily fix this issue by uninstalling the game, reinstalling the game, logging into my profile and opening a few treasures. It happened *again* and I reproed the fix, so I'm not going to touch my treasures or gallery anymore.


It's frustrating to need to get and open 40 chests just to access half the content you already unlocked.


Plus I guess Quest mode isn't saved server side so I lost all my characters I've been working on. :( In particular a level 22 Lem.

Link to comment
Share on other sites

  • 0

Llama did Aarik not get back to you? Might want to pm ping him.


Amion, you've done the most important thing, which is get your PFID so they can look into your account. I'd recommend either ping Aarik as well or contacting get support directly. The forums are only so so at getting good direct attention and the community can't help with these issues.


I'd be curious, if you can recreate it, see if you get a new pfid after opening another chest. Wonder if the game is creating new accounts for you.

Link to comment
Share on other sites

  • 0

Hey guys,


Well, if the game created a new account for him, then he would be seeing zero cards instead of a drop of 300 cards. Its something definitely to look into, but it may be a connection issue which is why the issue has occurred. We'll investigate it further to see if there is anything deeper going on. 


Thanks everyone!

Link to comment
Share on other sites

  • 0

Had it happen again today while opening a few more chests. Maybe something may happen once a certain number have been opened? A memory issue or hiccup on server side?


I had to do the same thing to resolve the issue. Tried resolving it by getting off WiFi and using 4G (and back) to no avail.


I won't be playing anymore Quest until this is resolved. I'm dead tired of farming a character to have to start at square one again and again. :(

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...