Jump to content
  • 0

Screen constantly flickering


Question

I have just started playing but this problem keeps me from continuing.

 

As soon as I enter the game, the mouse cursor keeps flickering and displaying what it is like at windows desktop (the hourglass, actually).

What is more, the other active elements at windows desktop keep flickering in and out. Like the browser, the explorer, and the task bar. Every time they switch in, they appear for about 0.5 sec or less and then disappear, while the game freezes when they do so as if I switched back to desktop, thus making the BGM and short films somewhat incontinuous.

 

I have tried many fixes and none works. Like lowering graphics, disabling and re-enabling V-sync, adjusting screen resolution, starting with -force opengl, and so on.

 

It has annoyed me so much that I did not even complete creating the character, so no saved games.

I'm using WIn7 x64, with NVIDIA Geforce 870 which is supposedly correctly configured, with newest DirectX and graphics driver.

The dxdiag.txt and output log have been attached.

I play this game on steam.

 

I've searched the Internet and game communities but no one seems to experience quite the same problem with me, and all commonly suggested fixes I can find related to graphics problems have failed.

 

Any help would be appreciated.

DxDiag.txt

output_log.txt

Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

You seem to use your internal graphic card.

 

Card name: Intel® HD Graphics 4600
Driver Version: 9.18.10.3071
Driver Date/Size: 3/19/2013 21:31:46, 8647680 bytes

 

The driver is 2 years old. You can try newer drivers at: https://downloadcenter.intel.com/search?keyword=4th+Generation+Intel%C2%AE+Core%E2%84%A2+Processors+with+Intel%C2%AE+HD+Graphics+4600

 

 

Check my post in this thread: http://forums.obsidian.net/topic/82762-pc-gog-version-crashes-on-start/

 

Maybe it helps to force the game to use the nvida card.

 

 

 

Link to post
Share on other sites
  • 0

You seem to use your internal graphic card.

 

Card name: Intel® HD Graphics 4600

Driver Version: 9.18.10.3071

Driver Date/Size: 3/19/2013 21:31:46, 8647680 bytes

 

The driver is 2 years old. You can try newer drivers at: https://downloadcenter.intel.com/search?keyword=4th+Generation+Intel%C2%AE+Core%E2%84%A2+Processors+with+Intel%C2%AE+HD+Graphics+4600

 

 

Check my post in this thread: http://forums.obsidian.net/topic/82762-pc-gog-version-crashes-on-start/

 

Maybe it helps to force the game to use the nvida card.

It seems weird to me as I set it NVIDIA card in global setting in NVIDIA contol panel, as well as in program settings.

 

...Maybe I should restart the PC?

 

 

I heard that this game actually runs in borderless windowed mode when you set it to full-screen, and some fixings are required to force it start in full-screen mode but it does not seem I managed to do that.

 

This is the fix

http://steamcommunity.com/sharedfiles/filedetails/?id=414835388

And I re-set the resolution to 1920*1024 which is same with windows resolution and started with -force opengl. Yet the problem persisted.

Edited by astralia123
Link to post
Share on other sites
  • 0

You seem to use your internal graphic card.

 

Card name: Intel® HD Graphics 4600

Driver Version: 9.18.10.3071

Driver Date/Size: 3/19/2013 21:31:46, 8647680 bytes

 

The driver is 2 years old. You can try newer drivers at: https://downloadcenter.intel.com/search?keyword=4th+Generation+Intel%C2%AE+Core%E2%84%A2+Processors+with+Intel%C2%AE+HD+Graphics+4600

 

 

Check my post in this thread: http://forums.obsidian.net/topic/82762-pc-gog-version-crashes-on-start/

 

Maybe it helps to force the game to use the nvida card.

Click on the second link in Aurelio's post and there will be a video on how to force your system to use the nvidia card.

Link to post
Share on other sites
  • 0

I believe that it is in output_log.txt that I can see which graphics card the game is actually using?

 

I already configured it to use NVIDIA card in NVIDIA control panel but no help.

 

 

What else can I do to force the game use NVIDIA card?

 

 

 

 

It‘s weird...I searched on internet but very few report same problem. I had no problem changing the setting in NVIDIA control panel, but the game's log still says it uses Intel card.

 

Or does the game actually uses NVIDIA card while says it uses integrated card in the log? I'm so confused.

output_log.txt

DxDiag.txt

Edited by astralia123
Link to post
Share on other sites
  • 0

Well, the problem is still there but I found a way to get it going.

 

Now I directly start the game from directory, right click on the exe and select the graphics card option, and it will use my NVIDIA card. Otherwise it still use the integrated graphics card.

 

 

Thanks for the help!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...