Jump to content
  • 0

Ondra's Gift completely submerged [Linux]


El Zoido

Question

I just visited Ondra's Gift for the first time and seem to have encountered a bug with the water level.

That or the spring tide of the century.

Initially the water level seemed just a little bit to high - all the lower streets (the level the Salty Mask is on) were submersed in water.

Just enough to wet the feet of the NPC standing around there, so I thought it might be intentional (even if a bit strange).

I visited the Mask, left it again and it was still the same. After I visited one of the Abandoned Houses on the topmost part of the map, however, the water level increased by a few meters and now the entire district is flooded.

Obviously that makes navigation and questing there pretty difficult.

 

Guess I can be lucky that my party is apparently able to breath underwater - or just very good at holding their breath (Guybrush Threepwood level good).

 

Edit:

 

Screenshot:

bqzupFi.jpg

 

 

Here's the savegame (max downloads is limited, so please leave it for the devs, sorry):

https://www.hidrive.strato.com/lnk/cLoNAVxX

 

System:

Kernel: 3.13.0-43-generic x86_64 (64 bit, gcc: 4.8.2)
Distro: Linux Mint 17.1 Rebecca Cinnamon
CPU:      

Quad core AMD Phenom II X4 965 (-MCP-) cache: 2048 KB flags: (lm nx sse sse2 sse3 sse4a svm)
Graphics: 

Card: NVIDIA GF104 [GeForce GTX 460] bus-ID: 01:00.0
X.Org: 1.15.1 drivers: nvidia (unloaded: fbdev,vesa,nouveau) Resolution: 1680x1050@59.9hz
GLX Renderer: GeForce GTX 460/PCIe/SSE2 GLX Version: 4.4.0 NVIDIA 331.113 Direct Rendering: Yes
 

Edited by El Zoido
Link to comment
Share on other sites

13 answers to this question

Recommended Posts

  • 0

Ok, I think I've found a partial fix for it.

Leaving the district and coming back didn't work, but entering the Mask and leaving again lowered the water level down to the Mask's door.

 

While I think it's still a bit too high (NPCs still get wet feet), at least I now can actually see something again.

Link to comment
Share on other sites

  • 0

I just tried loading your save on Arch with a GTX 970 and the 246.47 nvidia drivers, and everything looks just fine. Out of curiosity, when you re-enter the area from other city districts after the water level lowered, does it go back up?

Link to comment
Share on other sites

  • 0

I just tried loading your save on Arch with a GTX 970 and the 246.47 nvidia drivers, and everything looks just fine. Out of curiosity, when you re-enter the area from other city districts after the water level lowered, does it go back up?

 

Currently it seems to work. I still have water on the lower streetlevel, but it seems to be very shallow, at least (my characters are not entirely submerged).

Don't know what triggered it.

Link to comment
Share on other sites

  • 0

I'm having the same issue. Sometimes it looks normal, but most times I enter the area, it is completly flooded (like in the screenshot above).

After loading screen (even while loading a game that worked before) there is a small chance that it works, but the chance seems to be really low.

 

Not sure what exactly cause that problem, but a fix would be highly appreciated.

 

I'm using OpenSuse 13.2 and NVIDIA 340.76 Drivers (GTX 760).

Link to comment
Share on other sites

  • 0

I am pretty sure that its the same problem with the GOG version. 

Option 1: open a console/terminal and start the shell-script with 'LANG=C ./shell_script'

Option 2: edit the shell script and add the line 'LANG=C' somewhere above where it starts the main executable

If you have a desktop shortcut to start the game you can edit that one instead, but since I don't know which desktop you use I can't give you detailed instructions how to do that.

 

To elaborate the problem, game resources stores some values with a decimal point ( example 1.45 ), now the game reads that value out of the resources on your hdd, your localisation defaults to a language which uses a commata instead of a decimal point ( so value should be 1,45 ) but since its stored with a point the read on the value transforms it to 145 since there is no commata. With the environment variable LANG you tell the program to disregard your default language setting and fall back to english with a decimal point.

  • Like 2
Link to comment
Share on other sites

  • 0

Thank you for the clarification!

I checked it out and it does seem to work. Shouldn't be too difficult to fix for the devs, too.

 

Only other thing I encountered during the whole thing is that the water shaders on Linux look a bit strange (the dark parts in the waves towards the right of my screenshot do not seem to appear in Windows), but I guess that's a different issue.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...