Jump to content
Sign in to follow this  
DarthRevan09

Making Handmaiden Dark Jedi glitch (serious problem)

Recommended Posts

Hi everyone! I have a huge problem with in KotOR 2. I'm DS male (5 lvl Sith Lord), I've already trained Bao-Dur and Atton for Dark Jedi, and now I have a problem with Handmaiden. When I start conversation and ask her about her mother, then becoming a Dark Jedi, she agrees. Kreia says "Betrayal"... And here we go...
After this, there is a cutscene in Telos Academy where Atris says Handmaiden betrayed her and her sisters. Then she goes to meditate and my screen goes full black, I still hear Telos Academy theme playing and noises of surroundings but only thing I see is cursor. I can check my equipment, stats etc but only for my character and map says I'm in Telos Academy. When I save and then reload game I am really in Telos Academy but it's almost empty. Almost. I go in direction of chamber where are Sith Holocrons and before that room stays Atris. There is NOBODY else in whole Academy, I can't go back to Ebon Hawk. So when I talk to Atris she starts why have you returned or sth like that. Basically, it's the same conversation as the one you have when you're first time in Academy. The angle of camera is different, I can't see everything, especially when she draws 'my' lightsaber.

I know that after Atris' speech about betrayal I should be back to Ebon Hawk but nothing like that happens. Does anybody know how to fix this huge bug?

Share this post


Link to post
Share on other sites

Mods?


^

 

 

I agree that that is such a stupid idiotic pathetic garbage hateful retarded scumbag evil satanic nazi like term ever created. At least top 5.

 

TSLRCM Official Forum || TSLRCM Moddb || My other KOTOR2 mods || TSLRCM (English version) on Steam || [M4-78EP on Steam

Formerly known as BattleWookiee/BattleCookiee

Share this post


Link to post
Share on other sites

TSLRCM 1.8.3 and if it counts Kotor Save Editor. I used KSE to increase influence and give some items.

UPDATE:
Now it's even worse. I can get back on Ebon Hawk when I'm in Academy BUT when I go to Nar Shadda and I leave Hawk the map is undiscovered and I have to do everything again. This is ridiculous... I have Hanharr and G0-TO in my team and I have finished planet before... 
AND my every save has the same bug! Even if I decide not to train her and leave Hawk on Nar Shadda... it's the same, I have to do everything again. I didn't check Dantooine but I think it'll be the same...

Share this post


Link to post
Share on other sites

Hello!
KSE can mess up your saves if you don't use it carefully,trust me (experienced it myself)
are you sure that don't have any mods outside TSLRCM?
if i'm not mistaken,black screen means mod conflict 
for example,you use the Ultimate Saber Mod?
90sk's Super Content mod?
Or Handmaiden choice Mod?
are your party members still there or have dissapeared and have "I'm Broken so very very broken" in the party selection menu?
that means corrupted save
or try to use the console   
Enable the console
open the game when the cutscene is frozen
open the console (it's invisible and you'll understand it's open because you cannot move anything and pressing any hotkeys will do nothing)
Type "Warp 003EBO" and press Enter this will teleport you back to the Ebon Hawk and you'be able to proceed normally

For the new bug
you must have messed it up with KSE or you have a Ebon Hawk Map mod,there's no way a bug like that could happen to TSLRCM

:huh: by chance you have upgraded TSLRCM by 1)overriding a previous installation (for example from 1.8 to 1.8.3) or you have installed it by 2)first uninstalling the previous TSLRCM and then Install the new?
because i heard that doing the first can cause a lot of problems and game instability
:shrugz: i don't know what it could be if it's not these options-

Edited by DarthDeven

Share this post


Link to post
Share on other sites

Same problem, though the game crashed directly when the screen switched from Kreia to the cutscene on Telos.
No lingering black screen or anything like that, the game just crashed to desktop.

No mods except the TSLRCM and M4-78EP has ever been installed on this device, nor do I plan to use any.
Have been using KSE lightly, adding some attribute points (no ridiculus amounts, most stats are below 20 and few around 24-25), feats (no feats they couldn't gain through lvl up) and items (accidentally added 100 instead of 10 mando disintegrators, if that matters)

Game has been running flawlessly since I disabled frame buffering, with which the game wont even start.

Running on Win8.1
TSLRCM (1.8.3b)
M4-78EP (1.1b)
The rest of specs can handle the game without breaking a sweat, but ask and you shall recieve.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...