Jump to content
Bester

Modding thread: Asset Editor

Recommended Posts

Then I exited the game, and copied over my modification and loaded up the save.  I took note of any changes rest per day > to modular > out of combat..etc.  I didn't activate the skill, since that seemed to sometimes cause bugs.  Then I saved the game again.  I exited the game again, and copied back over the unchanged/original file.

 

Loaded up the save again, and my modification had stuck (no pink textures).  I tried resting, zoning, and even different game versions.  From what I could tell it worked in 1.30, 1.30 with IE, and 1.3.530.

Interesting.

 

From looking at the hex code of talents/spells; I saw no clear texture path.

 

I have no idea. Maybe there is no texture path at all. But the fact remains that something gets broken. Maybe the material and its texture are linked in some other files, and maybe the material gets slightly modified and a link between material and its texture gets broken? I never looked at what gets modified with a hex editor. Maybe it's something so minor that after saving the file, a pass to correct a few bytes would be enough? Will have a look at it when I get some time, I'm currently busy with something else and will be for at least a week or two.

Edited by Bester

IE Mod for Pillars of Eternity: link

Share this post


Link to post
Share on other sites

I know that the "Flag" for spells being usable in/out of combat is a simple byte difference of 00 vs 01 for on/off.  Sadly tho, I cant find a "Pattern" for where this flag appears in each file.  Guessing this has something to do with unity obfuscation of some kind..  (oddly enough tho, "Wall of Fire" and "Wall of Force" had identical patterns, maybe they copy pasted the spells?)

 

I was in the process of fixing all the wizard spells, but i think i have decided that i dont like this game enough to bother..

Edited by Xionanx

Share this post


Link to post
Share on other sites

×
×
  • Create New...