Jump to content

Control locking after Combat


Recommended Posts

I've had this issue... ever since KOTOR 2 came out.... i'd say... 70% of the time... after combat ends... I can't move my character. I have to quick save, and quick load for my movement to be restored. Its not the pc... this is the 3rd PC i've had since KOTOR 2 was released and they all have the same issue. Does anyone have an idea as to how to fix this... its very annoying to have to do after almost every fight.

 

Anyone?

 

BTW, the game has been patched, no mods installed. Just plain old PATCHED kotor 2... :*

Link to comment
Share on other sites

Like any troubleshooting, you will need to detail your system so that we can help you determine what the problem is. (Just because this fault has been repeated on three different systems doesn't necessarily mean that it isn't related to your particular way of customising Windows and the OS environment, either: you might be loading something that is clobbering one of the dynamic-linked libraries, or perhaps the Anti-Virus application is attacking some of KotOR's allocated memory, etc.)

OBSCVRVM PER OBSCVRIVS ET IGNOTVM PER IGNOTIVS

ingsoc.gif

OPVS ARTIFICEM PROBAT

Link to comment
Share on other sites

Out of interest have you tried switching to one of your other party members and seeing if you can move them? The graphics glitch on Dantooine does something similar to me-although not when fighting-and I can get around it by switching to a second party member and walking around with them. The main Character will unstick to follow them.

Link to comment
Share on other sites

  • 2 months later...

I know this is an old topic, but yesterday I reinstalled KOTOR 2 to play it again, patched it and had this exact same issue almost right out the gate. When I click on a enemy to attack, the controls lock. After saving and reloading, I can move once more, but it happens again next fight. It does not occur after the fight, but when you click on someone to attack (you can click on other enemies to attack and you will move to do so, but WASD controls, or anything to substitute for them, just don't function). It is incredibly aggrivating considering it used to work fine on this system before I upgraded it (most likely the issue). I think it may be the graphics card, as the program that checks the system reqs gave it a yellow light. Perhaps the card's architecture is so new the game doesn't know how to work with it? I also think it may have something to do with the last patch of the game, but that seems much less likely. I reinstalled Direct X and the graphics drivers and neither did anything to help the problem. I've tried reloading from another, differently named save of the same game (a remedy posted on another forum) and that did nothing. I am still on Peragus and am so frustrated with the issue I care not to continue to a point where I can pick up an extra party member to swap between (and thus try that remedy).

 

I noted the above request for system specs, so here:

 

OS: Windows XP 32 Bit, Service Pack 2

Processor: Intel Core 2 6600 @ 2.4 Ghz

Memory: 2.00 GB

Graphics Card: XFX PVT84GUDF3 GeForce 8600 GTS 256MB 128-bit

Direct X: 9.0c

 

If anyone who can solve this problem needs any more help beyond that, you have but to ask. I love this game, and really want to go through it again, but I refuse to do so with this issue in play.

 

Thanks.

Link to comment
Share on other sites

I understand it is considered poor form on most forums to double post, but I have found a solution and I wish to share it with anyone that might be having this very same issue.

 

After some more research, I have discovered that it was my Dual Core Processor that was causing the problems; it seems KOTOR II and Dual Cores are not on the best of terms. Download the Microsoft "Hotfix" for Windows to rememdy this problem on XP SP2 systems. Also, enable V-Sync; I did that as well and one or the other did the trick.

 

With that, I am off to play the game. I hope this info helps.

Link to comment
Share on other sites

My pleasure. I believe if I ask for help, I should be willing to render aid as well. The first thing I did after I got it working was saved, exited and came here to share the news. I figured at least one other person could benefit.

 

Happy gaming!

Link to comment
Share on other sites

  • 5 years later...

I just wanted to say thanks to BM15 and this forum.

 

  I had this problem tonight and it was fixed immediately by turning on the v-Sync in my Nvidia control panel for 680M.    This is one of my favorite games and I'm glad I can play it again on a newer machine.

 

I have a Quad Core Intel Processor also.

 

Thank you!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...