Jump to content

Older ATI Hardware


Recommended Posts

There are several threads on ATI problems floating around, but I wanted to draw attention to the older hardware, as most people seem to be running Radeon 9800 or better.

 

I have a Radeon 7500, out of date by today's standards, but it ran Kotor1 with a little graphics adjustment so I assumed it would run Kotor2. Like many I have been waiting for this game since finishing Kotor1, and like many I am disappointed.

 

I've tried installing drivers, old and new, directly from ATI. Cat 5.2 first, then I completely wiped anything ATI and installed 4.11. That didn't work for me either. The problem is this:

 

The game goes through character creation and the first movie, then it freezes inside the ship. Sometimes sound continues for a couple of moments, but eventually the program cancels itself and drops to desktop.

 

I passed everything on the config hardware check, except the video. This is the detailed report:

 

[Video]

Video Card Name=RADEON 7500 SERIES

Video Memory=64

Desktop Resolution=1152x864x32 @ 60Hz

DirectX=DirectX 9.0c (4.09.00.0904)

OpenGL Version=1.3.4707 WinXP Release

OpenGL Vendor=ATI Technologies Inc.

OpenGL Renderer=RADEON 7500 DDR x86/SSE2

Vid Card Status=Fail

Vid Card Driver Status=Pass

GL Status=Fail

DX Status=Pass

 

Is there anything I can do to remedy this? Is there something I can download to pass the OpenGL test?

 

Thank you for your time.

Link to comment
Share on other sites

Yep, I've the same problem with a 345M. I have been wondering, of late, though if its just that bit... wouldn't mind getting hold of a saved game and seeing if it would work from that... :ph34r:

Blue lorry yellow lorry blue lorry yellow lorry blorry. D'oh.

Link to comment
Share on other sites

I have the same exact problem it freezes at the place and everything and i have the radeon 7500 but the drivers fail also. I dont know what drivers to install, is there anything i can try that will help cause some of the drivers i downloaded i dont think were compatible with my video card.

 

any help?

thanks

Link to comment
Share on other sites

I'm trying to cat 4.9 and CCC pack right now with the 8.07 fix as suggested in another thread. Will report if it works.

 

 

PLEASE work.. I've tried everything except the 4.9's and 4.11s and I've yet to get past the first vid. sequence. I even had a set of 2.xx I think that I found on my computer that actually let me see the graphics of the inside of the ship for a moment before kicking me to the desktop.

 

I'm getting a lil frustrated here, and since I'm at work for another 3 hours, then off to another job for 3 more hours, I won't get the chance to try it until I get home later tonight.

 

 

IF for some reason this method from the other post works, I'll be happier than a pig in sh*t.! :D

Link to comment
Share on other sites

Received a tech support response from LucasArts basically highlighting the fact that my video card is not supported (which I knew). Generally I have been able to bypass this in the pass with certain drivers and whatnot, but I wonder if it will even make a difference.

 

Will wait for some form of ATI update before trading the game back to EB since I can't afford a new card just for one game. :thumbsup:

Link to comment
Share on other sites

Ahhhh, LA, so helpful.... if it makes u feel any better, my video card isn't supported by any games at all that I can think of, and yet runs them just fine (except for this one). "Supported" only means that they didn't test it. I'm not sure ATI will fix it either, but hey we can hope. I'm placing my money on a patch to solve it... :D

Blue lorry yellow lorry blue lorry yellow lorry blorry. D'oh.

Link to comment
Share on other sites

i assume you guys saw the requirements and thought you could force the game to work on a 7500?

 

more power to you, i just want to be clear... you look at hardware requirements on the box before you buy a game don't you?

 

The problem when you say that is that KotOR worked fine for these people- and I've heard that if you get a saved game and load that, then you can play it fine on an unsupported card- until the next cutscene, but I have yet to try this out... Besides, I've read people who have 9800's with this exact problem.

Blue lorry yellow lorry blue lorry yellow lorry blorry. D'oh.

Link to comment
Share on other sites

Ok...I have tried everything with this game. I have done everything I can eg Reinstalling DirectX of the game disk, Changing my settings and drivers. I have seen some improvements with the graphics however the game randomly resets my computer. It is really frustrating. Any suggestions?

 

Heres my settings:

 

[sWKotOR]

ReportDateTime=12/02/2005 20:11:42

SysInfoVersion=v1.00.60

GameExists=1

GameVersion=v2.00.420

GameInstallLocation=C:\Program Files\LucasArts\SWKotOR2\

 

[OS]

Name=WinXP

Version=Windows XP v5.1 build 2600

Service Pack=None

Status=Pass

 

[swapFiles]

C:\pagefile.sys=768

 

[CPU]

CPUCount=1

CPUSpeed=1808

CPUFamily=6

CPUModel=8

CPUStepping=0

CPUVendor=AMD

CPUName=AMD Athlon XP 2200+

Status=Pass

 

[Memory]

RAM=512

Status=Pass

 

[Disk Free Space]

C: (NTFS), UNICODE=121.43GB

Status=Pass

 

[CD-ROMs]

DriveLetters=D:\,E:\

Drives=PLEXTOR DVDR PX-708A,TOSHIBA DVD-ROM SD-M1302

 

[Video]

Video Card Name=NVIDIA GeForce FX 5200

Video Memory=128

Desktop Resolution=1024x768x32 @ 60Hz

DirectX=DirectX (9.0+) (4.09.00.0904)

OpenGL Version=1.5.2

OpenGL Vendor=NVIDIA Corporation

OpenGL Renderer=GeForce FX 5200/AGP/SSE/3DNOW!

NVidia Driver=6.14.10.6766

Vid Card Status=Pass

Vid Card Driver Status=Pass

GL Status=Pass

DX Status=Pass

 

[Audio]

Sound Card Name=Avance AC'97 Audio for VIA ® Audio Controller

Status=Pass

 

 

;Game Options from swkotor2.ini

 

[Display Options]

FullScreen=1

Disable Movies=0

Disable Intro Movies=0

Sort Modules=1

Width=640

Height=480

BitsPerPixels=32

RefreshRate=60

 

[sound Options]

Disable Sound=0

 

[Graphics Options]

EnableHardwareMouse=1

FullScreen=0

 

[Game Options]

 

[config]

firstrun=0

 

:huh:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...