Jump to content

Radeon 7500


Kiddo

Recommended Posts

Well i gambled and lost! DOH!!!

 

I had KOTOR I and was using this card a while back and had problems with the game.

 

the 7500 lacks the T&L Capability and apparently KOTOR II tells me i need Non-Windows Generic Open-GL 1.4.0 drivers.

 

 

I was able to get KOTOR I working, but i honestly can't remember how, or whether it was a game patch (in which case i'll have to wait :'( )

 

KOTOR II loads up fine, and character selection screen is passed fine too, the first movie begins to play, txt scrolls, the ship flies across space but then screen goes black and after a short while i'm booted to windows.

 

If anybody has any info on this card or these probs and is able to fix it or has been able to get the game running pls share! :) B/c i'm a huge fan and really want to play the game!

 

Thanks for your time guys.

 

Kiddo

Link to comment
Share on other sites

any thoughts/statements/theories/questions/solutions guys?

 

Would appreciate any insight, the box is sitting at my desk and i my eyes keep darting back to it! lol

 

 

 

Kiddo

 

 

I'm having the same problems... I've tried the 5.2 CAT, the Omega Drivers and a couple of others I had on my computer. Because I'm stuck at work, I can't finish what I started last night, which was upgrade to SP2, and try the 4.11 Cat's that I believe were recommended for KoToR when the problems arose in that title.

 

I can get to the video sequence, and I hear the game sounds for about 5 seconds. Sometimes I even get a cursor on the screen then it dumps me. I've changed sounds to Forced Software, Hardware EAX Disabled, EAX, EAX II, I've changed the refresh rates, resolutions and absolutely everything I can think of in the settings to no avail.

 

My specs are:

 

Athlon 2500+

512MB RAM

Radeon 7500 (I know, bottleneck, but still runs every new release to date that I've played)

120GB Hd

 

I don't understand how the game can launch up, play the first intro movie AFTER creating a character, then spits me out to the desktop. It's ludicrous and I'm already out $50 cause I can't return the game to EB now since it's opened..

Link to comment
Share on other sites

any thoughts/statements/theories/questions/solutions guys?

 

Would appreciate any insight, the box is sitting at my desk and i my eyes keep darting back to it! lol

 

 

 

Kiddo

 

 

I'm having the same problems... I've tried the 5.2 CAT, the Omega Drivers and a couple of others I had on my computer. Because I'm stuck at work, I can't finish what I started last night, which was upgrade to SP2, and try the 4.11 Cat's that I believe were recommended for KoToR when the problems arose in that title.

 

I can get to the video sequence, and I hear the game sounds for about 5 seconds. Sometimes I even get a cursor on the screen then it dumps me. I've changed sounds to Forced Software, Hardware EAX Disabled, EAX, EAX II, I've changed the refresh rates, resolutions and absolutely everything I can think of in the settings to no avail.

 

My specs are:

 

Athlon 2500+

512MB RAM

Radeon 7500 (I know, bottleneck, but still runs every new release to date that I've played)

120GB Hd

 

I don't understand how the game can launch up, play the first intro movie AFTER creating a character, then spits me out to the desktop. It's ludicrous and I'm already out $50 cause I can't return the game to EB now since it's opened..

 

Yea looks like we're having the exact same problem, i got the game because i assumed that as the specs were more or less the same and the first one worked fine that the second would too, doh!!

 

But yea i've "heard" an upgrade to SP2 and 4.12 Cat may help. But i honestly don't know :'(

 

It is frustrating because as you said every other new game released in recent months has worked fine, so a bit of a pain. I hoping i can resolve this without having to buy a new Gcard.

 

I'm at college but i should be home in about 3-4 hrs. I'll try the SP2 and Cat 4.12 a go and give you an update bro.

 

Specs:

 

Athlon 2500+

786 RAM

Radeon 7500

80 Gb HD

 

Kiddo

Link to comment
Share on other sites

Yea looks like we're having the exact same problem, i got the game because i assumed that as the specs were more or less the same and the first one worked fine that the second would too, doh!!

 

But yea i've "heard" an upgrade to SP2 and 4.12 Cat may help. But i honestly don't know :'(

 

It is frustrating because as you said every other new game released in recent months has worked fine, so a bit of a pain. I hoping i can resolve this without having to buy a new Gcard.

 

I'm at college but i should be home in about 3-4 hrs. I'll try the SP2 and Cat 4.12 a go and give you an update bro.

 

Specs:

 

Athlon 2500+

786 RAM

Radeon 7500

80 Gb HD

 

Kiddo

 

 

Cool dude.. I'm off from this job in about 4 hours or so and I'm gonna see if I can get SP2 up on my system before heading off to my other job.. Either way, I hope we can figure this problem out.

Link to comment
Share on other sites

If you really want to play, u can disable the movie at config, this will allow you to play the game but with no movies.  maybe the problem is our ATI cards.  Well here is my suggestion, i don't wanna play without movie so i'll be waiting for the patch.

 

 

Yea i tried that but had the same problem, it's not the movie sequences that are causing the crashes, it's the stoopid T&L requirement.

 

Well i invested in a new card, i got the GeForce FX5200 128mb

 

Runs like a charm now, just a shame i had to spend more money for the overhaul :'(

 

 

Kiddo

Link to comment
Share on other sites

Well i could run Half LIfe 2 extremely smoothly

 

these are the minimum requirements for half-life 2

 

# 1.2 GHz Processor

# 256MB RAM

# DirectX 7 level graphics card

# Windows 2000/XP/ME/98

 

the 7500 is a directx 7 based card (maybe even 8.1 not sure)

 

and kotor2

 

2 MB OpenGL 1.4 compliant AGP or PCX 3D Graphics card with Hardware Transform and Lighting (T&L) Capability required.

ATI Radeon 9200 or NVIDIA GeForce4 Ti or better recommended.

 

 

the bottom of the box even lists the specific series of cards the game runs on, this should have given you an indication that the game probably wouldn't run

also since they listed specific card series, any that aren't listed were not tested with the game at all

 

half-life 2 ran so well because the 7500 doesn't have the ability to display any of the additional effects in the game, ie it would pale in comparison visually to a card that supported the game features fully

 

also the game was actually built and tested to work with the 7500, kotor2 was not

its their choice and your job as a consumer to make sure the product you buy is intended to work the way you want/need it to

Link to comment
Share on other sites

AMEN

 

As someone with a supported on the box card, who is unable to run the game, I am tired of everyone saying "My card from the 1970's that ran KOTOR1 doesn't run this game! Even though the box says it never was intended to!"

 

You know what? I bet it doesn't run on your damn microwave either, complain about that instead.

Link to comment
Share on other sites

yea i have the same problem, is crashes at the same point

 

specs:

Intel® Pentium® 4 CPU 2.40GHz

HD=50 GB

RAM=512

 

[Video]

Video Card Name=MOBILITY RADEON 7500C

Video Memory=64

Desktop Resolution=1024x768x32 @ 60Hz

DirectX=DirectX 9.0c (4.09.00.0904)

OpenGL Version=1.3.3842 WinXP Release

OpenGL Vendor=ATI Technologies Inc.

OpenGL Renderer=MOBILITY RADEON 7500 DDR x86/SSE2

Vid Card Status=Fail

Vid Card Driver Status=Pass

GL Status=Fail

DX Status=Pass

 

 

its irriating that it has to happen like this. i have a laptop also so i cant upgrade my card so unless they make a super patch or something we r mostly screwed.

 

i plan on buying a top of the line alienware computer, has to be a laptop though

anyone know what the best one is or anything else about them. thanks

 

 

its

Link to comment
Share on other sites

One has to be uber-careful to read the minimum requirements lately. I pity all the poor suckers who bought Half-Life 2 and didn't have an internet connection.

 

 

On a side note... even though the Radeon 9200 is 'the bottom of the barrel' for this game... I am not having any problems with it all and I am running a R9000 with 4.11 catalyst drivers. I had way more problems with Homeworld 2 shading and such. Half Life 2 looks just fine to me and I have minimal lag with that; I even run anti-s filtering at 2x and I gives a nice effect. I love the R9000... it's at the tail end of it's life but man did I get some serious mileage out of that baby in terms of price.

 

If you're running a directx 7 card you're screwed.

 

 

 

P.S. I think having a decent sound card helps a helluva lot if you are running a lower end graphics chipset. I wouldn't recommend onboard sound. Completley anecdotal observation, but I know it helped my performance.

 

 

 

 

AMD Athlon 2.4 Ghz

Radeon 9000 Pro 128MB

Sound Blaster Live

ABit KV7-V Motherboard

512MB RAM

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...