Jump to content

Question

Hi Community,

Bought POE 2 from Steam the larger package with with all of the DLC's. Installed through Steam (55gb) onto a 1tb SSD. I read through some posts online and tried everything like giving exe admin privilages. Turned graphics to the lowest settings, and turned off scaling in my nVidia settings. Anyone else have any ideas, the game is pretty much unplayable for me at this point.

My system;

  • nVidia GeForce GTX 670 (latest driver 26.21.14.4575 - 3/7/2020)
  • 16gb memory
  • 1tb SSD storage
  • Intel Core i7-3770K - 3.50GHz
  • Dual Monitors.
  • Windows 10 Pro 64-bit 

Playing the game on it's lowest graphic settings in windowed mode. I have turned off any virus scan, I still have windows defender on. Before playing I exit out of any programs I usually run like docker windows, dropbox, teamviewer, etc. Lastly, I do not know how to get the logs at this time.

Any help would be greatly appreciated.

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

Hm, still wonder why there are people with Win Pro at home... as there is no benefit from the extra money spent on it.

Anyways you could look into gpu and driver compatibility as well. What version of windows are you running?

Share this post


Link to post
Share on other sites
  • 0
44 minutes ago, AeonsLegend said:

Hm, still wonder why there are people with Win Pro at home... as there is no benefit from the extra money spent on it.

Anyways you could look into gpu and driver compatibility as well. What version of windows are you running?

In a normal situation I wonder that also. Like why is my elderly mother running win pro lol. However I'm a former software engineer, now an agile coach, but I still work on hobby/side projects like websites, mobile apps, etc. on my home PC. That is why I run Pro at home.

I feel like it's a GPU thing maybe. One time the window was all white but I could hear the game. My windows version is 1903 (OS Build 18362.720).

Thank you for attempting to help me out. Stuck in the house, I really would like to play the game.

Share this post


Link to post
Share on other sites
  • 0

I just tried that and still freezes. I also tried turning down the frame rate and that didn't work.

However, I did restart in Safe Mode and played the game. The game actually played and didn't lock. Since Safe Mode doesn't load video drivers the game plays very slowly.

Edited by Christopher Parker

Share this post


Link to post
Share on other sites
  • 0
4 hours ago, Christopher Parker said:

I think it is GPU related. My recent attempt shut down the whole display and when I rebooted, Windows 10 displayed is 640x480.

 

Do you have other graphically intensive games you can try?

Also, perhaps it would be a good idea to completely remove and cleanup the GPU drivers and reinstalling them.


"My hovercraft is full of eels!" - Hungarian tourist
I am Dan Quayle of the Romans.
I want to tattoo a map of the Netherlands on my nether lands.
Heja Sverige!!
Everyone should cuffawkle more.
The wrench is your friend. :bat:

Share this post


Link to post
Share on other sites
  • 0

Sounds like a GPU issue indeed. Although could also be in combination with the display. Are both displays the same? You could try to switch them and try the other one. Sometimes a single display messes things up if it's not 100% compatible. 

Do you have any other GPU settings in the NVidia control panel? Try to set them to the defaults for this game. Reset it.

Another thing you can try is loading an older NVidia driver to see if that makes a difference. Or do a fresh driver install. So just uninstall the driver, don't let Windows install the one on it's own and then install the newest from NVidia. This should also reset any specific GPU settings.

Share this post


Link to post
Share on other sites
  • 0

It was the GPU, no matter what settings I did, it would crash. GTX680 is an older card, I think I bought it in 2015. While the game still should have worked, I noticed it would crash when the GPU hit 100% utilization and mostly when I was in a dialog screen. The game would run really heavy during that and would always crash. I read through the forums and nVidia cards with this game is an ongoing issue since the release. Seems like a limitation in the Unity game engine with the version the developers used and it wasn't an easy fix. I do hope in version 3 they are using the more updated engine. Anyway, I just purchased a Radeon card and this baby is running the game at the highest level. So we can close this thread.

Lastly, I will say that it is sad the way the developers handled the nVidia situation and it will give me a long pause when deciding if I will buy other games from this company and POE3, if there is one. I'm not saying I won't but going months without responding to customers on a major issue is a huge red flag. Great games + poor customer service = loss in customers! Just my 2 pennies on the subject. Thank you AeonsLegend and Pidesco for trying to help me. Happy gaming everyone and stay safe!

Edited by Christopher Parker

Share this post


Link to post
Share on other sites
  • 0

Obsidian games are kind of infamous for being poorly optimized. Man, that sucks. I must add though that Obsidian has greatly supported this game till it went out of support, which wasn't that long ago. The games state is what it is and it won't change anymore unless there's a fan patch (which are being made on the Nexus). There don't seem to be performance increasing mods.

The GTX680 is old. You can actually buy cards that are much better cards now for a little bit of money. Although I probably wouldn't for just a single game.

Wish you the best, and if you ever do play the game you know where to find us ;)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...