Jump to content
  • 0

Stutter/FPS Drops


Go to solution Solved by N7Cross,

Question

Hello everyone!

I have contacted the support about 6 months ago. Although they were very friendly they couldn't help me solve the problem. I also feel that maybe I have failed to explain the problem well enough.

Anyway I have made a short video capturing the problem. With NPCs on screen the game just turns into full retard mode. The more NPCs on screen - the worse it gets. I will not bother mentioning that it gets even worse in combat.

When the game first came out it ran absolutely fine. I completed the main story line. Now that I want to replay the game along with all DLCs I just can't. It's stuttering so much it that it is truly unplayable.

I have tried (I think) ALL of the stuttering fixes available on the internet and they just do not work. Min/Max settings, disabling telemetry, tweaking nVidia 3D Settings, updating drivers, reinstalling and so on. I've tried so many thing that I can't even remember them all.

I am running on a Intel i7, GTX980, 32GB RAM, SSD (the game is on SSD as well)

<iframe width="560" height="315" src="https://www.youtube.com/embed/XOO4njqZOXk" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>

 

Here is a link to the video (I am not sure the embed will work): https://youtu.be/XOO4njqZOXk

 

Please help! I can't even refund it probably, yet I can't even play the content I paid for like all the DLC.

Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0
  • Solution

So I  have finally found the solution to this problem while actually looking how to fix the exact same issue for Tyranny which I recently purchased (since Deadfire was unplayable)

Anyway here it goes a quote from steam community:

What is the problem you ask? The graphics card was seated in a PCI-E slot on my motherboard that would only run at full power (x16) under the right circumstances. In this case it was reserved for SLI-mode (dual-GPU) configurations, and was running at x2 mode. What this means in laymans terms is that the data lanes between the GPU and my system were at 2 instead of 16, and it was choking like a movie stream over 64k internet.
What is amazing about this specific problem is that it'll only affect games that send a lot of visually heavy data to the GPU, like Tyranny. Games like Battlefield send less texture data than Tyranny, despite being so much more graphically intense, and so I could play BF1 at 60FPS no worries, but not Tyranny. That still points to really bad optimisation on Obsidians part, but it is only a problem because of my issue.

As it says someone had a problem that the GPU was plugged in to the wrong PCI-E slot which in my case was a 2nd Slot in an ASUS X99 Pro motherboard which does't function properly. Only slots 1,3 & 4 allow full potential for GPU. So now that it is plugged in to slot 3 the game runs smooth and well and is playable. 

Link to post
Share on other sites
  • 0
11 hours ago, N7Cross said:

Hello everyone!

I have contacted the support about 6 months ago. Although they were very friendly they couldn't help me solve the problem. I also feel that maybe I have failed to explain the problem well enough.

Anyway I have made a short video capturing the problem. With NPCs on screen the game just turns into full retard mode. The more NPCs on screen - the worse it gets. I will not bother mentioning that it gets even worse in combat.

When the game first came out it ran absolutely fine. I completed the main story line. Now that I want to replay the game along with all DLCs I just can't. It's stuttering so much it that it is truly unplayable.

I have tried (I think) ALL of the stuttering fixes available on the internet and they just do not work. Min/Max settings, disabling telemetry, tweaking nVidia 3D Settings, updating drivers, reinstalling and so on. I've tried so many thing that I can't even remember them all.

I am running on a Intel i7, GTX980, 32GB RAM, SSD (the game is on SSD as well)

<iframe width="560" height="315" src="https://www.youtube.com/embed/XOO4njqZOXk" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>

 

Here is a link to the video (I am not sure the embed will work): https://youtu.be/XOO4njqZOXk

 

Please help! I can't even refund it probably, yet I can't even play the content I paid for like all the DLC.

I'm willing to bet it has something to do with you having an i7.I have a 9900k and experience the very same issue from the start on the beach.Jittery camera movement/stutter.I opened the task manager>details>game.exe>affinity and disable every 2nd core like 1,3,5,7, and etc.... after that if you still experience  either jutter/stutter  disable 1 more core and repeated till its smooth again.I had to lower the game to only use 3 cores to somewhat fix it from my whole 16.Crazy.

 

Video of the issue with pillars of eternity for example. https://www.youtube.com/watch?v=1J1Pk-A4Y10&feature=youtu.be Stil stutters sadly after disabling the cores but I think it's the game tbh but the frames are better.

Edited by Wiseude
Link to post
Share on other sites
  • 0
On 10/1/2019 at 6:33 PM, Wiseude said:

I'm willing to bet it has something to do with you having an i7.I have a 9900k and experience the very same issue from the start on the beach.Jittery camera movement/stutter.I opened the task manager>details>game.exe>affinity and disable every 2nd core like 1,3,5,7, and etc.... after that if you still experience  either jutter/stutter  disable 1 more core and repeated till its smooth again.I had to lower the game to only use 3 cores to somewhat fix it from my whole 16.Crazy.

 

Video of the issue with pillars of eternity for example. https://www.youtube.com/watch?v=1J1Pk-A4Y10&feature=youtu.be Stil stutters sadly after disabling the cores but I think it's the game tbh but the frames are better.

Well... It didn't help unfortunately... Looks like I'll need to build an ATi/AMD rig to play if hardware is the issue.

Link to post
Share on other sites
  • 0
6 hours ago, N7Cross said:

Well... It didn't help unfortunately... Looks like I'll need to build an ATi/AMD rig to play if hardware is the issue.

yeaa upon further testing it doesnt really help that much.It does however decrease the rate they happen though.Still kinda lame.

Edited by Wiseude
Link to post
Share on other sites
  • 0

I had the popular 0,5s stuttering issue occuring every 20-30 seconds or so with the sound playing fine. It was completely resolved by disabling PCI-e energy saving feature in Windows power options.

Latest Win 10, i7-4790K, 16GB DDR3 1600MHz, GTX 1060 6GB.

Link to post
Share on other sites
  • 0
16 hours ago, daerragh said:

I had the popular 0,5s stuttering issue occuring every 20-30 seconds or so with the sound playing fine. It was completely resolved by disabling PCI-e energy saving feature in Windows power options.

Latest Win 10, i7-4790K, 16GB DDR3 1600MHz, GTX 1060 6GB.

Any Pcgamer worth their salt plays with the high performance power plan already which has the option disabled.It does not solve the issue.

Link to post
Share on other sites
  • 0
On 11/24/2019 at 10:26 PM, daerragh said:

I had the popular 0,5s stuttering issue occuring every 20-30 seconds or so with the sound playing fine. It was completely resolved by disabling PCI-e energy saving feature in Windows power options.

Latest Win 10, i7-4790K, 16GB DDR3 1600MHz, GTX 1060 6GB.

Turns out some motherboards simply have specific slots that just won't allow "powerful" GPUs to function properly. I'm not a super PC guy that explain things well but here's from tomshardware website: (From what I understand it is a 2.0 slot and there is nothing I can do about it. So as recommended plugged it in the 3RD slot and it works like a charm now.)

 

The ASUS X99-PRO comes with three PCI Express 3.0 x16 slots (PCIEX16_1, PCIEX16_3, and PCIEX16_4). With a 40-lane processor installed, the board supports x16/x16/x8 configuration. With a 28-lane CPU, the board supports x16/x8/x4 configuration. In both cases, the last slot (PCIEX16_4) shares bandwidh with the on-board M.2 slot; if this M.2 slot is used, this PCI Express 3.0 x16 slot is disabled.

There is also one PCI Express 2.0 x16 slot (PCIEX16_2), which works at x4 speed (x1 speed if the additional USB 3.0 ports are enabled), and two PCI Express 2.0 x1 slots.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...