Jump to content

Welcome to Obsidian Forum Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

Performance issue on GOG copy


  • Please log in to reply
3 replies to this topic

#1
Daggerknight

Daggerknight

    (2) Evoker

  • Members
  • 53 posts
  • Steam:taurus_daggerknight

I apologize if this has been posted. I've not found any discussion here, and I also apologize for this not being in the Tech support section, which clearly labels itself as being for the Beta's and Steam....

 

Anyhow, as stated, I'm on the GOG version of the game, with all expansions. I took a long break after Seeker, Slayer, Survivor (or however it's called), and only just got back to POE with a new character. My previous runs on the game were buttery smooth (running on  a GTX 1080 here), no issues at all, not even a single crash. Yet now, when I run the game, every few seconds there's a pause and dip in FPS, even in the first few zones of the game where not a lot is happening. I've trapped capping the FPS, tried lowering the AA, nothing helps. 

 

Anyone experiencing the same problem? If so... what's the solution?


  • Lord_Mord likes this

#2
Daggerknight

Daggerknight

    (2) Evoker

  • Members
  • 53 posts
  • Steam:taurus_daggerknight

Anyone? Please?



#3
bringingyouthefuture

bringingyouthefuture

    (4) Theurgist

  • Members
  • 375 posts
  • Location:Los Angeles
  • Deadfire Backer
  • Fig Backer

I only run on Steam, I don't use GoG. Have you tried installing the game directly to your hard disk and running it not through a launcher?  I am not actually familiar with GoG at all, so not even sure they have a launcher. 

 

I run a 1070, but with an i7 and haven't experienced any problems with the game so far - maybe a few dropped frames and slow down in the most hectic combat situations, but mostly it runs pretty great!

 

Hmm, there was a bug awhile back where some of the top end NVIDIA graphics cards were having an issue, check this post here:

 

https://forums.obsid...graphics-cards/

 

Not sure that describes your issue.

 

Also, the top level of the Bugs reporting is for game bugs, it has been very active lately with the turn-based being launched, so you should for sure post there, here is the a direct link to the forum:

 

https://forums.obsid...poiler-warning/

 

I would post there if you can't find another solution :)


Edited by bringingyouthefuture, 24 March 2019 - 10:06 PM.

  • Daggerknight likes this

#4
Daggerknight

Daggerknight

    (2) Evoker

  • Members
  • 53 posts
  • Steam:taurus_daggerknight

I only run on Steam, I don't use GoG. Have you tried installing the game directly to your hard disk and running it not through a launcher?  I am not actually familiar with GoG at all, so not even sure they have a launcher. 

 

I run a 1070, but with an i7 and haven't experienced any problems with the game so far - maybe a few dropped frames and slow down in the most hectic combat situations, but mostly it runs pretty great!

 

Hmm, there was a bug awhile back where some of the top end NVIDIA graphics cards were having an issue, check this post here:

 

https://forums.obsid...graphics-cards/

 

Not sure that describes your issue.

 

Also, the top level of the Bugs reporting is for game bugs, it has been very active lately with the turn-based being launched, so you should for sure post there, here is the a direct link to the forum:

 

https://forums.obsid...poiler-warning/

 

I would post there if you can't find another solution :)

 

Thanks for the tips! Will check these out later today. GOG does have a launcher, but it's almost never been  a problem, certainly it's lighter than Steam anyhow...






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users