Jump to content

Question

I think this is a bug. My game is in patch 3.0.1. 

Detailed steps to reproduce the bug is given below.

  1. Go to luminous bathhouse boiler room and reach the wall that can be broken.
  2. Disable the alarm successfully and then break the wall with chisel and hammer. 
  3. Next, reach Arkemyr's manor using grappling hook from the dark cupboard upper floor window.
  4. Go to Arkemyr's room and steal his robes.
  5. Wear the robe and the ironclad guard outside still becomes hostile.

Now, till patch 2.1, this quest worked fine with the robes.

 

In case you cannot reproduce the bug here is a save file which is after I have donned the robe. I have no save file prior to breaking the wall in bathhouse. Any help is appreciated.

 

save file: https://drive.google.com/open?id=146MCoSUerWpeRt0vhx8njEuLuLnzPHqn

Edited by bartopolis1234
  • Like 1

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

Hello Bartopolis!

 

Thanks for another great bug report!  Fortunately we've had this one bugged and a fix is already in the works.  It is currently being Fix Verified by QA to make sure the fix is indeed working and that it doesn't break something else.  Once that is taken care of, it should be ready for implementation into a future patch.  Keep an eye on the forum patch notes to see when this fix is implemented into the game or when it becomes available on the Beta Patch branch if you want to get through this quest sooner.

 

Thanks again for the help, and sorry for the inconvenience this bug is causing.

Share this post


Link to post
Share on other sites
  • 0

Any update on the fix? It's still occurring in the latest build.

 

bugs suxs i know. perhaps the intended way is go to the dark cupboard directly instead of going through the bath house first. after wearing the robes, latest patch the steel ironclad didnt get hostile. even if he does.. what i did was sneak pass through it.

Share this post


Link to post
Share on other sites
  • 0

Hey everyone,

 

The bug is thought to be fixed for version 4.0.0.  If you are still having it occur, can you please send me a new save where this can happen to support@obsidian.net along with a link to this thread as a reference?

 

Thank you and sorry if you're still having this problem :(

Share this post


Link to post
Share on other sites
  • 0

I just experienced the bug in the newest version of the game! I wore the Arkemyr's Old Robes and had no issue with Yellow-Eye Three and the construct on rooftop, but once I got to the ground floor of the manor through the second floor, I was immediately attacked by the imp.

 

It seems that the constructs can't see through the disguise but the imps can.

Edited by DaylenAmell
  • Like 1

Share this post


Link to post
Share on other sites
  • 0

I'm running a fully patched version of the game and the Arkemyr's Old Robes does not work for me either. Every imp and construct in the mansion is hostile, regardless of whether my MC is wearing the Robes. I snuck in through the bathhouse basement, FWIW.

 

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
9 minutes ago, LotharVI said:

... you know the password?...

Yes: I have the Robe and I read Arkemyr's notes. The imps never asked for a password, just aggro'd right away.

Edited by cheesechoker
ambiguously worded

Share this post


Link to post
Share on other sites
  • 0

OK, this was probably my fault. While I was sneaking to the top floor, I destroyed one of the constructs on the exterior of the mansion. Maybe that turned everything inside permanently hostile. Reloaded an earlier save and used the rope bridge to get to the top floor instead. Now the disguise works.

 

Please disregard previous posts

Share this post


Link to post
Share on other sites
  • 0

Yup, that is all it takes..., you can also use high Diplomacy and high Bluff...  Imps are easily fooled...

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...