Jump to content


  • Posts

  • Joined

  • Last visited

Everything posted by mindkeep

  1. I'm having the same problem. I just gave this a try again in v1.0.4.0540 on linux and it still seems to be broken. Here is a screenshot of the issue http://mindkeep.org/public/Screenshot_2015-03-28_13-16-47.png. Right is my primary monitor in landscape and the left monitor is secondary in portrait (rotated left). nvidia presents this to X as one massive monitor with dead zones in the upper and lower right. If I disable the left monitor, everything works fine, but it's annoying to have to switch between the 2 modes. Option "metamodes" "DVI-I-1: 1920x1080_144 +1050+270, DVI-D-0: 1680x1050_60 +0+0 {rotation=left}; DVI-I-1: 1920x1080_144 +0+0; DVI-I-1: nvidia-auto-select +0+0" This let's me swap via "xrandr -s 0" and "xrandr -s 1" to enable/disable the left monitor. Most games will work just fine in full screen mode, which will use ony the primary (right) monitor, allowing me to keep some reference page vibily on the left/portrait monitor. It would be nice to see this fixed.
  2. I have a similar, though not quite the same issue. Here's a screenshot of both monitors. The left is in portrait mode and the right (primary) is landscape. http://mindkeep.org/public/Screenshot_2015-03-28_13-16-47.png My monitor setup is something like: 22 221111 221111 22 Where 1 is 1920x1080 and 2 is 1050x1680. (Awesome for coding on the left monitor by the way.) The upper and lower left corners are non visible space (just whatever happens to be hanging around the buffer). The problem is that Pillars seems to be trying to use the whole 2 monitopr space (and failing at it) while most games in full screen mode will maximize to the right monitor without issue. I think the root of this is Grestorn's post: Whatever Pillars is trying to do here is probably overcomplicated and it should just be using the ffullscreenmode instead of rolling it's own solution. (Or at least give us the option so we can fiddle the nobs until it works.) I can't even see the Graphical options to try and fix this on my linux desktop, because most of the dialog is not visible on the screen.
  • Create New...