Jump to content
  • 0

Linux PoE not rendering correctly w/ multi-monitors


Question

1: Congrats on launch!
2: Thanks for linux on day 1!

 

Now, the issue. I'm running a pretty standard linux setup (Ubuntu 14.04, updated proprietary NVidia drivers on a 570 card, etc.). I have 2 dell monitors running @1920x1080. When I start up the game, it seems to mis-detect them as one massive display, and ends up only drawing the bottom-eft 2/3 of the game on the main monitor (and nothing on the second monitor). The mouse cursor is also mis-aligned from what is detected for hovering - making it impossible to do much of anything.

 

If I disable multi-monitor, then it seems to start up fine.

Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

It looks like I'm having the same issue. I just flipped to single monitor, and the mouse problem went away. I also found that I could force the resolution to 1920x1080 and that got rid of the mouse alignment issues. I'm on an AMD 6970 card myself with the proprietary drivers, Mint 17.1 (which is Ubuntu 14.04 underneath.)

 

Looks like I've solved the problems enough to play though. :)

Link to post
Share on other sites
  • 0

If you're using nvidia. open nvidia-settings either by sudo nvidia-settings or kdesu nvidia-settings or gksu nvidia-settings and set the monitor you want to be primary as primary in the "X Server Display Configuration" tab and remembering to apply and save to your xorg.conf. If this doesn't fix the issue you have to be a bit more specific to Xorg. By doing gksu gedit /etc/X11/xorg.conf go down to the "Section "Screen" " find the option Option         "metamodes" and specify the resolutions you want the system to be able to use.
Mine looks like this

Option         "metamodes" "2560x1600, 1920x1200; 2560x1440, 1920x1200; 1920x1200, 1920x1200; 1600x1200, NULL; 1680x1050, NULL; 1440x900, NULL; 1280x1024, NULL; 1280x800, NULL; 1280x720, NULL; 1024x768, NULL; 800x600, NULL; 640x480, NULL; 320x200, NULL"


obviously you will have to edit the resolutions to fit your display configuration, but mind the setup, specifically notice where it says 'null'. It means that on any given resolution where ResXbyResy, null. Only the first specified resolution on the first monitor will be set on a full screen application, the other monitor turns off. It'll turn back on again as soon as the full screen application closes.

I hope this helps you :)

Link to post
Share on other sites
  • 0

I'm having the same problem. I just gave this a try again in v1.0.4.0540 on linux and it still seems to be broken.

 

Here is a screenshot of the issue http://mindkeep.org/public/Screenshot_2015-03-28_13-16-47.png. Right is my primary monitor in landscape and the left monitor is secondary in portrait (rotated left). nvidia presents this to X as one massive monitor with dead zones in the upper and lower right. If I disable the left monitor, everything works fine, but it's annoying to have to switch between the 2 modes.

 

    Option         "metamodes" "DVI-I-1: 1920x1080_144 +1050+270, DVI-D-0: 1680x1050_60 +0+0 {rotation=left}; DVI-I-1: 1920x1080_144 +0+0; DVI-I-1: nvidia-auto-select +0+0"

 

This let's me swap via "xrandr -s 0" and "xrandr -s 1" to enable/disable the left monitor.

 

Most games will work just fine in full screen mode, which will use ony the primary (right) monitor, allowing me to keep some reference page vibily on the left/portrait monitor. It would be nice to see this fixed.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...