Jump to content

Welcome to Obsidian Forum Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

Sound glitching (when in party)

- - - - - sound glitch sound no sound

  • Please log in to reply
1 reply to this topic

#1
Nail

Nail

    (2) Evoker

  • Members
  • 72 posts
  • Location:Kiev, Ukraine
  • Steam:Perebor
  • Deadfire Silver Backer
  • Fig Backer
  • Black Isle Bastard!

Hello,

 

Please raise up your volume to hear the glitching sound

 

This sound is playing with my nerves, seriously. 
 
There is no problem with my sound drivers, Pillars is the only game such problem occurs. 
 
Also I've noticed it's only when you have party members, everything is fine if you solo.
It's not constant, after several loads and changing ground (wooden tiles) sound it's coming to normal.
And comes back after Companion dialogue between each other.
 
And when logging out to the main menu there is a sound of equiping Abydon's Hammer.
 
Fix please?

Edited by Nail, 27 March 2017 - 01:38 PM.


#2
Nail

Nail

    (2) Evoker

  • Members
  • 72 posts
  • Location:Kiev, Ukraine
  • Steam:Perebor
  • Deadfire Silver Backer
  • Fig Backer
  • Black Isle Bastard!

Anyone else had this issue, or it's just me?







Also tagged with one or more of these keywords: sound glitch, sound, no sound

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users