Jump to content
  • 1

Bought Obsidian Edition on Steam, did not get all goodies


Darkheart

Question

Hi there,

 

I bought the Obsidian Edition on Steam yesterday and installed it immediately. Both DLC check as installed.

I made an account at Asmodee (from in-game). Did not get an email to validate the new account (maybe that is the problem). I can log-in to the Asmodee website and see my account details, but no option to resend the email in question.

 

Yesterday I did not get the alt chars. They were unlocked this morning, but I still miss goodies like gold, runes and charms, epic and legendary cards (did get the PoE promo cards, though), Goblin campaign deck...

 

Any advice on how to solve this?

 

Thanks in advance!

Link to comment
Share on other sites

11 answers to this question

Recommended Posts

  • 0

Hi there,

 

I bought the Obsidian Edition on Steam yesterday and installed it immediately. Both DLC check as installed.

I made an account at Asmodee (from in-game). Did not get an email to validate the new account (maybe that is the problem). I can log-in to the Asmodee website and see my account details, but no option to resend the email in question.

 

Yesterday I did not get the alt chars. They were unlocked this morning, but I still miss goodies like gold, runes and charms, epic and legendary cards (did get the PoE promo cards, though), Goblin campaign deck...

 

Any advice on how to solve this?

 

Thanks in advance!

 

Hello! 

 

Please PM me your PFID and i'll see what the issue is.

Link to comment
Share on other sites

  • 0

I had this exact same issue. DLC lists as unlocked on steam but is not in the game. No alt chars, no nothing else.

 

I also encountered another very bad bug. After playing the tutorials I got a lot of nice loot both from playing and from the chests, and I wanted to equip my newly created character with them. I went to the manage decks screen from the scenario select screen, put in the new cards and exited the deck manager. Instead of getting taken to the scenario screen, I got to the create party screen - with no chars selected. I tried to add the chars that I had made, but they were in another party. I wnet back to the main screen and pressed play, and I now had two parties. One with the chars I made, and another with no chars in it. I selected the party with the characters and went to look in their decks to check that they were all right. They were not. Alle the loot cards that I have gotten were gone. They were not on the chars, not in the stash, nowhere to be seen. Now I really don't want to go into the manage decks screen as I am scared to reset my deck again.

 

Is there anything you can do to see what happened and maybe get my cards back? It is not a very good first experience when you have just bought a game that you have waited SO long for.

Link to comment
Share on other sites

  • 0

I thought this had initially happened to me but then found that a new PFID had been created that had all my PC content on (and some of my tablet content).

 

I merged the two IDS and everything appeared on both devices. It could well be that this is the issue on some of these cases.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...