Jump to content
  • 0

Continue and Load Greyed out with saved files are present


Savanamistral

Question

Running 3.02 on Win 10 just after a Win 10 update, "Cumulative Update for Windows 10 Version 1607 for x64-based Systems (KB3213986)".  Invoked Pillars of Eternity (installed via GOG) and found the Continue and Load buttons grayed out.  Followed this issue through several forums, and have deleted the files in the AppData areas, ensured that the Pillars of Eternity exe was invoked as Admin, and reinstalled POP.  Since the New button was not greyed out I did succeed in creating a new game but the reloads from those saves were also hidden behind the greyed out Continue and Load buttons so even restarting a game is not an option. I have basically tried all of the suggestions in the various forums, but if others are having the same problem that I'm reporting, it is not currently clear to me.

 

I've done a bit more investigation.  I found the GOG location for the output_log.txt file in C:\Gog Games\Pillars of Eternity\PillarsOfEternity_Data\output_log.txt.  It reported errors in the savedfiles as ZIP FILE WAS CORRUPT.  It reports this if the only savefile that was available was the last one saved, the first one saved, or a new one from a newly started game.  So files that had worked before to Continue or Load games from were now reported as corrupt even though the timestamp on those files had not changed.  All of the tested savegames file were not marked as readonly.  In each test I deleted the AppData areas suggested and ensured the exe was invoked as admin.

 

My conclusion is that the savegames files are not at fault.  Either the program itself is manifesting an error or the OS environment change is manifested a bug in the program.  One other change was that I deleted Chrome from my system because after switching to Developer mode and load Win 10's Bash environment, it started invoking on startup which I didn't care for.  A red herring, likely, but a change in environment none the less.

 

I would like to continue with my level 12 Cipher.  Would be okay with starting over if I could be assured I could complete the game.  I've enclosed the output_log.txt file from the fresh new game start and my DxDiag.txt file.  I also included the new savedgame files as zip files.

 

output_log.txt

DxDiag.txt

b202e6f7-364c-45bd-b3c7-feac87678e76 autosave_0.savegame.zip

b202e6f7364c45bdb3c7feac87678e76 7656255 Encampment.savegame.zip

Edited by Savanamistral
Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

The savegames you attached work in my PoE without corruption warnings in the log.

 

Sharing violation - another program keeping the files in use?

Try to launch the game as admin with the antivirus disabled and close any program that could be trying to access the user folders.

 

Another user had your same problem, but his output_log.txt error was different ("UnauthorizedAccessException: Access to the path"). He fixed it by restoring the folder permissions: save games not recognized

I've come to burn your kingdom down

Link to comment
Share on other sites

  • 0

Thank you for confirming the savegames files were not corrupt as expected.
 
I had noticed the issue with permissions and ruled that out earlier, but I repeated the removal of the readonly flags just in case.
 
After turning off my antivirus protection, and invoking as admin with no effect, I tried deleting just the 0.png file.  This time the sharing violation disappeared in the output_log.txt file but the Continue and Load buttons were still greyed out.  I also noticed that the 0.png file was still deleted.  I tried a number of games with what files got deleted but still got the non-working Continue and Next buttons although the shared violation stayed removed from the output-log.txt file. 
 
At this point I started to lose track of what I had done and which actions were recreating the various temp files and which were not.  I decided to do a restart from scratch by deleting all of the savedgames and starting a new one.  This time when I saved the new game, I reloaded it immediately.  I then exited, but not all the way.  I reloaded from the New-Continue-Load  screen, and then finally exited completely.  On each of the loads I rechecked the output_log.txt file to ensure the shared violation message was still missing. 
 
Wonders - The next invocation gave me working Continue and Load buttons.  I now went back to my savedgames backup (which I had created at the very beginning of this exercise) and restored my oldest save - it worked.  I'm back in business at lvl 12.
 
Here's what I'll try if this happens to me again.  I'll make a backup of all savedgames file.  I'll read the output_log.txt file now that I know what messages to ignore (I've enclosed the new one where everything appears to be working.)  I'll create a new game, save it, load it, exit to the New-Continue-Load menu and Load.  The I'll exit completely to see if the problem is resolved.  With the problem now gone, it's hard to know exactly what the magic was, but I'm just be happy to be back in the saddle.

 

Thanks

output_log.txt

  • Like 2
Link to comment
Share on other sites

  • 0

I've had this problem with Continue being grayed out - almost everytime I start up - I found a solution which I wanted to share because there are so many posts and not many solutions. 

It seemed to be random at first, and sometimes a restart made it work.  But now it seems that if I have too many saved games it happens - so I go to C:\Users\User\Saved Games where it appears my saved games are for this - which might be the problem - however, I just remove a few earlier saved games and it starts the first time. 

Hope this helps someone because this is truly an annoying bug that has been brought up - for years and years and still no fix... 


 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...