Jump to content
  • 0

Used to run flawlessly, now constant crashes [3.03]


darkholypl

Question

Hi all.

 

Even tho I followed this game since the kickstart, I only just now made an account and not for a positive reason either, I'm afraid...

 

The game used to run perfectly for me after launch, but now with the patch 3.03 I can't finish a single dungeon level without crashing several times...

It crashes at area change, at loads, at save game, sometimes the game just doesn't update the fog of war at all and I need to restart the game...

It's very frustrating, especialy since, like I've said, it sometimes crashes when I try to make a quick save, so I can't even do that to no lose my progress.

 

I've uninstalled the steam version and reinstalled again and I've also did check the game cashe. I'm out of ideas.

 

Any help? 

 

 

i5 3570k @4.4GHz

8GB hyperX ram

saphire R9 280 4GB

win 8.1 64bit

Link to comment
Share on other sites

Recommended Posts

  • 0

*knocks on wood* I MAY have fixed it. I rolled back my GPU drivers, and so far so good. Either it's fixed, or I was just being extremely lucky last night. 

 

 

EDIT: ..well I guess I was just lucky. Still getting crashes, but not nearly as frequent. Still at a loss what the reason is. 

 

If anyone has something of substance to say about this, I would listen.

Edited by darkholypl
Link to comment
Share on other sites

  • 0

Shame on the save, could show if it was replicable on other computers.

For Pillars I warmly recommend you to keep several regular saves.

Forgot to tell you that you get a new output_log when you start the game.
To save any information on the crash you'll need to save the output_log.txt just after.

I've come to burn your kingdom down

Link to comment
Share on other sites

  • 0

Ok so as (ill) luck would have it, the game just crashed on me. I was trying to make a quick save, and that is when the game crashed, The save was not made, but I do have a nearby quicksave still.

 

Here are the output log and the save file: https://www.dropbox.com/s/aiyu4ppquse3met/4dded61c-279b-4647-85d1-0b972e6058cd%20quicksave.savegame?dl=0

                                                                  https://www.dropbox.com/s/evghycsuqbrr23z/output_log.txt?dl=0

 

 

The save is right at the door. All I did was enter the House, go up and talk to Kurren. After talking, and accepting a quest to go look for missing people I pushed F5 to make a quick save, and that is when the game crashed.

 

Out of curiosity I was running GPU-Z to see if my temps were in order. They were, so that is not the problem.

Link to comment
Share on other sites

  • 0

Eh, the crash interrupted the log. Windows logs probably stored some information, but it's hard to say how useful those can be. You can look at the event viewer (run->eventvwr), and double click the events.

Also check the programs active in background. For example evga precision crashed Pillars.

 

Other stuff:

The "NullReferenceException: Object reference not set to an instance of an object " lines are repeated ad infinitum around the Warden in the Sanitarium.

 

NullReferenceException: Object reference not set to an instance of an object
  at AIController.IsWithinEngagementRange (UnityEngine.GameObject enemy, .AttackBase attack) [0x00000] in <filename unknown>:0

  at AIController.CanEngageEnemy (UnityEngine.GameObject enemy, .AttackBase attack) [0x00000] in <filename unknown>:0

  at AIController.UpdateEngagement (UnityEngine.GameObject owner, .AttackBase attack) [0x00000] in <filename unknown>:0

  at AI.Achievement.PerformAction.Update () [0x00000] in <filename unknown>:0

  at AIState.BaseUpdate () [0x00000] in <filename unknown>:0

  at AIStateManager.Update () [0x00000] in <filename unknown>:0

  at AIController.Update () [0x00000] in <filename unknown>:0

  at AIPackageController.Update () [0x00000] in <filename unknown>:0
 
(Filename:  Line: -1)

 

I've come to burn your kingdom down

Link to comment
Share on other sites

  • 0

Could you try starting a new game with a new character, to see if that does work (if you haven't already tried that, since the update)? It's just a hunch, but with all the "filename unknowns" flying around in the log I'm starting to believe that this is a savegame incompatibility of some kind. Looking at the savegame itself, this is an old game you started last year and recently picked up again, and it might well be that for whatever reason the 3.03 version cannot parse it correctly anymore.

 

If this is the issue I cannot quite explain why I had no problem loading your savegame myself (not so far anyway, but my output log isn't showing any signs of trouble here either); it might be that I have WM 1 & 2 installed whereas if I'm not mistaken you do not. Not sure why that would matter, but it might do. Anyway, trying a new game would tell if the (age of) the save game is somehow an issue. 

Link to comment
Share on other sites

  • 0

Well I might try that, but I do not intend to start the game from zero at this point. Time is at a premium as is. And yes, you are right, I do not have WM1 nor 2 installed and yes, this is an old save game that I've recently picked up again.

 

Oh well, I guess I'll just brave through it. It's not like I can't make any progress, it's just that it crashes randomly with no warning. Might take me longer to finish, but I will. 

Link to comment
Share on other sites

  • 0

Well, it's a segfault, which isn't surprising. It seems the game was trying to access memory not mapped to it, which is the kind of problem no program can really recover from. It's also not very surprising, since it was a data access issue to begin with. 

 

The error occurs in particular during deserialization which, paired to the earlier description of the issues when playing the game, to me again suggests that there is some kind of incompatibility between the old save game and the current installed game. Have you already tried whether the same issues occur when you start a new game with a new character? Knowing whether that is the case or not would be a strong clue as to whether the problem is indeed with the save game specifically or with your installation of the game in general.

Link to comment
Share on other sites

  • 0

It shouldn't in terms of installation in that sense, no (it theoretically still could, but that would be quite unlikely). But it could be in a more general sense, ie. a finnicky virus scanner interfering somehow (there have been some reports of a different kind of issue where something like that was probably the cause, strange interactions like that can happen sometimes). Again not very likely though, at face value that doesn't fit the symptoms, but it's possible.

Edited by Loren Tyr
Link to comment
Share on other sites

  • 0

I am having the game crash like CRAZY, as well.  I didn't even have it crash like this when I first downloaded it, not long after release.  It is, quite frankly, highly irritating.  I have the Steam version, so I assume that it is updated to the most current build...  And I'm not smart enough to find or make logs. 

 

The issues are almost identical.  I go to level someone up or leave an area... and crash. 

 

Hopefully this works:

 

https://drive.google.com/open?id=0B18FcuaRvyD2ME1uTWplT0Z3UWc

Edited by Michael_Galt

"1 is 1"

Link to comment
Share on other sites

  • 0

@Michael The file TempSaveData.zip under C:/Users/usuario/AppData/Local/Temp/Obsidian Entertainment/Pillars of Eternity is corrupted, delete it.

See if it works.

 

I tried that.  I could at least leave the Gilded Vale Inn and talk to the dwarf.  Then I recruited the blonde guy and when I went to level him up... crash again.  I tried loading the save that I made before leveling him?  Crash.

 

New files: https://drive.google.com/open?id=0B18FcuaRvyD2ZTZaQ0UtaGJ3UTg

"1 is 1"

Link to comment
Share on other sites

  • 0

I have no idea what is going on.  This is super annoying and frustrating.  Quite frankly, for how much people love to complain about how buggys Obsidian games are, I've really never had an issue with any of their games, and have played nearly all of them.  That being said, this is practically game-breaking, and this is after I don't know how many patches.  I left the Gilded Vale Inn and decided to skip the tree and the blonde guy and just go back north to explore a little.  Everything there went fine.  Then, I saved, and decided to travel back to the Gilded Vale, thinking maybe that it had "fixed itself".  Then, before loading me in the Gilded Vale, it crashed again...  I have probably 10 crash reports on my computer now. 

 

HALP!

"1 is 1"

Link to comment
Share on other sites

  • 0

I could be wrong, but it seems to be related to the tree.  I have 2 saves that I made after speaking with the dwarf.  Now, I can't load either of those... So, I'm going to try the save from BEFORE that... and that didn't work either.  It seems like all of my saves are just getting corrupted, or something... :l

"1 is 1"

Link to comment
Share on other sites

  • 0

I went and uninstalled and reinstalled the entire game.  I couldn't load a single save from inside the Gilded Vale.  I then loaded the save from BEFORE returning from the Gilded Vale, and it loaded.  Then I returned to the Gilded Vale and went to the smithy, skipping the tree and the blonde guy.  Bought stuff.  Went to leave smithy.  Crash. Now at 21 crash reports in total.

 

WHAT IS GOING ON???

 

I should not have my computer crashing over and over and over again.  ESPECIALLY when I didn't have any problems with the game before, at all, basically.  I don't remember it crashing on me once, to be honest.  And I've played Mass Effect, Shadowrun, and a fair number of other games in the intervening time, and they haven't crashed on me either, or, very, very infrequently to the point that I can't even really remember it.

 

* Further update.  I went and ran a memory test on my installed memory, to make sure that I don't have some sort of internal problem there, thinking it might have something to do with that.  The test showed zero problems...  I want to play this game, but I can't even leave the stupid smithy or recruit Eider...

 

* I'm not playing the game any further, because I CAN'T.  I tried to load my last save, which was right before recruiting Eider, and it crashed.  I DID recruit him and tried to enter the nearby monastery... and it crashed.  So, it SEEMS to be related to him.  When it crashes, I see that my memory is pretty much maxed out.  It's just crazy to me, that I played this before, without problems, and now I literally can't even transition a single area, practically.  I've played Fallout: New Vegas, Skyrim, all the Mass Effects, and my computer was fine with those... yet I can't play Pillars of Eternity, which SHOULD have much lower specification requirements and that I formally could play without problem... 

 

So, HOPEFULLY someone helps me with this, because I've been posting since 7 in the morning, and no one has said anything in the past 5 hours... and YES, I've been "bumping" the post in the attempt to get it attention.  But, I'm not going to write more today, because I'm sick of having it crash, and it is completely unacceptable that I can't progress beyond a completely necesarry central plot point. 

Edited by Michael_Galt

"1 is 1"

Link to comment
Share on other sites

  • 0

Could you post the save game you have from before Gilded Vale that you can load, and one of the ones from inside Gilded Vale that you can't? Then I can try them out in my installation to see whether the issue is with the savegames (somehow becoming corrupted by a bad file in your installation, for example) or something else. Do you have White March installed, or just the base game?

 

Location of the savegames is described here, by the way: https://forums.obsidian.net/blog/7/entry-175-location-of-save-games/

Link to comment
Share on other sites

  • 0

So, HOPEFULLY someone helps me with this, because I've been posting since 7 in the morning, and no one has said anything in the past 5 hours... and YES, I've been "bumping" the post in the attempt to get it attention.  But, I'm not going to write more today, because I'm sick of having it crash, and it is completely unacceptable that I can't progress beyond a completely necesarry central plot point. 

Some people sleep, and in the other hours they go to work ;)

 

From the Output Log: Game is running Windows 32 Bit

 

Your statement that it is happening in Gilded Vale let me look at this again. You need to increase the memory avalialbe for programms.

 

See here: http://forums.obsidian.net/topic/86079-workarounds-and-troubleshooting-4-19-16/ The last block, 32bit Operating System

 

Or just put this in cmd or powershell and then reboot, the first allows the os to use full 4gb, the second allows each user process to have more than 2GB ram at a time.

bcdedit /set nx AlwaysOn
bcdedit /set IncreaseUserVA 3072

Gilded Vale is the first map to use more than 2GB limit so its the first point where the game is crashing, and it has done so since ever.

Edited by Xaratas
Link to comment
Share on other sites

  • 0

 

So, HOPEFULLY someone helps me with this, because I've been posting since 7 in the morning, and no one has said anything in the past 5 hours... and YES, I've been "bumping" the post in the attempt to get it attention.  But, I'm not going to write more today, because I'm sick of having it crash, and it is completely unacceptable that I can't progress beyond a completely necesarry central plot point. 

Some people sleep, and the other hours go to work ;)

 

From the Output Log: Game is running Windows 32 Bit

 

Your statement that it is happening in Gilded Vale let me look at this again. You need to increase the memory avalialbe for programms. http://forums.obsidian.net/topic/86079-workarounds-and-troubleshooting-4-19-16/ The last block, 32bit Operating System

 

Gilded Vale is the first map to use more than 2GB limit so its the first point where the game is crashing, and it has done so since ever.

 

That makes sense.  How is it that I can increase the memory available?? I mean, I don't have almost anything else running in the background. And did this not increase??  I didn't have any problems before...

"1 is 1"

Link to comment
Share on other sites

  • 0

I just figured out the problem...  I "upgraded" to Windows 10 earlier this year... and they gave me the 32bit version.  So, even though I have 8gb of RAM... I can only use 4 of that... Which means, that when I need to have at least 2gbs, my system gets overloaded...  So, now I'm in the process of trying to get Windows 10 64bit, like I should have... so I can use my full 8gb of RAM :/  Stupid Windows!!!  :banghead:

"1 is 1"

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...