Jump to content
  • 0

Heavy mess-up bug in encounter at Waterfront


Tootzo

Question

Hi guys.

This just happened to me.

I was playing Brigandoom with Merisiel and Kyra (solo play, story mode).

Kyra was on the Wooden Bridge, Merisiel at Waterfront.

Kyra encountered an ancient skeleton horde and defeated her skeleton with no problem.

I then proceeded with Merisiel's encounter.

I revealed a dagger to roll 1d12+1d4 ant the game correctly bumper the difficulty of the fight from 8 to 11 due to piercing damage to the skeleton. It also added the -2 penalty to the roll, from the AT THE LOCATION section of Waterfront.

I then recharged a card to activate Merisiel's Sneak Attack and it added 1d6 to my dice pool and another -1 from Waterfront penalty.

Then things started getting weird.

I inadvertently clicked on the shop icon. When I got back from the shop, the skeleton card was missing, the Skeleton Horde barrier mini-card was missing too, my dice pool was the same as before (1d12+1d4+1d6) but the penalty from waterfront had been doubled and read -6!

I force quit the game and restarted. When I hit continue, the game was in the very same situation: missing both ancient skeleton card and the miniature of the barrier card that spawned the skeletons; but the penalty was then -9!!

I tried quitting the game or force quitting the app a few times but the penalty never increased anymore and it was stuck at -9.

Another nasty thing happened in this situation: if I switched to Kyra and play a couple of cards to aid Merisiel, they get counted correctly and if I hit the undo button on the left, then all the cards played by Kyra get back in her hand and everything gets back to what was before.

But if I try to do the same on Merisiel's screen, all I can undo is the activation of her sneak attack: I lose the die, the power is again available to use but I don't get the card back from recharging! O_o

Moreover, shouldn't the undo button revert back to the start of the encounter, undoing also my revealing of the dagger card and setting the dice pool back to the default 1d8 for Merisiel's strength value?

I think something got broken in that encounter when I entered the shop page and it now seems to be unable to get back to the start of the encounter, thus incorrectly calculating the penalty from the location and not displaying the monster card and barrier card that summoned the skeleton.

 

I'm playing on an iPad 3 with iOS 9.3.1

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

My actual problem wasn't that I was stuck in that condition. I actually didn't try to see if I could proceed with the combat.

I forfeited the game and I was able to get to the deck management screen, so it seems I can try the scenario once again (anyway I was poorly losing XD)

I've yet to restart the game and try again.

I'll keep you posted.

  • Like 1
Link to comment
Share on other sites

  • 0

As a side note, I highly recommend using Merisiels evade ability in most summoned monster situations. Most, but not all, barriers and villains that summon monsters for you to fight (including Skeleton Horde) don't specify that the summoned monsters must be defeated to defeat the barrier or villain card. Unless it specifies that "this card is only defeated if all summoned monsters are defeated" or something similar, Evade is your friend!

  • Like 1
Link to comment
Share on other sites

  • 0

Thanks Brainwave. I actually didn't notice I could defeat those barriers just evading the fight ;)

I then tried the scenario a couple times more and was finally able to defeat it ^_^

The cumulative penalty bug hasn't returned for the moment.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...