Jump to content
  • 0
Sign in to follow this  
Ranes

3.01 bug: Mac sudden frame rate drop

Question

Hi, I’m playing 3.01 bought through the app store on a fully up-to-date Mac with a dedicated GPU (system details attached). About the only nasty bug I regularly encounter is the frame-rate-falling-off-a-cliff issue. I’ve tried to find what it is that causes this but, until today, it has always seemed random (bear in mind I only bought the game a few weeks ago). The cure is always and only to quite to desktop (quitting to main menu never cut it), re-launch and cross my fingers. Sometimes I can play for hours without encountering the bug; sometimes it’s there on re-launch and I simply have to start over.

 

Well, today I have a what appears to be a repeatable trigger for this bug. Whenever I invoke the local area map while exploring Cliaban Rilag the frame rate bombs.

 

I hope this is going to be a Rilag-specific problem…

 

Anyway, feast on these files, if you like (system spec, save game, output log). Hope they help.

 

Dropbox link:

 
 

And thanks for PoE.

 
 

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

I guess I should reply to this, having just read my own log file. There are numerous error messages in it. Though I haven't read all of these, some may appear relevant (but I doubt it, on grounds that I'll explain below), I moved the app from its default installation folder to an external drive. My Mac has a small SSD that is packed to the brim. I run several of my games from an external USB 3.0 drive, including other games bought via the Mac app store.

 

When I moved the app at first, it fell over at the launch screen. I wrote to MacPlay (providers of the app store version) and they said they hadn't been asked before about moving the file. I got it working by opening the app contents and bypassing the MacPlay launcher, running the game directly. This works every time. I wrote to MacPlay to alert them of this and they said it would be addressing it in a future patch (of their launcher, presumably).

 

That's great. But I'm not convinced that my unusual installation location is responsible for the glitch, in spite of error messages in the log relating to that install location. The reason I doubt it's relevant is simply this: the bug occurred even when I was running the app from the default location.

 

Anyway, I just wanted to address this in case any of your devs were looking at those lines in the log file and thinking, "Ah, well we can stop here."

 

I think there's something else for you to find.

 

But you lot know more than me, so this is just a full disclosure moment.

 

Cheers.

 

Share this post


Link to post
Share on other sites
  • 0

Hey Ranes,

 

Looks like you were right about those errors in your log. I would suggest to uninstall and reinstall the game and see if that helps. Also you can move the Quality Slider all the way to the left in the Graphics section in Options.

 

Thanks!

  • Like 1

Whats this at obsidian.net?

Share this post


Link to post
Share on other sites
  • 0

Hey Ranes,

 

Looks like you were right about those errors in your log. I would suggest to uninstall and reinstall the game and see if that helps. Also you can move the Quality Slider all the way to the left in the Graphics section in Options.

 

Thanks!

 

Hi Aarik D,

 

Really appreciate the response. Okay, I've done some ruthless file culling to make enough SSD real estate available, reinstalled the game and restored my save games. Now I'll experiment. I'll just try the game as it is to start with. If I encounter epic frame rate drop, I'll copy the saved game and log files. Then, I'll try the moving the quality slider as you suggest and see what happens. Again, I'll copy the save and log files. And then I'll report back.

 

Meanwhile, thanks again for the help. 

Share this post


Link to post
Share on other sites
  • 0

Looks like you were right about those errors in your log....

 

I played all evening yesterday with the quality slider set to maximum and didn't experience any problems at all. So your were right. I was wronger than Wrong "Wrong" McWrong, winner of last year's Mister Wrong Competition (apologies to Rowan Atkinson). I didn't think that the installation location would have anything to do with it. I was sure I'd encountered the issue before moving the game to an external drive. But it seems completely fine now, despite dozens of map uses and area transitions. So, thank you.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...