Jump to content
  • 0
pasgrave

Uses integrated graphics instead of dGPU on Surface Book

Question

Pillars of Eternity runs awful (max 30 fps at 1600x1200) on a Surface Book even though it has a fairly decent 940m-ish dedicated GPU.  There's no log file in the directory or console command that would allow me to verify which graphics card the game is actually using, but it seems like the integrated graphics card is used no matter I do.  I've tried forcing the game to either use the integrated graphics or the dGPU by using the Nvidia manager but it doesn't affect performance at all.  I've even tried disabling the integrated graphics card in the device manager and it actually lowers the fps to 1-4 fps even in the menu.  There seems to be a problem with Unity 4 games defaulting to integrated graphics but I've never found any solution.  Any advice in how I can force the game to use the dedicated GPU?  I've tried updating drivers, looking through the registry, etc.  

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Hey pasgrave,

 

Welcome to the forums! While we have never tested the game on the Surface Book, you can still gain access to the system specs and an output log. You can find those files by clicking on the link in my signature. If it is an issue with Unity 4 games, then there is nothing we can do to fix that. However, if you go Power Options in the Control Panel, you can set the preferred plan to High Performance and that should set your Surface Book to the higher GPU.

 

Hope that answers your question, 

 

Thank you for your support!


Whats this at obsidian.net?

Share this post


Link to post
Share on other sites
  • 0

I'm also using a Notebook with integrated plus dedicated graphics (hybrid). When I use the Nvidia Settings to switch to the Nvidia device it works. So maybe that's not a Unity related problem but one of the Surface Book? I doubt it's a hardware problem though. 


Deadfire Community Patch: Nexus Mods

Share this post


Link to post
Share on other sites
  • 0

I managed to find the output_log.txt which says that the dedicated GPU is in fact being used.  It still seems strange that I don't see any performance change when switching between integrated and dedicated graphics, but I guess it could be a driver issue since there hasn't been an official update of surface book drivers so far (although the most recent version of the nvidia drivers install without problem).  The poor performance might also be due to the fact that the monitor is very high resolution (3000x2000) and then scales the desktop by 200%.  Performance is better when I use windowed mode instead of fullscreen, or when I modify scaling from the desktop settings (it actually runs better when I raise scaling to 300%, although that may be due to it actually running on a lower resolution).  It might be a Unity issue with high-resolution / scaled desktops since Dungeon of the Endless, which is also apparently a Unity 4 engine game, runs at about half speed until I lower the desktop resolution to match the in-game resolution.  "Fullscreen" in both Dungeon of the Endless and Pillars of Eternity really seems to be more like "Borderless Windowed" in a lot of other games, which sometimes creates problems with scaled desktops.  

 

In any case, thanks to both of you for your help and I'll keep messing with the settings to see if I figure anything out.  

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...