Jump to content
  • 0
AndreaColombo

3D models upscaled at level up

Question

Despite being real-time rendered 3D objects, character models are upscaled in the level-up screen if playing at resolutions higher than 1920x1080.

 

SAVED GAME: link

 

REPRO STEPS:

Load the attached saved game on a machine whose monitor runs natively at 2560x1440 or higher.

Observe that all characters have enough experience to level up.

Pick one of the characters and level them up.

Observe that when the level-up screen is brought up, the 3D model of the character is blurry as though it was being upscaled.

 

Being real-time rendered 3D objects, characters models should always be rendered at the resolution the game is set to, and never upscaled.


"Time is not your enemy. Forever is."

— Fall-From-Grace, Planescape: Torment

"It's the questions we can't answer that teach us the most. They teach us how to think. If you give a man an answer, all he gains is a little fact. But give him a question, and he'll look for his own answers."

— Kvothe, The Wise Man's Fears

My Deadfire mods: Brilliant Mod | Faster Deadfire | Deadfire Unnerfed | Helwalker Rekke

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Since ultra-wide screens are becoming more common (especially the curved variants), checking if 3440x1440 also is problematic along with 2560x1440 would probably be worth it.

Share this post


Link to post
Share on other sites
  • 0

Would be totally rad if 3.0 fixed this

  • Like 1

"Time is not your enemy. Forever is."

— Fall-From-Grace, Planescape: Torment

"It's the questions we can't answer that teach us the most. They teach us how to think. If you give a man an answer, all he gains is a little fact. But give him a question, and he'll look for his own answers."

— Kvothe, The Wise Man's Fears

My Deadfire mods: Brilliant Mod | Faster Deadfire | Deadfire Unnerfed | Helwalker Rekke

Share this post


Link to post
Share on other sites
  • 0

hello~~

 

as I understand it, there's been problems reproducing this. I don't know if that's because it's not happening at dev machines, or if you're just not noticing it, but here are some convenient ways to reproduce it no matter what display you have. Just so there's no doubt, here's an example at 2560x1440 and 2560x1600.

 

This is for linux, as I don't know how to arbitrarily set the resolution of a panning view on windows. I assume there exists tools for windows as well. In any case, since I have this happening under both windows and linux regardless of hardware, I don't think it matters that much.

 

I'd suggest doing this on a 1920x1080/1200 display, but 2560x1440 will also do. Displays that are natively above 2560x1440 won't work well using these instructions (perusing the xrandr manpage though will give you good pointers).

 

First off, start a terminal window. Then type

 

xrandr
this should give an output similar to this:

 

HDMI1 connected primary 1920x1200+0+0 (normal left inverted right x axis y axis) 518mm x 324mm
   1920x1200     59.95*+
   1920x1080     60.00    50.00    59.94  
   1600x1200     60.00  
..and so on. What you need is the identifier of the "connected primary" display, in this case HDMI1.

 

If your display is not natively 2560x1440, run this command (NB! This will not work if your display is natively ABOVE 2560x1440!):

 

xrandr --output HDMI1 --panning 2560x1440
(substituting HDMI1 for the identifier you found above. You can also use substitute 2560x1440 with an arbitrary resolution to see what resolutions work correctly in Pillars of Eternity)

you should now have a panning display of 2560x1440. Moving the cursor to the edge of the screen will scroll it around.

 

Now, start PoE and make sure the resolution selected there is 2560x1440. Start a new game, or load an existing game and levelup a character. You should see a quite upscaled character model. This is actually easier to see if you're running on a display with a "low" native resolution (e.g. 1920x1080).

 

Exit PoE, and re-run the xrandr command with another panning resolution (e.g. 2560x1600):

 

xrandr --output HDMI1 --panning 2560x1600
Start PoE again, make sure the in-game resolution is 2560x1600, and start a new game. Observe that the character model is now sharp and clear.

 

To disable the panning, run xrandr like so:

 

xrandr --output HDMI1 --panning 0x0
I've consistently reproduced this on entirely different hardware, using AMD, Intel and nVidia cards.

 

Here are screenshots of some different resolutions. Particularly 2560x1440 vs 2560x1600 are very good to look at, as they are almost the same size -- only the height is different, and poe handles that difference by padding at the bottom and top of the screen, which means they should otherwise look identical:

Closeup at 1920x1200

Closeup at 2560x1440

Closeup at 2560x1600

1920x1200

2560x1440

2560x1600

 

I hope all of this makes it easier to see the issue, and reproduce it using your own hardware.

If there are any questions around this, I'll be happy to answer and/or test as necessary (by forum post, PM, email or anything really)!

  • Like 2

Share this post


Link to post
Share on other sites
  • 0

^ That's exactly what I see, too.


"Time is not your enemy. Forever is."

— Fall-From-Grace, Planescape: Torment

"It's the questions we can't answer that teach us the most. They teach us how to think. If you give a man an answer, all he gains is a little fact. But give him a question, and he'll look for his own answers."

— Kvothe, The Wise Man's Fears

My Deadfire mods: Brilliant Mod | Faster Deadfire | Deadfire Unnerfed | Helwalker Rekke

Share this post


Link to post
Share on other sites
  • 0

I don't think we'll ever get crisp models at 1440p :( devs can't seem to repro.

 

To think I bought this screen for PoE...


"Time is not your enemy. Forever is."

— Fall-From-Grace, Planescape: Torment

"It's the questions we can't answer that teach us the most. They teach us how to think. If you give a man an answer, all he gains is a little fact. But give him a question, and he'll look for his own answers."

— Kvothe, The Wise Man's Fears

My Deadfire mods: Brilliant Mod | Faster Deadfire | Deadfire Unnerfed | Helwalker Rekke

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...