Jump to content
  • 0

Graphics ptions for low requirements on further patchs?


Question

Hello everyone, I am writing to ask if you could include graphic options to run pillars of eternity in laptops/PCs with low resources more efficiently in future patches?

 
I'm trying to play on a i3 M 330 2.13GHz 2.13GHz With 2GB RAM and successfully brought on my team lvl 4 ... but my laptop get crash on the 60% - 70% of the loading screen due to the low requirements of my laptop and its result really frustrating to me cause i love this game.
 
The only thing i have done is remove the antialiasing with the command console "msaa 0"
 
If there is any other command console i could use to get a better frame rate on the game I also appreciate
 
Please help me, im sure im not the only one who would love to play this awsome game having a low resources PC/laptop
 
Thks.
Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

Hi,

 

I'm in a situation like yours, the game runs fine on my static computer, but it runs like crap on my laptop.

The anti aliasing option coming with the update helped a bit to get more FPS, but the main setting availabel at the moment seems to be the resolution.

 

By default, I'm at 1600 x 900 and downgrading it to 1280 x 720 (which is the minimum) gives me FPS but the UI looks very bad.

I think the most cpu/GPU intensive is the quality of effects and models (characters, water movements, lights ...)

 

I used stuff like game booster by Razer and others windows optimizing softwares, the gain isn't big but it still helps.

 

By default :

1600 x 900

Anti aliasing max

FPS (only in the first place of the game) : 10-20

 

Whent putting anti aliasing to mini :

FPS : 15 - 25

 

When putting in 1280 x 720 :

FPS : 20 - 27

 

Some would say that about 30 FPS is okay, but it's the performance when my laptop is "cold", after a few minutes, the FPS drops to 10.

 

I've already been searching for low end PC mods, but there is'nt yet.

 

The most efficient solution I found, still unplayable, is to modify the  compatibility mode of the game and launch it with 640 x 480 resolution, the FPS gain is obvious but the UI doesn't work under the 1280x720 limit.

 

But there's a starting with this tool : http://www.nexusmods.com/pillarsofeternity/mods/27/?

 

The Idea would be to extract the assets to get a zero compression folder which would take more disk space but need less ressource to be used.

 

You can read the discussion on this mod, there are many troubles using it but maybe, with a new version, it will be possible.

 

Anyway, I hope a new update would come with settings about quality models and shaders.

I know it's a great game, but it's almost impossible to play it for more than 2 hours without over heating the pc.

  • Like 1
Link to post
Share on other sites
  • 0
Some would say that about 30 FPS is okay, but it's the performance when my laptop is "cold", after a few minutes, the FPS drops to 10.

 

Future performance improvements aside, I think you should also focus a bit on the cooling of your laptop. This really looks like it's running too hot due to some issue with the cooling system.

Make sure the fans/exhausts are clean and unobstructed. Cleaning the fans of a laptop can often work wonders.

There are also external laptop coolers available for a few bucks. I've never used one, but allegedly they can help quite a bit.

Link to post
Share on other sites
  • 0

To the OP - I think they mentioned somewhere that they are going to optimise how maps load, so the game doesn't run out of memory and crash as much on 32-bit systems with less RAM. In your case I reckon the biggest problem is the 2GB RAM - you might want to close absolutely everything else that might be eating RAM, or just bump it up to 4GB if you can.

 

I play on a laptop that's below minimum requirements on everything but RAM, and it doesn't run too badly at all.

Link to post
Share on other sites
  • 0

Thanks for the advices, I'm definitly going to look for a good cooling system.

 

As I said, the game runs fine with a static pc, but on a weak laptop without cooling except the fan (mine would need a little clean up), the need of Low graphic settings is very important.

 

Maybe the modding community will make it possible to modify the UI to adapt it with a 1024 x 768 or less version, 800 x 600 in Baldur's Gate II is just fine in my opinion.

  • Like 1
Link to post
Share on other sites
  • 0

Hi,

 

I'm in a situation like yours, the game runs fine on my static computer, but it runs like crap on my laptop.

The anti aliasing option coming with the update helped a bit to get more FPS, but the main setting availabel at the moment seems to be the resolution.

 

By default, I'm at 1600 x 900 and downgrading it to 1280 x 720 (which is the minimum) gives me FPS but the UI looks very bad.

I think the most cpu/GPU intensive is the quality of effects and models (characters, water movements, lights ...)

 

I used stuff like game booster by Razer and others windows optimizing softwares, the gain isn't big but it still helps.

 

By default :

1600 x 900

Anti aliasing max

FPS (only in the first place of the game) : 10-20

 

Whent putting anti aliasing to mini :

FPS : 15 - 25

 

When putting in 1280 x 720 :

FPS : 20 - 27

 

Some would say that about 30 FPS is okay, but it's the performance when my laptop is "cold", after a few minutes, the FPS drops to 10.

 

I've already been searching for low end PC mods, but there is'nt yet.

 

The most efficient solution I found, still unplayable, is to modify the  compatibility mode of the game and launch it with 640 x 480 resolution, the FPS gain is obvious but the UI doesn't work under the 1280x720 limit.

 

But there's a starting with this tool : http://www.nexusmods.com/pillarsofeternity/mods/27/?

 

The Idea would be to extract the assets to get a zero compression folder which would take more disk space but need less ressource to be used.

 

You can read the discussion on this mod, there are many troubles using it but maybe, with a new version, it will be possible.

 

Anyway, I hope a new update would come with settings about quality models and shaders.

I know it's a great game, but it's almost impossible to play it for more than 2 hours without over heating the pc.

 

Completely agree with you.

 

Hope obsidian can add some settings to run this game better on laptops with low resources and we can enjoy this awesome game.

Link to post
Share on other sites
  • 0

Hi,

 

After a few days waiting for performance updates or mods, I've found something which may help some of you.

 

The game supports some settings directly from the launcher, these are hidden settings and may improve performance, but also can simply crash the game at launch.

 

So to avoid any problem, backup your saves before doing anything.

 

 

You've got to make a shortcut of the launcher and modify the path of this one, for example :

 

The defaut path for me is :

"C:/GOG Games/ Pillars Of Eternity/Pillars.exe"

 

After the last ", you can add these lines :

 

-force-d3d9 : Make the game using Direct X 9

-force-d3d11 : Make the game using Direct X 11

-force-opengl : Make the game using Open GL instead of any Direct X

 

For example, to use direct X 9 : "C:/GOG Games/ Pillars Of Eternity/Pillars.exe" -force-d3d9

 

I don't know for you, but for me, this setting makes the game more smooth (about + 5-10 FPS) but also a bit ugglier, especially with the effects, but man, that's the purpose of this topic.

Link to post
Share on other sites
  • 0

Hi!

 

I just tested out the dx11 one (-force-d3d11) and it run a lot smoother on my laptop ( CPU: 2350m 2.3Ghz, RAM: 8GB DDR3 1333Mhz, VGA: Geforce GT630m 1GB, HDD: Kingston SSD 240GB, OS: Windows 7 sp1 64bit).

 

I only experienced some graphical bugs in UI especially with the local area map and on the inventory screen with the item category icons so far.

I hope that these are the only drawbacks of forced dx11 mode.  :)

 

 

My graphics settings in game are: -resolution: 1080p

                                                      -screen mode: windowed fullscreen

                                                      -vsync: off (also disabled in nvidia controll panel)

                                                      -graphic quality: min

                                                      -max fps: 60

 

With these settings PoEt is very playable on my machine.

Edited by Pegazus
  • Like 1

There are more things on earth and in the sky than you can dream about.

Link to post
Share on other sites
  • 0

You sure it's low resource and not some game bug? I run it on old laptop with embedded intel gpu (hd4k) and 4Gb or ram - it's sufficient to work smoothly at full-hd resolution. Still impossible to play due to impressive amount of gamebreaking bugs but that's another story.

Link to post
Share on other sites
  • 0

...For example, to use direct X 9 : "C:/GOG Games/ Pillars Of Eternity/Pillars.exe" -force-d3d9

 

I don't know for you, but for me, this setting makes the game more smooth (about + 5-10 FPS) but also a bit ugglier, especially with the effects, but man, that's the purpose of this topic.

PoE uses DX9 by default, so forcing it shouldn't make any difference. If you are encountering problems related to DX9, it may be worth downloading and installing the full DX9 redistributable from Microsoft:

 

DirectX End-User Runtimes (June 2010)

 

As for performance issues, it should be trivially easy for Obsidian to provide simpler graphics (disabling reflections/shadows/bloom, reducing spell animations, using low-poly-count models) but it's only likely to happen if enough people ask for it. A game like PoE should be able to run on 1/10th the specified minimum hardware (two similar games: Temple of Elemental Evil required a 700MHz CPU, 128MB RAM and a 32MB graphics card; Beyond Divinity an 800MHz CPU, 256MB RAM and a 64MB graphics card) so there should be significant scope for optimisation, should Obsidian care to resource it.

 

Until then, those with issues may want to experiment with adding the following (unsupported) options to their PoE shortcut:

 

-force-opengl

 

(this made no performance or graphical improvement on my system and resulted in increased memory usage but others' mileage may vary)

 

-screen-quality Fastest

 

(this made no perceptible difference for me, but should enable the lowest graphics quality level).

Edited by AstralWanderer
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...