Jump to content
  • 0

[Bug report][Linux] Screen not centering on party after area change


Question

After every area change, the screen is NOT centered on party but somewhere else on the map and i have to scroll everytime (which is really annoying). I seems that it is usually somewhere in the lower left corner of the map. The party is usually very far away so i don't even see them without long scrolling.

  • Like 2
Link to post
Share on other sites

22 answers to this question

Recommended Posts

  • 0

After every area change, the screen is NOT centered on party but somewhere else on the map and i have to scroll everytime (which is really annoying). I seems that it is usually somewhere in the lower left corner of the map. The party is usually very far away so i don't even see them without long scrolling.

 

I can second that.  Happens for me too.  One tip: you can click on the little "offscreen" character icons to instantly move your view to center on your party.

  • Like 2
Link to post
Share on other sites
  • 0

In case it's useful, some more info:

 

[v1.0.3.0530, Linux, GOG]

 

Description:
When "Screen Edge Scrolling" option in the Game menu tab is enabled, at almost every area transition and reloading the game screen is centered on the left bottom corner of the map, regardless of the party position.

 

Almost every area transition means that in few cases there was on party centered reload -- sometimes when changed screen resolution and/or fullscreen option and/or reload from the main menu. But so far, I'm not able to reproduce those few cases consistently.

 

Further, right after area loading the game doesn't react to the arrow keys at all, till the mouse itself is moved. Then the arrows start work ok.

 

When the "Screen Edge Scrolling" option is disabled, the game screen is properly centered on the party.

 

 

 

Comments:

In past Beta BBv435, there was issue with the screen-to-corner traveling, in case it's possible related:

 

http://forums.obsidian.net/topic/70469-435-linux-self-scrolling-on-map-transition-or-alt-tab/

 

Edit:

Also added to the unofficial bugtracker:

https://github.com/PoE-unofficial/Pillars-of-Eternity-bugtracker/issues/4

 

I hope you don't mind?

Edited by ushas
  • Like 1
Link to post
Share on other sites
  • 0

I posted about this on the steam forum a few days after this report, and there is confirmation there from a Windows 7 user, Arfur Brain, that it is not just Linux. The current theory is that it is a Unity-specific bug. Can someone from Obsidian please get in contact with Unity about this? I'm skeptical that a couple of Linux users asking them about something are actually going to make them do anything.

  • Like 1
Link to post
Share on other sites
  • 0

I should note that I am still seeing this in the 1.0.4 beta (1.0.4.0540 beta), though I'm not sure if any progress can be made on Obsidian's end. Has anyone heard of people *not* experiencing this bug? I wonder if there's a possible workaround or configuration item that's causing it.

Link to post
Share on other sites
  • 0

Has anyone heard of people *not* experiencing this bug?

It would be nice if people encountering this bug could post their configuration here (hardware and software), maybe we could spot some similarity.

 

Here you go for mine:

 

CPU: AMD Phenom II X4 965 Processor

GPU: Radeon HD 6670

RAM: 8G

(full hardware list there: http://www.dotslashplay.it/extras/lshw.html)

 

distribution: Debian unstable "Sid" amd64

kernel: linux 3.16.7

graphic driver: radeon 7.5.0

graphic server: X.org 7.7

Edited by vv221
Link to post
Share on other sites
  • 0

Ditto. Most maps seem to load with the viewing window at the bottom left of the map? I adjust by hitting '1' on the keyboard to immediately zoom to my first party member.

 

Does this happen in all maps, though? Or just larger ones? I wonder if map size is a factor.

 

SYSTEM SPECS
Game Version: v1.0.4.540 / GoG
Operating System: Linux Mint 17.1 / Xfce 64
Processor: 4x Intel® Core™ i5-3470 CPU @ 3.20GHz
Memory: 4001MB
Resolution: 1280x1024
OpenGL Renderer: Gallium 0.4 on AMD CAICOS

Link to post
Share on other sites
  • 0

On my system the autoscroll to bottom can be prevented by constantly moving the mouse a little bit till the transition is complete.

 

The same autoscroll happens if i take a screenshot with the print key. I can also prevent it by moving the mouse. (But moving the mouse, hold tab and then hit print screen is no easy task ^^)

Edited by Xaratas
Link to post
Share on other sites
  • 0

Hey guys/gals,

 

Screen edge scrolling is in fact the cause of this issue. We have this in our system and we are working on a fix for a future patch. Until then you can avoid the issue by turning off the option in the menu.

  • Like 1
Link to post
Share on other sites
  • 0

Screen edge scrolling is in fact the cause of this issue. We have this in our system and we are working on a fix for a future patch. Until then you can avoid the issue by turning off the option in the menu.

Nice!

While the workaround was already known, it’s nice to have a confirmation that you guys are aware of the issue and working on it.

 

You might find some useful informations about this bug in the unofficial bug tracker here:

https://github.com/PoE-unofficial/Pillars-of-Eternity-bugtracker/issues/4

Link to post
Share on other sites
  • 0

Bumping up topic, this bug is still there on patch 3.02 (GOG). This is quite annoying, since the only troubleshoot I found is to disable border scrolling. After more than 300h playing with infinity engine it is annoying using keyboard to move camera.

 

Hope it will be fixed soon :no: (Arch linux)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...