Jump to content
  • 0

"msaa" command status is reset when changing the map


Vitamini

Question

Hello.

 

The "msaa 0" command was a life saver for me and my i3-2350M. However, whenever the map is changed, it seems to be reverted to it's initial value.

 

Steps to reproduce:

 

1- Run the game. At the title screen, type "msaa 0" in the console. msaa is disabled.

2- Start a new game. When the character creation screen is loaded msaa is enabled again.

3- Type "msaa 0" in the console. msaa is now disabled.

4- Finish creating the character and begin the game; msaa should still be disabled

5- play until you finish killing the first bandits; when the game loads the next map msaa becomes enabled again

 

Does anyone know a way to keep msaa disabled?

 

Thank you.

  • Like 1
Link to comment
Share on other sites

16 answers to this question

Recommended Posts

  • 0

Hi Developers,

 

Please let us know if there is a way to permanently disable MSAA e.g. via command line parameters or such.

 

Quick help would be highly appreciated!

 

Kind Regards

"Two things are infinite, the universe and human stupidity, but I'm not absolutely sure about the universe."
Albert Einstein

Link to comment
Share on other sites

  • 0

I found something interesting. Someone created a little tool that will automatically turn MSAA off whenever you start the game or transition into a new area: PoEKey

"Two things are infinite, the universe and human stupidity, but I'm not absolutely sure about the universe."
Albert Einstein

Link to comment
Share on other sites

  • 0

knightvision, on 27 Mar 2015 - 3:41 PM, said:snapback.png

MY SOLUTION!   ATI CARDS !  but also working on NVIDEA

 

I had on my ATI card supersampling enabled,   i turned this to adaptive multisampling or normal multi, that does fixed the blur for me !

And this must be the solution for everyone also!

Link to comment
Share on other sites

  • 0

Have you tried below?;

 

If you've got an nvidia card, you can actually permanently disable antialiasing. (I use Nvidia Inspector, but it should probably work fine with the default NV control panel.)

  • Set 'Antialiasing - Mode' to 'Override any application setting'.
  • Set 'Antialiasing Setting' to 'Application-controlled / off'.

 

This will turn off the msaa properly, without it resetting to defaults every time you change location.

 

You can try doing the same with on the AMD vision control center as well, but I can't confirm if it'll work.

Link to comment
Share on other sites

  • 0

Have you tried below?;

 

If you've got an nvidia card, you can actually permanently disable antialiasing. (I use Nvidia Inspector, but it should probably work fine with the default NV control panel.)

  • Set 'Antialiasing - Mode' to 'Override any application setting'.
  • Set 'Antialiasing Setting' to 'Application-controlled / off'.

 

This will turn off the msaa properly, without it resetting to defaults every time you change location.

 

You can try doing the same with on the AMD vision control center as well, but I can't confirm if it'll work.

Thank you for the suggestion. Unfortunately I have integrated graphics (Intel HD 3000)

 

At any rate, not retaining the "msaa" value in the game is an issue within the game, and anything else to be done outside of it is a workaround rather than a fix - a workaround that I wish I could do now.

Link to comment
Share on other sites

  • 0

Yes, I totally agree, of course. Ideally you shouldn't be 'forcing' anything on the game like that, but it's a nice workaround until it's patched.

 

This problem of things resetting when changing areas isn't just with the msaa, it happens with other things as well. If whatever you try to change doesn't have a place to store the value locally on your machine (ie the registry in this case, with the other settings). It reverts back to defaults(sometimes glitchy versions of the defaults) on every area change.

Edited by Asmodean-
Link to comment
Share on other sites

  • 0

 

I found something interesting. Someone created a little tool that will automatically turn MSAA off whenever you start the game or transition into a new area: PoEKey

Thank you for the link. Unfortunately it only supports 1920x1080 resolution.

 

Why don't you support the author by providing the screen shots he asks for to implement the screen resolution you are using?

"Two things are infinite, the universe and human stupidity, but I'm not absolutely sure about the universe."
Albert Einstein

Link to comment
Share on other sites

  • 0

The next patch will include an options slider that effects msaa and will persist between level loads.

That`s exactly what I was hoping for! Thank you very much. I'm looking forward to the next patch.

 

you can just add this command line in the launch options : -force-opengl

i can't garantee a good stability, but the msaa won't load

That was actually one of the first things I tried. Everything but the menu buttons becomes glitched. Did it work for you?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...