Jump to content

radeon igp thread


Recommended Posts

there are a couple of threads that indicate this problem for radeon igp users: after character creation and intro movie, the game freezes on a shot from inside the ebon hawk with t3m4 (or a blank screen), then disappears to desktop. i'm having the same problem (with radeon igp 340m). has anyone had *any* success at getting past this? i've tried minimising configurations, updating drivers etc with no results. some of the other threads indicate that installing omega or catalyst drivers doesn't work either. i've read that radeon igp is not opengl 1.4 compatible; is this true? (kotor1 had this opengl requirement, but could still run on my system). is there any chance of the game running (even sub-optimally) if/when the patch comes out?

threads that describe the same problem: 1 2 3 4 5

Link to comment
Share on other sites

does anyone know of any kotor2 savegame files (from start) available for download online? (to try to bypass the crash after the intro movie). if not, who else is looking for a file like this? if there's enough of us, is someone willing to use yousendit.com to store a zipped file (for a week) and post the link here so that people can download it?

Link to comment
Share on other sites

someone posting at the lucasarts forum (this thread) has kindly put up a savegame on his site. it didn't work for me, but the effort is appreciated

for any igp users who care, i also tried installing the latest radeon omega drivers (2.6.12). this didn't work, with the game being unable to even start from the launcher

Link to comment
Share on other sites

I've tried.

 

When I got a save of peragus mining facility from kiwegapa. His save, however, is playable in my comp (never before....) and that's the first time I could move the exile through the outer part of mining facility. His character was in space suit. I've walk around, talk to atton, and meet an event that the Republic ship is harboring at mining facility.

 

The last thing I could do is go through another door that lead into mining facility again, and that's the end. The game was crash...back to desktop with the last view inside the facility, freezing just like that T3's vision which we faced until now.

 

So what's the point I'm telling you this?

The point is... what I've experienced proved that my and all of your comp could play THIS game. But there're something that prevent us. May be some lightning effect, sound effect, or some object that is in that peragus mining facility but didn't appear outside the facility.

 

Some said the OpenGL1.4 has "Lightning and object transformation balh blah blah...". And this (what OpenGL1.4 has) still prevent us from playing the game, though OpenGL1.4 itself doesn't do that. Because I can play KotOR1 in my comp fine.

 

Come to conclusion that if we can disable those things preventing us, we can play this game.

 

But how?

Link to comment
Share on other sites

well, that's good news; like you said, it shows that the game *is* playable (in areas at least) for igp users (and hopefully for whoever else is getting the BSoD). i guess we just have to hope that the patch is going to fix whatever problems we're having in those particular areas. if it doesn't, i really don't know what we can do.

 

here's a list of the things i've tried:

- minimising in-game configurations (including disabling movies, sound, and everything in graphics menu)

- editing swkotor2.ini with "disable vertex buffer objects=1" under graphics options

- renaming all files in c:\ named wnaspi32.dll to wnaspi32.bak

- checking various things in the troubleshooting guide (directx, monitor setup, system resources, colour palette)

- updating video drivers provided by hp

- fiddling with the opengl settings in the ati control panel

- installing radeon omega drivers 2.6.12 (based on catalyst 5.2)

- trying to play from a loaded savegame

- placing catalyst 4.11 atioglxx.dll file in the kotor2 root directory

 

at this point in time, i'm not going to try to install the latest catalyst or catalyst 4.11 or omega drivers based on 4.11, because i don't really have much hope that they'll work, and downloading large files and installing and cleaning out drivers is pretty damn time consuming.

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...