Jump to content

Stuck on Citadel Station


Recommended Posts

This is my third time through the game, but first time as DS. I cant get into see lopak slusk until I prove my worth to Luxa. I took a mission from her to bring so weapons to some dealers in the apartment area.

 

Problem is............whenever I approach the door, the guy on the other side tells me "we told you to come alone, don't toy with us blah blah blah."

 

I've tried solo mode, I've left the other party members in "my room" area. I've tried it with a stealth generator on and everything. I can't get in there. So basically I'm stuck.

 

Anyone else get this or am I just being a DS noob and missing something?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...