Jump to content

A Real Gameplay Bug list (spoilers!)

Recommended Posts

We need a real GAMEPLAY bug list to help Devs clean up the mess in this game. The official thread is littered with unrelated discussion and doesn't seem to be doing its job.


This thread is intended to be a more suitable place. Post bugs you've come across while playing the game, whether glitches, diolog misspellings or errors, problems with the interface, odd occurances, etc.




A few guidelines for the thread to keep things on track.


1) DO NOT RESPOND TO OTHER PEOPLE'S BUG REPORTS. Do not use this thread for discussion of bugs or other topics. Keep this thread on topic and strictly for reporting bugs.


2) Do use this thread to make suggestions for added content. This is for bugs only.


3) No graphics card related issues. The graphics card issues are well known and do not need to be incuded here. This thread is for GAMEPLAY bugs only.


4) Include the specs of your computer with your bug report in case it's a computer related issue.


5) Please include a detailed description of the bug and details about when and where the bug occured and what you were doing in the game when it happened. Also, include whether you were Light Side or Dark Side.


6) Try to avoid making duplicate bug reports.





Thanks for your help with this. Hopefully, with a proper bug thread, we can help make a diference. Off we go!

Link to comment
Share on other sites

Right now I'm on Nar Shadda, going to help the Jedi Council Member there after Mira gets knocked out by Visquis... and for some reason I can't go into the alien bar. Very weird... I'm light side and my computer specs are


And when I say I can't go in, I literally can't, there's no ''door' option, it's like one of those nonselectable doors. I'll try reloading my game and seeing if I maybe broke it somehow... sad that it's broken so easily.


9800 Pro O/Ced to 470 core/370 RAM

AMD Athlon XP 3200+

1 GB of Dual Channel Corsair PC3200 DDR RAM

220+ GB of HDD space

Sound Blaster Audigy 2 ZS


...Also, there's a problem with KOTOR1 and 2 where EAX 1, 2, and 3 don't have music... it's just sound effects. Maybe Audigy 2 drivers?...

Link to comment
Share on other sites

Processor: AMD XP2100 1.7 GH

RAM: 512 ddr 2700

Graphics: ATI Radeon 9000 AGP

Sound: Soundblaster LIVE (original)

OS: Windows XP Pro


Bug Report #1:

On Telos, after landing on the planet, I experience a bug in the Cerka base. A blue twilek Cerka engineer is hiding about mid way to the end of the level. He asks you to show him out. If you agree, you tell him to follow you. The Twilek begins to follow you, but then seem to lose track and stop following after a short distance, forcing the player to repeatedly talk to the character, agree to lead him out, then lead him a short way until he loses track again and you must repeat the process. I was a LS player when this occured.


Bug Report #2:

On the Telos Space station just after you are released from your cells and are taken to your cell, there is a scripted sequence where you talk with the head security officer who is standing in the doorway with two gauds beside him. When the conversation ends, he turns to leave the room, but the door closes before he does so, trapping him and the guards in the room. This has the side effect of allowing you to repeat the conversation with him again. I was a LS player when this occured.


Bug Report #3

This bug occured with Atton. When you speak to Atton on the Ebon Hawk, he always stands up from the pilot's seat, but never turns around to look at the player. The result is that you are forced to stare at the back of his head through most of the conversations with him on the ship.


Bug Report #4

This bug occured with T3 on the Ebon Hawk. It was after I'd finished at least 3 systems. I did a repair on T3's memory core and brought up the Carth Onasi holographic sequence where he instructs T3 to stay with Revan. I was standing near the exit of the Ebon Hawk. When the conversation ended, Carth Onasi's hologram remained behind, and stayed there for the remainder of the game. I do have a saved game with this glitch available. I was light side when this occured.


Bug Report #5

This Bug occured in the Tomb on Korriban at the point where you meet the illusion of Kriea. The sequence is scripted with NPC's appearing and challenging her. I chose to defend her and fought the NPC's. They disappeared, but Kriea did not. I had to talk to her and repeat the scene and battle two more times before it ended properly and allowed me to move to the next room. This happened when Korriban was my last planet to visit, and my third. I was a lightsider both times when this occured.


Bug Report #6

This bug occured on Dxun in the Mandalorian camp the first time it is visited. I'm not entirely certain that this is a bug, but it seems odd enough that it might be. When the Sith attack the mandalorian base, you can jump in and help fight. When I was playing, I went to the part of the camp near the exit of the came and away fromt he hangar to help fight. The sith continued to spawn and did not stop spawning, allowing me to fight them indefinately with no end. It allows the player to gain infinate XP so long as they keep fighting. I suspect that there is a trigger that is not being cued here that would have the Mandalore tell you that you need to get out of there and go to Onderon after killing a certain number of sith. I was able to cue that sequence myself by going back to the section of the camp nearest the hangar and battle ring. I was a Light Sider when this occured. Duxn had been my 2nd or 3rd planet to visit. I can't recall which.


Bug Report #7

This bug involves Bao-Dur, the Iridian. About midway through the game after a few planets are visited, Bao-Dur's dialog options go from "Do you have any Grenades" to nothing at all. I get the impression that there may be other dialog that should be repeatedly accessable as well, ala Handmaiden and Visas, that doesn't work. Either way, the Grenades option probably shouldn't disappear like that. I was Light Side when this occured.


Bug Report #8

Near the end of the game when you finally meet Carth Onasi as a LSer, he tells you about Revan going away. I forget exactly what the dialog request is, but he begins to tell you that she went beyond the rim and could't take those she loved. The screen blacks out as if there is to be a transition or cutscene there, then fades back in and Carth continues with dialog that seems to imply that there was a cutscene we just missed. I'm not sure if this is a bug or cut content. I was a Light Sider when this occured.

Link to comment
Share on other sites

I "screwed up" and let the first Jedi Master live.. is this the price to pay for a momentary twinge of compassion? :blink:




Anyway, now I don't get the council meeting.. just a battle with the last Jedi followed by Kreia's denunciation. This had better be a bug because I was looking forward to some answers! :p

Edited by Cybersquirt
Link to comment
Share on other sites

Random (I couldn't repeat it in the same place)


Occassionally, the game will freeze for about a second, and when the animation resumes, the PC is across the room, or in another room altogether.


The first time it happeneds was on Telos. While running past the entrance to Apt complex A, not actualy in the complex, just running past it, the game froze for abour 2 seconds. When the game unfroze, the PC was sitting in the base apartment. The NPCs were still in the main area. In the crystal cave, the game froze for a second while running into the (at that time) empty merc chamber. When it kicked back in, the PC was halfway back to the crystal area, the NPCs were still in the merc chamber.


Brief system specs:

Athlon 2800+

Asus A7V600

1 gig (512x2) Corsair pc3200

geForce FX5600 Ultra

Soundblaster Live 5.1


BIOS and all drivers updated with the latest within the past 30 days.

Link to comment
Share on other sites

1 - Sometimes (or allways) my party mebers change ligth and dark sides.

2 - On the peragus station at the start of the game when you playing as T3 at the begining(first room) it sometimes disapears and i can see through walls.

3 - I've finished the game and now i want to know everything about the game (eg all the stories of all my party members,all missions etc...)

so i started all over and to get some help in this i use a walkthrough,so i need to Alt+Tab from game to read the instructions of walkthrough and after about 3 or 4 times that i alt+tab from game it freezes, i can move my mouse and i hear the music but i can't do anything...It freezes often in main menu screen and when i use consoles.


My specs are:

AMD Athlon XP 2500+

Radeon 9600 256 MB

768 MB of RAM

Windows XP

Link to comment
Share on other sites

Processor: AMD XP2100 1.7 GH

RAM: 512 ddr 2700

Graphics: ATI Radeon 9000 AGP

Sound: Soundblaster LIVE (original)

OS: Windows XP Pro


Bug Report #9

Force Sight, the power your learn from Visas doesn't seem to work, in First Person mode or otherwise. Not sure if this is a video Card problem or not. This problem occured when I played in either alignment.

Link to comment
Share on other sites

Processor: AMD XP2100 1.7 GH

RAM: 512 ddr 2700

Graphics: ATI Radeon 9000 AGP

Sound: Soundblaster LIVE (original)

OS: Windows XP Pro


Bug Report #9

Force Sight, the power your learn from Visas  doesn't seem to work, in First Person mode or otherwise.  Not sure if this is a video Card problem or not.  This problem occured when I played in either alignment.


This isn't going to help since we don't even know if they are really working on a patch since they haven't given us a list of what is getting fixed. I think we all have a long time to wait for all of our problems to get cleared up. I am really thinking about just not playing it until then even though I love the game.

Link to comment
Share on other sites

There is an incorrect reference to an area or something when trying to go to dantooine after finishing the rest of the planets. No matter what I try, after party selection, the game goes to where it should be loading and it does not load at all. very frustrating to get 20+ hours in and be completely stuck by a bug. Please fix devs, in the future I am likely to wait a few months after a game is released so that they can fix the bugs that should have been fixed before shipping.

Link to comment
Share on other sites

Problem #??: I imagine I hit it in just the right way, but I was able to walk through a wall on Nar Shaddaa.

It was in the 'Flophouse' area, I wanted from the room with the guy looking for his wife into the next room, and got stuck.

The entry point was next to the storage bin, the side closest to the door I believe.


Problem #??+1: You'll be seeing another thread started by me concerning this topic.

Starting with the dialogs between

the Exile and Sion on Korriban


and going through to as far as I am (

Malachor V inside the Academy

), they skipped all audio and flew by before I could read them.

This includes the following conversations (all spoiler-proof):



- Exile/ Sion on Korriban

- Handmaiden/ Atris on Telos

- Exile/ Atris on Telos

- Exile/ Carth on Telos

- Exile/ Nihilius on Ravager

- Exile/ Visas just about everywhere

- Kreia/ Sion on Malachor (I think they had a conversation)

- Mira/ Hanharr on Malachor

- Bao-Dur/ Remote on Malachor




The dialog skip also happened a couple times on the Hawk with T3, but it was not nearly as prevalent, nor as damaging to the overall storyline.

Link to comment
Share on other sites

1- On Nar Shadaa, after Ratrin Vhek asks for his ship and tells me about the secret compartment I head back to the ship. When I enter the ship there is a black screen (as if a cutscene was about to start) and when I get to the starboard dormitory there is no secret compartment. I saved and reloaded. Still nothing. I tried the autosave and it worked. Weird. And now everytime I get in the Ebon Hawk there is like the start of a cutscene (maybe 2 seconds of black screen).


2- On Dxun, I was with Handmaiden and Kreia when I got to an old crashed ship. It appeared to be from the Mandalorian Wars (if I remember correctly). Anyway when I get out of the crater below the ship the two ladies did not follow. When a fight started they came and helped and after the fight the got back to their hiding place. I had to remove the characters from the party and add them to solve this.


This is my first play through as a lightside Jedi Guardian/Weaponmaster.




P4 2GHz


XP pro sp1

GeForce 4 MMX 440 64MB

SBLive 5.1

60 GB Hard drive (35 free)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...