Jump to content

game performance changes


Recommended Posts

I'm not sure what causes this but when I first started playing everything was fine. Pumped all graphics options up to max and ran smooth as silk the entire time. Until I got to... the second planet you get to (no spoilers in tech help please!). I was fine until a level transition and my fps was shot. If I had to guess it went to around 15fps. I played for a while, still playable so I ignored it.

 

This problem also showed on the main screen, with the 'stone' guy. He was also exhibiting about 15fps and that is not an intensive scene. So I knew something was wrong somewhere. I turned off smooth shadows and everything was running like silk again! Then I decided to exit and reload... it was back to being choppy. So I turned smooth shadows back on, it was smooth again! What the crap is going on...

 

It seems a graphics restart it clearing some issue that is happening on game start or level load. I am going to try some different drivers.

 

3500+

6800GT running the 66.93's

 

I know the 66.93's are unstable with a lot of stuff despite their whql cert. I'll post any update when I play around with this more.

 

If anyone else experiences something similar please post your video card/driver version.

 

I have a feeling a lot of the tech stuff is going on the LA forums, let's try to keep it here. If you're over there, tell people to come over here and post.

Link to comment
Share on other sites

I figured it out!

 

Skipping the intro 'movies' causes this problem. I tested it many times. Skipping just the LA movie does nothing, but if you skip the Obsidian movie it trips out and causes the game to run choppy. (kind of funny actually >_<

 

I'm not even going to attempt to guess why this happens. After skipping the Obsidian logo movie though the nice 'loading' screen that appears a split second after flickers a bit. I still haven't tried other drivers but since this is completely reproducable (at least on my machine) it has to be able to be fixed.

 

You can bypass this problem altogether by disabling the intro movies.

 

Open your swkotor2.ini with notepad and under Game Options change

 

Disable Movies=0

 

to

 

Disable Movies=1

 

There is no way for this problem to occur now.

 

Seems I was mistaken in my original post too. It must have started after playing the game the second time and skipping the logo movies.

 

If you're having framerate problems try letting the intro movies play all the way through and see if it doesn't improve things for you.

Link to comment
Share on other sites

I figured it out!

 

Skipping the intro 'movies' causes this problem. I tested it many times. Skipping just the LA movie does nothing, but if you skip the Obsidian movie it trips out and causes the game to run choppy. (kind of funny actually >_<

 

I'm not even going to attempt to guess why this happens. After skipping the Obsidian logo movie though the nice 'loading' screen that appears a split second after flickers a bit. I still haven't tried other drivers but since this is completely reproducable (at least on my machine) it has to be able to be fixed.

 

You can bypass this problem altogether by disabling the intro movies.

 

Open your swkotor2.ini with notepad and under Game Options change

 

Disable Movies=0

 

to

 

Disable Movies=1

 

There is no way for this problem to occur now.

 

Seems I was mistaken in my original post too. It must have started after playing the game the second time and skipping the logo movies.

 

If you're having framerate problems try letting the intro movies play all the way through and see if it doesn't improve things for you.

 

Well, if you tell it to skip movies, doesn't it like skip the movies you want to watch?

Link to comment
Share on other sites

I had the exact same problem

 

First time I played I watched all the intro films and performance was good

All the rest of the time the performance was really bad, even on the menu screen it was really slow.

I don't want to watch the intro movies again and again so I was always skipping them, it crossed my mind that it could be the Obsidian movie but that didn't seem very likely so I didn't bother until I read this

 

100% fixed all performance issues, title screen is nice, so is ingame

I thought it might be my FX5600U as it's a bit lacking when it comes to PS

 

I now run with AA and AF, even with both these on it runs better than it does if I skip the Obsidian movie and have AA and AF turned off

 

It seems to have something to do with whatever they use to show the movies, they always stutter a couple of times and if I skip the ship travelling to a different planet movies I lose all sound effects until I leave the ship and it loads a new area

 

 

(I used to get similar performance problems with Hitman3, esp the title screen, maybe it was the same thing)

 

 

 

 

 

AMD 2500+

512MB

GeForce FX 5600 Ultra 67.65

SBLive 5.1

Link to comment
Share on other sites

I think I know why this works:

 

When the intro movies are shown... The game is probably cacheing the files it needs to start up (namely the main menu and any sounds the menu needs and probably some global stuff that will get executed once you load a save; create a character, etc).

 

I bet by disabling the movies you are bypassing something getting cached THAT IS CORRPUTED and that is why performance is better once you skip the movies.

 

This has to be a memory allocation bug or something similar (or just a bad file that gets cached like I said above).

 

This is just speculation on my part, but that is why most intro movies for games are played: To hide the fact the game is cacheing files need to actually start playing.

Link to comment
Share on other sites

Hmm well this isn't quite as surefire a fix as you guys seem to have found... though I am an ATi user.

 

Having said that, it has helped performance a little. Main menu is still lagged, but I can now get 4x AA where before I could only get 2x (with 'DVBO=1'), though I'm not in a very demanding area. I say 'a little'... I should get 6x AA and soft shadows perfectly, like in kotor (not sure, but I would say this is less demanding so far). TBH I wasn't expecting to be able to max out specs like I could in kotor... but it looks like I should be able to. In any case, FPS still isn't anywhere near high enough.

 

Shame, coz this sounded exactly that kinda crazy fix that would for no earthly reason fix everyone's problems.

 

Jalo Jago out.

Link to comment
Share on other sites

Odd...I tried editing swkotor2.ini and neither Disable Movies=1 or Disable Intro Movies=1 had any effect. The in-game movies and the intro movies would still play. This isn't too much of a problem, though. I just renamed leclogo.bik and ObsidianEnt.bik and replaced them with dummy files. The game loads much quicker without the movies playing.

Link to comment
Share on other sites

I'm not sure what causes this but when I first started playing everything was fine. Pumped all graphics options up to max and ran smooth as silk the entire time. Until I got to... the second planet you get to (no spoilers in tech help please!).  I was fine until a level transition and my fps was shot. If I had to guess it went to around 15fps. I played for a while, still playable so I ignored it.

 

This problem also showed on the main screen, with the 'stone' guy. He was also exhibiting about 15fps and that is not an intensive scene. So I knew something was wrong somewhere. I turned off smooth shadows and everything was running like silk again! Then I decided to exit and reload... it was back to being choppy. So I turned smooth shadows back on, it was smooth again! What the crap is going on...

 

It seems a graphics restart it clearing some issue that is happening on game start or level load. I am going to try some different drivers.

 

3500+

6800GT running the 66.93's

 

I know the 66.93's are unstable with a lot of stuff despite their whql cert. I'll post any update when I play around with this more.

 

If anyone else experiences something similar please post your video card/driver version.

 

I have a feeling a lot of the tech stuff is going on the LA forums, let's try to keep it here. If you're over there, tell people to come over here and post.

 

I always esc the intro movies and don't experience what you mentioned. I do experience slowdowns specific to certain areas, which could be some kind of memory leak. On the second planet as you mentioned, I got some slowdowns at the residential area. Everywhere else was smooth as silk.

Link to comment
Share on other sites

I'm not sure what causes this but when I first started playing everything was fine. Pumped all graphics options up to max and ran smooth as silk the entire time. Until I got to... the second planet you get to (no spoilers in tech help please!).  I was fine until a level transition and my fps was shot. If I had to guess it went to around 15fps. I played for a while, still playable so I ignored it.

 

This problem also showed on the main screen, with the 'stone' guy. He was also exhibiting about 15fps and that is not an intensive scene. So I knew something was wrong somewhere. I turned off smooth shadows and everything was running like silk again! Then I decided to exit and reload... it was back to being choppy. So I turned smooth shadows back on, it was smooth again! What the crap is going on...

 

It seems a graphics restart it clearing some issue that is happening on game start or level load. I am going to try some different drivers.

 

3500+

6800GT running the 66.93's

 

I know the 66.93's are unstable with a lot of stuff despite their whql cert. I'll post any update when I play around with this more.

 

If anyone else experiences something similar please post your video card/driver version.

 

I have a feeling a lot of the tech stuff is going on the LA forums, let's try to keep it here. If you're over there, tell people to come over here and post.

 

I always esc the intro movies and don't experience what you mentioned. I do experience slowdowns specific to certain areas, which could be some kind of memory leak. On the second planet as you mentioned, I got some slowdowns at the residential area. Everywhere else was smooth as silk.

 

Well, i get slowdowns in multiple areas, even Kotor II config scan says my computer specs exceed the recommended requirements, i wish i knew what caused it.

 

For example, on Paragus, where there i alot of fire and smoke, i can turn north, south and east, but west it slows riight down to a crawl.

 

I need to know what causes it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...