Jump to content
Grak500

Horrid screen tearing on PC in Fullscreen, but Windowed Fullscreen causes stuttering / frame pacing issues.

Recommended Posts

No matter what I limit my frame rate to, the game has serious screen tearing. 

Nvidia's Fast Sync doesn't seem to work with the game.  DX12?

Is there any .ini edit to enable Triple Buffering?

Barring those, my normal solution would be to switch to Windowed Fullscreen and allow Windows DWM to do a triple buffering pass itself.   It does work here to eliminate tearing, but The Outer Worlds stutters like crazy in Windowed Fullscreen.

Is the only solution to play Fullscreen with Vsync on?  It causes a lot of input lag even with nvidia's low latency option set to Ultra.


Specs:

RTX 2080

i7-9700k

 

Edit: Also, just a suggestion, you should allow higher than 100% with the render scaling option for people who would like to upscale.  The game doesn't respond well to DSR or .ini edits from what I've seen.  DSR completely breaks the UI and r.ScreenPercentage= does upscale but causes some weirdness.

 

Edit 2: To clarify, adding r.ScreenPercentage=X to engine.ini does upscale the game, but causes serious problems in dialogues with textures vanishing on the right side and bottom of the screen -- some sort of overlay/filter seems to still be rendering at your native resolution.  I don't really know what to make of it, and don't want to start a second topic, so I'll just ask here if anyone knows how to upscale this game?

Edited by Grak500
  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Grak500 said:

No matter what I limit my frame rate to, the game has serious screen tearing. 

Nvidia's Fast Sync doesn't seem to work with the game.  DX12?

Is there any .ini edit to enable Triple Buffering?

Barring those, my normal solution would be to switch to Windowed Fullscreen and allow Windows DWM to do a triple buffering pass itself.   It does work here to eliminate tearing, but The Outer Worlds stutters like crazy in Windowed Fullscreen.

Is the only solution to play Fullscreen with Vsync on?  It causes a lot of input lag even with nvidia's low latency option set to Ultra.


Specs:

RTX 2080

i7-9700k

 

Edit: Also, just a suggestion, you should allow higher than 100% with the render scaling option for people who would like to upscale.  The game doesn't respond well to DSR or .ini edits from what I've seen.  DSR completely breaks the UI and r.ScreenPercentage= does upscale but causes some weirdness.

 

I'#m playing on fullscreen and so far the game is filled with spots that cause a stutter every time I pass trough them.

 

Specs:

 

1080ti

9900k

SSD

16GB ddr4 ram

Rog maximus Hero XI

R750MX PSU

  • Like 1

Share this post


Link to post
Share on other sites

Windowed Fullscreen also seems to have an uncapped framerate...  wait?  what?  

I thought Windows 10 DWM automatically implemented triple buffering and vsync on any windowed/windowed fullscreen application unless you really borked with some stuff.  Maybe I'm confused.

Edited by Grak500
  • Like 1

Share this post


Link to post
Share on other sites

Hey everyone,

Thank you for reporting these stuttering and tearing issues.  I submitted a report to the team so they can investigate the issue and try to get a fix in.  If you happen to notice any changes, good or bad, please continue to post about it here as I linked this thread to the report as a reference for the devs during their investigation.

Thank you, and sorry for the inconvenience the stutters and tears are causing during your playthrough.

  • Like 2

Share this post


Link to post
Share on other sites

Copy-pasting from the other thread, and I appreciate the response from SChin. Many devs do not take these issues seriously, and figure that because it's a small portion of their audience having the problem, it's not worth fixing. I hope that's not the case here. :)

Anyway, here's my post:

Having the same issues. I have G-Sync turned on and setup properly (as tested by Blur Busters -- in game V-Sync off, Nvidia control panel V-Sync on, G-Sync set for fullscreen only, etc.), I have the game running in exclusive fullscreen, I have the latest drivers, and I'm running an 8700K and 1080 Ti system with 16GB of RAM. Nothing is overheating, nothing is dangerously overclocked.

Some other details that may or may not help the devs:

  • The game is running on an SSD.
  • Even when the game is set to fullscreen, I'm still able to quite easily alt-tab out and perform other actions, with the game still running and displayed on my first monitor. This seems to be somewhat abnormal behavior for fullscreen games, at least in my experience. Typically, alt-tabbing is quite an ordeal, and can risk crashing a game (or at least causing some annoying screen flickers). Is the game truly running in exclusive fullscreen?
  • I have two monitors, both 144Hz, but only one (the one the game's running on) with G-Sync compatibility.
  • I'm playing through the Xbox Game Pass for PC.
  • I've completely uninstalled my drivers using Display Driver Uninstaller (performed properly -- I ran it in Safe Mode and as an Administrator), and then re-installed the latest ones.
  • I do not have GeForce Experience. The only overlay tool I have is Rivatuner Statistics Server, for capping the FPS at 141. I've tried without that software as well.

At 1080p with my current system, I see frequent FPS drops into the low 80s, and out in the wilds, it's usually well above 100. However, even at high framerates, the stuttering is constant. I'm not exaggerating. Every few seconds, stutter. Standing still but turning the camera, stutter.

And yes, I've tried with G-Sync off, too, as well as with normal in-game V-Sync on (that just made things worse).

I would be more than happy to record a clip of the stuttering in action, or provide any other details needed by the devs.

Edited by Polycount

Share this post


Link to post
Share on other sites

"Xbox Game Pass for PC"

Game Pass/Microsoft Sotre never uses exclusive fullscreen in my experience, only borderless.  Since it also locks off access to the executable (and with The Outer Worlds actually prohibits you from opening properties via task manager), you can't disable Fullscreen Optimizations or test launch options.

 

NVIDIA Inspector's framerate limiter doesn't work with this game for some reason.

Edited by Grak500

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...