Jump to content

Recommended Posts

I tried posting this in technical support but that place is a ghost town. I'm hoping this will be allowed here since things are kind of slow. 

In the middle of a playthrough my game stopped recognizing what achievements I have unlocked. My Steam account still lists them properly, but my achievements list in-game was wiped and, most importantly, my Berath's Blessings were wiped. They are unlocking again as a I play but I would rather not have to earn every single one again before starting a new playthrough.

I've tried verifying the game files in Steam, and my computer has restarted umpteen times since this issue started. The problem still persists. Can anyone help me out here? Maybe I need to fiddle with the game folders or something?

Share this post


Link to post
Share on other sites

Are you using any mods ?

I do remember this happened to me a couple times shortly after release when my steam client wasn't connected to the cloud. Thought this was fixed. Never happened to me again. 

Share this post


Link to post
Share on other sites

If you just want the Berath's Blessing points you can grab the file here 

 

I know that doesn't help with the underlying issue you are having but hopefully it helps


Free games updated 3/6/19

Share this post


Link to post
Share on other sites

Sorry, for some reason I missed that this thread got responses. It turned out all I had to do was load my other saved games (where I had the game finished already) and I automatically re-unlocked the achievements. Odd but it worked out in the end.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...