Jump to content

Welcome to Obsidian Forum Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

Known Major Issues


  • Please log in to reply
14 replies to this topic

#1
jlee

jlee

    QA Tester

  • Developers
  • 468 posts
Known Major Issues

 

*THIS THREAD IS ONLY FOR ADDRESSING THE ISSUES LISTED HERE. FOR ALL OTHER BUGS, PLEASE CREATE A SEPARATE POST.*

 

Hi all,

 

The purpose of this thread is to address major issues that we have seen a significant amount of users experiencing. To accomplish this, we are reaching out to you in the community for as much information as possible on these topics to help us investigate and ultimately resolve these issues. Any aid you can provide us with is greatly appreciated, but before that, here are some standards:

 

1. Please provide us with the necessary files: DxDiag, output log, save file(s), screenshots, videos, etc.

2. Provide detailed and specific steps with appropriate context to your issue

3. State the OS (Window, Mac, Linux) and platform (Steam, GOG, MacPlay, Origin) you are using

 

 

Save Files Being Deleted:

 

We are aware of users experiencing their save files disappearing and are working hard to investigate the cause. Details we are looking for specific to this issue are the following:

  • Are your saves not present from the Main Menu screen in-game? Or are the files completely gone from your save file location?

          Note: Your save files should be found in your respective platform's file destination https://support.obsi...me-files-stored

  • Do you have Cloud Sync enabled? Or have you disabled Cloud Sync recently? (Disabling Cloud Sync will not sync to any save files created in the Cloud)
  • What patch versions have your saves been present through? (ex: Patch v1.0.2 - Patch v1.1.1)
  • Did your saves disappear right after updating to this latest patch? Or did this occur on this latest patch sometime while you were playing?
  • Do newly created save files also disappear?
  • Are you switching between different platforms? (ex: PC to Mac, Linux to PC, Mac to Linux, etc.)
  • Anything else you can think of that you think may have caused this to occur

 

Crash/Freeze upon entering Arena Sub-level:

 

*NEW UPDATE*

 

Hi all,

 

We are committed to fixing this issue and after much analysis, we've come to the conclusion that we need one of your rigs that is experiencing the issue to runs tests on for ourselves. Specifically, we are requesting that anyone who is nearby to our Irvine office to please physically bring in their computer so that we may have our programmers discern the direct cause of this crash. If you are nearby, experiencing this issue, and are willing to let us borrow your machine for analysis, please message me directly so that I may look into setting up an appointment for you.

 

Users have reported experiencing a crash/freeze upon transitioning into Arena Sub-level from the Engwithan Digsite. Details we are looking for specific to this issue are the following: 

 

 

  • Do you experience this crash/freeze upon clicking on the area transition, during the loading screen, or after you've entered Arena Sub-level?
  • Are you able to cheat into the scene using the Debug Transition console?

        Note: To do this, type ` and then type iRoll20s in the command line and press enter to enable cheats. Then press F11 and select Arena Sub-level from the Map list and click Start.

  • Are you experiencing this issue on a new game save file created from this latest patch? (currently 2.0.0.0017) or on a save file created from a previous patch? Please attempt to transition to Arena Sub-level on a new game save created on the latest patch.
  • Have you experienced this issue on previous patch version(s) and if so, which ones?
  • Have you ever been able to enter Arena Sub-level successfully and then it stopped working? Or have you never been able to enter Arena Sub-level?

Additional Instructions: 

 

When you experience the freeze issue upon entering Arena Sub-level, Alt+Tab and run Task Manager. Then right click Pillars of Eternity II: Deadfire in the "Processes" list and click "Create dump file". Send that dump file to us as an email attachment at support@obsidian.net with this post linked.

 

Black Screen upon launching the client:

 

Users have reported experiencing a black screen upon launching the client. Details we are looking for specific to this issue are the following:

  • Do you hear any game audio?
  • Are you able to interact with the Main Menu blindly and load a save to get past the black screen?
  • Is this current patch the first time you've encountered this issue? (currently 1.2)
  • If you've encountered this issue on a previous patch version(s) and this is still occurring, which patch version(s) have you had this issue occur on?
  • Is your OS (Windows, Mac, Linux) up to date?
  • Are your graphics drivers up to date?

  • ghalidrim, Yopo and DannSann like this

#2
Achilles

Achilles

    Arch-Mage

  • Members
  • 3043 posts
  • Pillars of Eternity Silver Backer
  • Kickstarter Backer
  • Lords of the Eastern Reach Backer
  • Deadfire Gold Backer
  • Fig Backer
  • Black Isle Bastard!
Black Screen upon launching the client:
 
Users have reported experiencing a black screen upon launching the client. Details we are looking for specific to this issue are the following:
  • Do you hear any game audio? No
  • Are you able to interact with the Main Menu blindly and load a save to get past the black screen? No
  • Is this current patch the first time you've encountered this issue? (currently 1.2) Yes. I was part of the beta branch for 1.2, but didn't experience it and didn't encounter the issue until I was several hours into a playthrough using 1.2 (release).
  • If you've encountered this issue on a previous patch version(s) and this is still occurring, which patch version(s) have you had this issue occur on? N/A
  • Is your OS (Windows, Mac, Linux) up to date? Yes (Win7 Home, SP1)
  • Are your graphics drivers up to date? Yes (GeForce 398.36)

 

I started a new playthrough on 1.2 (beta branch) and played through until Vilario's Rest. I stepped away from the game for about a week and when I returned 1.2 (release) was out. Before jumping back in I upgraded my video card from an EVGA GeForce 980 SC to an EVGA GeForce 1080 SC (I ordered it a while ago and had put off installing it). I notice some stuttering and found Caleb's instructions for GeForce users. I made the changes and the stuttering issue was resolved.

 

Continued the playthrough through the end of the Port Maje content (Burning Bridges, Restoring Order, Stranded, etc). I returned to The Defiant, set sail, met Furrante, got most of the way through the dialog with Serafen...and my computer did a hard reboot (no deadfire crashlog, but the Windows event log can be found below). Logged back into my computer, launched the game, reloaded from the autosave, got all the way through the dialog, went to select Serafen's class...hard reboot again (Windows event log #2). Gave up for the night. Went to bed.

 

Got off work the next day, came home. Fired up the game. Reloaded from the autosave. Computer hard rebooted as soon as the cutscene started. Nothing but black screens since.

 

I tried to verify the steam cache. 150+ files missing (surely that will fix it!). Still black screen. Uninstalled RivaTuner. Still black screen. Restored previous setting in Nvidia Control Panel. Black screen. Loaded Pillars 1 to make sure the problem wasn't with Steam. Loaded fine. Tried Deadfire again. Black screen. Uninstalled Deadfire. Started reinstall process. Went to bed. Woke up. Black screen.

 

And that's where we are now. 

 

Windows Event Log from the hard reboots:

https://www.dropbox....c/859.evtx?dl=0

https://www.dropbox....y/934.evtx?dl=0

 

Output Log (fresh install. Sorry):

https://www.dropbox....ut_log.txt?dl=0

 

Quick Save and Autosave:

https://www.dropbox....e.savegame?dl=0

https://www.dropbox....0.savegame?dl=0

 

DxDiag:

Attached File  DxDiag.txt   26.78KB   2 downloads

 

I hope this helps, guys. Let me know if you need anything else.

 

UPDATE: I tried Sidorf's suggested fix (found here) and I can launch the game again. I'll have to check later to see if I'm still having problems with the Sarafen intro. 

 

PS I saved a copy of the appdata folder. If you need me to zip and send that to you, let me know.


Edited by Achilles, 11 July 2018 - 05:34 AM.


#3
Sered

Sered

    (0) Nub

  • Initiates
  • 4 posts
Black Screen upon launching the client:
 
Users have reported experiencing a black screen upon launching the client. Details we are looking for specific to this issue are the following:
  • Do you hear any game audio? ------ No
  • Are you able to interact with the Main Menu blindly and load a save to get past the black screen? ------- No
  • Is this current patch the first time you've encountered this issue? ------- Yes
  • If you've encountered this issue on a previous patch version(s) and this is still occurring, which patch version(s) have you had this issue occur on? -------- Never occurred before
  • Is your OS (Windows, Mac, Linux) up to date? ---------- Yes --Windows 10
  • Are your graphics drivers up to date? Yes

 

 

Very similar to the user above's experience. Loading the game would cause my PC to lock up and require a Hard Reboot to operate normally again. Eventually when I attempted to launch the game I was just met with the black screen. I tried verifying the game cache files and preformed two reinstalls.

 

I own the game through Steam.

 

 

Edit: The fix that Achilles linked above also worked for me. Thank goodness I am so glad that there are helpful people out there way more knowledgeable than I. Hopefully the Devs can sort all this out because it has been a real turn off.

Attached Files


Edited by Sered, 11 July 2018 - 06:22 AM.


#4
jww

jww

    (3) Conjurer

  • Members
  • 100 posts

Save Files Being Deleted:

 

We are aware of users experiencing their save files disappearing and are working hard to investigate the cause. Details we are looking for specific to this issue are the following:

  • Are your saves not present from the Main Menu screen in-game? Or are the files completely gone from your save file location?

          Note: Your save files should be found in your respective platform's file destination https://support.obsi...me-files-stored

  • Do you have Cloud Sync enabled? Or have you disabled Cloud Sync recently? (Disabling Cloud Sync will not sync to any save files created in the Cloud)
  • What patch versions have your saves been present through? (ex: Patch v1.0.2 - Patch v1.1.1)
  • Did your saves disappear right after updating to this latest patch? Or did this occur on this latest patch sometime while you were playing?
  • Do newly created save files also disappear?
  • Are you switching between different platforms? (ex: PC to Mac, Linux to PC, Mac to Linux, etc.)
  • Anything else you can think of that you think may have caused this to occur

 

I don't have all of this information handy, but I'll try to update this post later.

 

- The files are missing in-game. Not sure about the save file location off the top of my head.

- I have never used Cloud Sync, and I've never switched platforms (I'm playing on a Mac).

- The problem was present through the early patches, but I figured out the behavior and have avoided the problem since then, so I don't know if it's still present.

 

If you save the same file twice during the same in-game time, the save file disappears (I think this also happens if you save two different save files with the same in-game timestamp). So, for example, if you pause the game, save it, then don't remember if you saved it (because there is no output saying you did so) so you save it again, then that save file will disappear. A very similar issue occurred in PoE1, and I think when I took a look at the save files back then, it was adding the timestamps to the filename, so if the in-game timestamp hadn't changed, there'd be a collision. It can't be an out-of-game timestamp, because there'd always be at least a second between saves, and the problem is too consistent for those numbers to be a random hash, so it's got to be an in-game timestamp.

 

I don't know all the ins and outs of the issue, but this work-around has worked for me: Always keep two rotating save files that you switch between every time (never save to the same file twice in a row), and always un-pause and take a few steps in-game before saving, just in case you forget that you just saved. Also, as a secondary precaution, before I quit a gaming session, I usually transition areas before my final save, since that will also give me an auto-save (auto-saves don't appear to be affected by this issue).



#5
Rik Kirtaniya

Rik Kirtaniya

    (1) Prestidigitator

  • Members
  • 6 posts

 

 

Crash/Freeze upon entering Arena Sub-level:

 

Users have reported experiencing a crash/freeze upon transitioning into Arena Sub-level from the Engwithan Digsite. Details we are looking for specific to this issue are the following: 

 

 

  • Do you experience this crash/freeze upon clicking on the area transition, during the loading screen, or after you've entered Arena Sub-level?
  • Are you able to cheat into the scene using the Debug Transition console?

        Note: To do this, type ` and then type iRoll20s in the command line and press enter to enable cheats. Then press F11 and select Arena Sub-level from the Map list and click Start.

  • Are you experiencing this issue on a new game save file created from this latest patch? (currently 1.2) or on a save file created from a previous patch? Please attempt to transition to Arena Sub-level on a new game save created on the latest patch.
  • Have you experienced this issue on previous patch version(s) and if so, which ones?
  • Have you ever been able to enter Arena Sub-level successfully and then it stopped working? Or have you never been able to enter Arena Sub-level?

Additional Instructions: 

 

When you experience the freeze issue upon entering Arena Sub-level, Alt+Tab and run Task Manager. Then right click Pillars of Eternity II: Deadfire in the "Processes" list and click "Create dump file". Send that dump file to us as an email attachment at support@obsidian.net with this post linked.

 

 

Firstly, I would like to thank the developers for taking this issue into consideration.  :)  It has been really bothering and disheartening since this is actually not allowing me to play the game at all, so it feels really good to see that it has finally been taken up for investigation.

 

I wish I could lend my PC for this purpose, but I live in a completely different part of the world. Nevertheless, I shall try my best to help, so that this issue can be fixed as fast as possible so that I (and others facing it) may finally play the game.

 

For your information, I am playing on Windows 10, on the GOG version and on the latest patch (v.1.2.2.0033). Now let me answer the above questions one by one:

  • In my case, the freeze occurs after the loading screen is finished showing. The screen remains black with only the hand-cursor for an indefinite time. It's not like the other after-loading screen periods where the music briefly pauses and the cursor changes from the hand to the red and then to the yellow one. Here the hand remains indefinitely along with the black screen. At this moment, when I open the Task Manager, the CPU, GPU and Disk Usages for the game's .exe file process is near zero. The only way to exit is to kill the process using task manager. This issue occurs only with this map, and I've not faced anything like this in all the areas that I have access to so far in the game.
  • I've tried using the console to go to the area directly from the map screen, but the issue still occurs in the same manner.
  • The issue does occur even on a new game started on the latest patch. I started a new game a few hours ago and speed-ran to the area with Eder and myself, but it's still happening.
  • Yes, I've experienced this issue on previous patches as well. I don't clearly remember the exact version, but I think it's since v.1.1 at least.
  • My answer to the last question is indeed the most remarkable thing. The fact is that I have been able to enter the area the very first time I played. I played upto the narration scene with Eothas and decided to take a break. I made a save game, and then attempted to continue playing the very same day, with no updates of any kind in between (neither that of the game, nor any of those pesky Windows updates), and all of a sudden this problem appeared and it continues to persist till date. I simply can't play any further, and I'm sad.  ;(

Here's a link to the save game file, dxdiag file and output file when the issue occurs:

 

https://drive.google...IxkhSmwzVoKJyF5

 

I'll try to send the dump file created when this issue occurs, but it's huge (3.83 GB), so it'll probably take me a day or two to upload it to one of my Cloud Drives. (I don't have a super-high-speed internet connection.) I'll update this post with the link to the dump file as soon as I have been able to upload it.

 

I wish the developers good luck, and eagerly hope that this issue gets fixed soon.  :)



#6
Rik Kirtaniya

Rik Kirtaniya

    (1) Prestidigitator

  • Members
  • 6 posts

Well, well, it seems my internet connection is not really as slow as I imagined it to be!  :grin: I compressed the file to less than a GB, and got it uploaded to my Google Drive within 20 minutes.

 

Since being a new member, I cannot update my previous post unless it is approved by a moderator and is visible, so I'm posting the links here in a new post.

 

Firstly, here's the link to the Dump File of the game's .exe file created when the freeze takes place:

 

https://drive.google...JCbx00SqY1MSpxf

 

Secondly, here's the link to the latest output file and save game created using the latest patch (release 33). (The previous one was with older patches, so I thought you might like to see the condition of the latest one with the freeze issue).

 

https://drive.google...u1ciKdT17ZPRdcy

 

Hope this helps!  :)

 

Please let us know if you find the culprit behind this problem.  :)



#7
Darth Reaver

Darth Reaver

    (0) Nub

  • Initiates
  • 2 posts

SAVE FILE BEING DELETED

 

I have'nt played since the first month the game was out. but everything worked fine for me.

As of today the game does not see my save files. 

They are located where they are supposed to be. I can see them.

The save files do not show up in-game. Only New Game option is available.

I tried verifying integrity. 

I tried Uninstalling, restart my comp, then installing again. 

I have even tried deleting my saved folder (backing it up first, of course) Then starting a new game. I saved. loaded the save while still in game. Quit to desktop, launched again and still no save there. 

Yes I use cloud sync through steam. always have. I have multiple computers in my house plus my laptops. Ive made saves with and without it on. Still the saves dont show up in game but they appear in the saved game folder.

 

The game is literally unplayable and I'm getting highly frustrated. I cant play at all. I mean I can, but it doesn't matter because as soon as the game closes everything gone. I just purchased the season pass a few days ago in anticipation of playing this weekend. So you can see how I'm even MORE upset. Just plopped down money and the WHOLE game is broke.

 

 Please can I get some help with this. Please.

 

Steam, Windows 10, Save files are from launch day and up to current. Effects all saves even new ones. Save files are in thier directory, just not showing up in-game. 


Edited by Darth Reaver, 09 August 2018 - 12:29 PM.


#8
rone

rone

    (3) Conjurer

  • Members
  • 133 posts
  • Location:depends on momentum
  • Steam:ronebofh
  • Pillars of Eternity Backer
  • Kickstarter Backer
  • Deadfire Backer
  • Fig Backer

Crash/Freeze upon entering Arena Sub-level:

 

*NEW UPDATE*

 

Hi all,

 

We are committed to fixing this issue and after much analysis, we've come to the conclusion that we need one of your rigs that is experiencing the issue to runs tests on for ourselves. Specifically, we are requesting that anyone who is nearby to our Irvine office to please physically bring in their computer so that we may have our programmers discern the direct cause of this crash. If you are nearby, experiencing this issue, and are willing to let us borrow your machine for analysis, please message me directly so that I may look into setting up an appointment for you.

 

Users have reported experiencing a crash/freeze upon transitioning into Arena Sub-level from the Engwithan Digsite. Details we are looking for specific to this issue are the following: 

 

 

  • Do you experience this crash/freeze upon clicking on the area transition, during the loading screen, or after you've entered Arena Sub-level?
  • Are you able to cheat into the scene using the Debug Transition console?

        Note: To do this, type ` and then type iRoll20s in the command line and press enter to enable cheats. Then press F11 and select Arena Sub-level from the Map list and click Start.

  • Are you experiencing this issue on a new game save file created from this latest patch? (currently 2.0.0.0017) or on a save file created from a previous patch? Please attempt to transition to Arena Sub-level on a new game save created on the latest patch.
  • Have you experienced this issue on previous patch version(s) and if so, which ones?
  • Have you ever been able to enter Arena Sub-level successfully and then it stopped working? Or have you never been able to enter Arena Sub-level?

Additional Instructions: 

 

When you experience the freeze issue upon entering Arena Sub-level, Alt+Tab and run Task Manager. Then right click Pillars of Eternity II: Deadfire in the "Processes" list and click "Create dump file". Send that dump file to us as an email attachment at support@obsidian.net with this post linked.

 

 

I want to note that i ran into this with 2.0.0 (tested repeatedly) and it didn't crash; it just went into beach-ball hell (i have a Mac).  I worked around this by going into the Foreman's Office first, then into the sub-level. Strangely, after reloading the game, i was able to enter the sub-level directly.


  • Rik Kirtaniya likes this

#9
Rik Kirtaniya

Rik Kirtaniya

    (1) Prestidigitator

  • Members
  • 6 posts

I want to note that i ran into this with 2.0.0 (tested repeatedly) and it didn't crash; it just went into beach-ball hell (i have a Mac).  I worked around this by going into the Foreman's Office first, then into the sub-level. Strangely, after reloading the game, i was able to enter the sub-level directly.

 

Great! This actually WORKED! Going to the Foreman's Office and then to the Arena Sub-level makes it load properly!  :grin:  Though how this worked successfully is beyond my imagination.

 

That is because I tried to enter the Arena sub-level directly from the Engwithian ruins after I successfully tested this workaround. But this time, the freeze bug persisted. Weird.

 

My hypothesis is that the dreaded freeze occurs if one enters the Arena sub-level directly, or if one loads a save game from within the Arena sub-level (because that is what happened with me). However, if one enters it after entering the Foreman's Office, it loads normally. Strange.

 

Anyways, I'm happy to have finally found a reliable workaround (tested it myself two times on Windows 10, and it worked consistently on both occasions). I'll try to complete the area in one go (without risking any saving and reloading) and get through this. At least somehow I can finally play the rest of the game now! Hurray!  :grin:

 

Thanks for sharing this workaround, rone!  :grin:


  • rone likes this

#10
maxikyd

maxikyd

    (0) Nub

  • Initiates
  • 3 posts
  • Deadfire Backer
  • Fig Backer
Black Screen upon launching the client:
 
Users have reported experiencing a black screen upon launching the client. Details we are looking for specific to this issue are the following:
  • Do you hear any game audio? Yes
  • Are you able to interact with the Main Menu blindly and load a save to get past the black screen? Sometimes
  • Is this current patch the first time you've encountered this issue? (currently 1.2) Started in late June
  • If you've encountered this issue on a previous patch version(s) and this is still occurring, which patch version(s) have you had this issue occur on? 
  • Is your OS (Windows, Mac, Linux) up to date? Yes (Win7 Home, SP1) and (Win10)
  • Are your graphics drivers up to date? Yes (AMD Radeon)

Started playing on Win10 ROG laptop while on vacation, started crashing in mid-June.  Returned home and just installed on Win 7 PC, hoping crashes would stop, but no such luck.  Get black screen at startup--occasionally, if I wait, the load screen will appear.  Game runs about 5 minutes then crashes on both computers at random places.  I followed the directions for reporting a bug/crash, but most of the files I'm supposed to attach are not where they were listed.  Tried the fix for vidocard probs (drop frame rate, turn off extra cpu path, etc.) to no avail.

 

Can't get past character creation before crash.

I know, this is no help.  I'm sorry about that.



#11
InkSpot

InkSpot

    (0) Nub

  • Initiates
  • 1 posts

Crash/Freeze upon entering Arena Sub-level:

The crash occurs during the loading screen, I can move the mouse but when I click the game stops responding.

 

I am not able to cheat using DeBug Transition. 

 

I have been experiencing the glitch since I bought the game in the first week of July and in the current patch 2.0.1

 

I have never been able to enter the sub level. 

 

Please note that this is my first post to any form here so if I seem clueless it is because I am. 

 

Here is the crash report 

 

Log Name:      Application
Source:        Application Hang
Date:          9/5/2018 4:47:54 PM
Event ID:      1002
Task Category: (101)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      Cohava
Description:
The program PillarsOfEternityII.exe version 2.0.1.44 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Security and Maintenance control panel.
 Process ID: 1d28
 Start Time: 01d4455637a749de
 Termination Time: 467
 Application Path: C:\Program Files (x86)\Steam\SteamApps\common\Pillars of Eternity II\PillarsOfEternityII.exe
 Report Id: 26bef59e-582d-4f94-b4f1-5bddb13a81b3
 Faulting package full name: 
 Faulting package-relative application ID: 
 
Event Xml:
  <System>
    <Provider Name="Application Hang" />
    <EventID Qualifiers="0">1002</EventID>
    <Level>2</Level>
    <Task>101</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2018-09-05T20:47:54.665075500Z" />
    <EventRecordID>7076</EventRecordID>
    <Channel>Application</Channel>
    <Computer>Cohava</Computer>
    <Security />
  </System>
  <EventData>
    <Data>PillarsOfEternityII.exe</Data>
    <Data>2.0.1.44</Data>
    <Data>1d28</Data>
    <Data>01d4455637a749de</Data>
    <Data>467</Data>
    <Data>C:\Program Files (x86)\Steam\SteamApps\common\Pillars of Eternity II\PillarsOfEternityII.exe</Data>
    <Data>26bef59e-582d-4f94-b4f1-5bddb13a81b3</Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Binary>55006E006B006E006F0077006E0000000000</Binary>
  </EventData>
</Event>


#12
Freddythe5

Freddythe5

    (0) Nub

  • Initiates
  • 1 posts
  • Steam:freddythe5

Black Screen upon launching the client:

 

Users have reported experiencing a black screen upon launching the client. Details we are looking for specific to this issue are the following:

  • Do you hear any game audio? Only during the Obsidian and Versus Evil logos and then it's quiet.
  • Are you able to interact with the Main Menu blindly and load a save to get past the black screen? No. If I click anywhere it opens up a internet browser that goes to https://eternity.obs...r-available-now page. I can also hit escape and it will bring up a screen with the game logo off center and the version up in the top right edge of the screen. I can't click on anything in that screen.
  • Is this current patch the first time you've encountered this issue? (currently 1.2) I just got this game and this is the first time I have tried running it.
  • If you've encountered this issue on a previous patch version(s) and this is still occurring, which patch version(s) have you had this issue occur on? I havn't tried playing it before today.
  • Is your OS (Windows, Mac, Linux) up to date? Yes, I am on an up to date Mac.
  • Are your graphics drivers up to date? Yes

  • Lightwild likes this

#13
Lightwild

Lightwild

    (1) Prestidigitator

  • Members
  • 7 posts
  • Deadfire Silver Backer
  • Fig Backer
  • Do you hear any game audio? No
  • Are you able to interact with the Main Menu blindly and load a save to get past the black screen? I clicked everywhere but nothing happens
  • Is this current patch the first time you've encountered this issue? Just got the New DLC as of today
  • If you've encountered this issue on a previous patch version(s) and this is still occurring, which patch version(s) have you had this issue occur on? Never occurred before today.
  • Is your OS (Windows, Mac, Linux) up to date? Windows 10
  • Are your graphics drivers up to date? Yes


#14
Lightwild

Lightwild

    (1) Prestidigitator

  • Members
  • 7 posts
  • Deadfire Silver Backer
  • Fig Backer

*FIX* Did a lot of online searching today, Looks like the steam users just need to verify installed files and it fixed everything.



#15
Commander_sheperd79

Commander_sheperd79

    (0) Nub

  • Initiates
  • 1 posts

Black Screen upon launching the client:

 

Users have reported experiencing a black screen upon launching the client. Details we are looking for specific to this issue are the following:

  • Do you hear any game audio? yep
  • Are you able to interact with the Main Menu blindly and load a save to get past the black screen? no
  • Is this current patch the first time you've encountered this issue? (currently 1.2) this is patch 4. something (latest I think)
  • If you've encountered this issue on a previous patch version(s) and this is still occurring, which patch version(s) have you had this issue occur on? game was working fine until a couple of days ago. not sure re: patch, happens automatically.
  • Is your OS (Windows, Mac, Linux) up to date? Win 10, yes
  • Are your graphics drivers up to date? yes Geforce latest

I should mention I got through to the Main Menu once this evening after Verifying Game integrity. But then later after quitting and restarting the problem recurred. Retried Verifying => same issue. Obsidian and Versus splash screens, glove cursor, music starts, brief pause, music starts again, then game minimises to non-interactable desktop, have to alt-tab and go to task manager to force close.

 

UPDATE

 

I happened upon a solution after some experimenting. I forced it to use the integrated graphics and it actually worked, leading me to conclude that it was probably a GPU driver issue, so I decided to rollback the driver and the game now works :).

 

Device manager > Display adapters > Select Adapter > Drivers > Rollback driver.

 

I hope this helps somebody!


Edited by Commander_sheperd79, 25 December 2018 - 02:29 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users