Jump to content
  • 0
Sign in to follow this  
virgi26

[1.2][linux] black screen on start

Question

Hi,

 

I'm getting black screen when starting the game. Nothing displayed, no messages, no errors, no nothing.

It was working perfectly fine before 1.2 =(

 

I'm on opensuse42.3 with nvidia 1080

 

No output.log generated

Edited by virgi26

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

and even cleaner solution is change launch options in Steam to

SDL_DYNAMIC_API=/usr/lib64/libSDL2.so LC_ALL=C %command%

Share this post


Link to post
Share on other sites
  • 0

I had the same bug after 1.2 patch. After two days of my investigation i manage to fix it. 

U need to delete(or move) folder "Pillars of Eternity II" from "\Users\Username\AppData\LocalLow\Obsidian Entertainment". I have no idea where it can be on linux but i hope that you will find it. 

After this, game should create new folder on startup. I dont know why, but now it's working fine for me.  

  • Like 2

Share this post


Link to post
Share on other sites
  • 0

I had the same bug after 1.2 patch. After two days of my investigation i manage to fix it. 

U need to delete(or move) folder "Pillars of Eternity II" from "\Users\Username\AppData\LocalLow\Obsidian Entertainment". I have no idea where it can be on linux but i hope that you will find it. 

After this, game should create new folder on startup. I dont know why, but now it's working fine for me.  

can't find anything similar on linux=( only separate folder with save games

Share this post


Link to post
Share on other sites
  • 0
Guest Psychovampiric Shield

It is probably ~/.config/unity3d/Obsidian\ Entertainment/Pillars\ of\ Eternity\ II/ on Linux. Saves should be in ~/.local/share/PillarsOfEternityII/SavedGames/, make sure which is which before deleting (or just rename).

 

May be of interest: https://forums.obsidian.net/topic/97385-linux-unable-to-start-game-hangs-on-black-screen/

Edited by Psychovampiric Shield

Share this post


Link to post
Share on other sites
  • 0

It is probably ~/.config/unity3d/Obsidian\ Entertainment/Pillars\ of\ Eternity\ II/ on Linux. Saves should be in ~/.local/share/PillarsOfEternityII/SavedGames/, make sure which is which before deleting (or just rename).

 

May be of interest: https://forums.obsidian.net/topic/97385-linux-unable-to-start-game-hangs-on-black-screen/

oh nice!!!

deleting .config/unity3d/Obsidian Entertainment/Pillars of Eternity II didn't help, but that link did!!!

I can start the game with "MESA_GL_VERSION_OVERRIDE=4.5 MESA_GLSL_VERSION_OVERRIDE=450 LD_PRELOAD=PillarsOfEternityII_Data/Plugins/x86_64/libSDL2-2.0.so DRI_PRIME=1 ./PillarsOfEternityII"

 

I wonder, why is it only happening with 1.2. Previous versions were ok

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...