Jump to content
  • 0

Amira's Wing not attacking?



Aloth is using Amir'a Wing and it seemed to me that not only is he always missing, there is no attack roll at all, only the animation of attacking.
So out of combat I tried to have him attack my party members (I just noticed there's no way to force attack for a normal attack! only if I order him to use a rogue special attack does it work). I found out that when he attacks some characters, there's a normal attack roll and he hit or misses normally. But for other characters, there's no attack roll and he never seems to hit them no matter how many times I try.

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0



Would simply like to chime in on this particular issue which i've encountered as well. If Haran's post suggests the variable is the character which you're hitting, according to my testing its due to the projectile interaction with terrain.  (Tldr at the end)


Indeed what's special about this Rod is the attack, a gust of wind whose width is huge instead of the normal sphere of energy. I've checked the files of the items in the game data bundle and even if i'm no programmer this is plain Json, and there is no discrepency whatsoever, the item should work as intended.


Point being, i thought it had to with the projectile when i noted that the attack triger was on hit. If a projectile hit needs to be recorded for the attack to trigger, then an issue with the projectile travel would explain that the animation triggers without producing an attack roll and represent adequately what we see on screen.


With that idea in mind, i just took up my save where i encountered the bug, i was in some corridor in Crookspur Fortress, checked if my wielder -Aloth- could hit anyone, he couldnt. Then i went back to other areas, and as soon as Crookspur caverns, where the spiders are, i managed to hit people and the factor that governed whether i could hit them or not was their placement relative to aloth in what remained a relatively tight space.


Conclusion the projectile width is most likely to blame, being so huge that it gets blocked by irregularities in the terrain or simply the lack of width in some areas. I didn't go farther because one would have to check the unity files and know their way around thoses to verify. Something i havent learned yet but might very soon if this bug proves an issue in many other areas (i havent been playing with amira for long at this point so i cannot give a list of affected maps). Hopefully someone can make a quick fix on this if it has only to do with the width. However it promises painstakingly annoying file per file check if its a conflict btw said projectile and terrain.


Personal note: The current projectile/animation is nice and fits the theme so one might consider keeping it for gusto but then we'd need a work around to make the item more reliable (aka not plainly useless) in some maps. It does make sense for wind to be stopped by terrain and again it could be nice to keep it that way but its supposed to be a heavy gust not smthg an unseen pebble stops.




Bug description: Attacking with Amira's wing sometimes does nothing yet the animation fires. The animation looks cut short as if the gust of wind is hitting against smthg that prevents it from reaching its intended target. Instead of a long fog we just see some winds next to wielder. As such it is graphically very clear that the actual/usual length of the projectile is missing. There is no attack roll, nothing recorded in combat log.


This matches the steps of the game code from what i understand.


Proposed Fix: Reduce the width of Amira's gust-projectile. Aka storm_blight_foul_wind_projectile.prefab, either directly this mob's attack or make a custom for the rod. I'm not playing with any druid in my party but maybe this impact wind blight summons. I'm not aware of their spells/abilities as i play blind.


Supposed Steps to fix: Modify Unity projectile prefab or isolate and modify projectile/terrain interaction


Edit: This explanation should also be consistent with Haran's report as Rogue attacks with an item override the item's attack animation with theirs. More over they are coded with NO PROJECTILES thus no travel time which supports the conclusion i've arrived at.


+ You can sometimes get a hit if you try to stick your wielder as close as possible to its target. This is highly inconsistent as far as i can tell.


Cordially, Triskald, your neighbourhood witch.

Edited by Triskald
Link to comment
Share on other sites

  • 0





Here. Tried to have the picture as relevant as possible.  -T


Edit: I played a bunch with that item since my previous post, and i double down on the above. May this be fixed soon.


Edited by Triskald
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...