Jump to content

Recommended Posts

@Mannock: By "little box next to the DLC name", are you meaning the DLC area on the game's page? As in, when you click Pillars of Eternity II: Deadfire in your library list, the DLC area right below achievements, and to the right? So for example, it might say:


ITEM                                                                                             INSTALL                                              ACQUIRED

Pillars of Eternity II: Deadfire - Rum Runner's Pack                     Installed                               [check]    Added 6/27/2018


That area? Because if so, that's what I'm saying. I have none of those free DLC's there, no matter if I clicked install, or add all items to cart, etc. No trick works, as it seems to be a licensing issue preventing it from even initializing. I'm thinking the reason it might not have started downloading when you exited the game was because of a Steam setting or issue you might be experiencing. As I saw other people talk about having issues similar on PoE2's DLC comments.


Thanks again man for trying to help. I think it has to be something that Obsidian takes care of, and nothing that I can do personally. I'm just hoping they know what to do. Feel bad though, as they already tried to fix the issue, and quite quickly. Sucks that I'm saying "umm, can you fix it again?".

Yeah, that's what I meant.


But yes, seems like Obsidian and Steam need to have a chat and fix that particular problem.

  • Like 1

I'll do it, for a turnip.


DnD item quality description mod (for PoE2) by peardox

Link to comment
Share on other sites

@Mannock: Steam should just remove this "feature", or at the very least, default to off. Or something. Annoying that I even have to try and reach out to Obsidian, or that they even have to deal with this.


Hopefully accessible free DLC is in my future haha.

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

Hello Drone456,


I've been working with Valve on this. They do believe that this is configured properly (and has been for a couple weeks). Would you mind sharing your Steam Username so that I can pass that along to our contact at Valve? They'd like to take a closer look at why this isn't working for your account.


Thank you,

  • Like 3
Link to comment
Share on other sites

@David Benefield: Sorry for the late reply. I hadn't got notified there was a response to this forum for some reason until Azulmar posted. I will contact you via PM with my username, just in case you need further details that are a little more confidential we can continue it there.


@Azulmar: Thanks for posting man. Glad/sad that I'm not the only one. Hopefully we can both get this figured out.


EDIT: Nevermind haha, it wouldn't let me message you. Is it possible for you to initiate the chain, so I can then respond? If not, then let me know and I will post my details here. Just to clarify, do you need the account name (what I login to Steam with) or the Username (what everyone else sees?)


Thanks very much for your time David. And to Aarik whom I assume contacted you with this.

Edited by Drone456
Link to comment
Share on other sites

  • 2 weeks later...

I was curious if there has been any progress on this issue?   I finished Pillars of Eternity and have now moved on to Deadfire and i'm encountering the same issue where I am unable to access the free dlcs through steam family sharing.  Unlike the first game Deadfire has quite a bit of content from free dlcs which I would hate to miss out on. 


Thanks for all your time and hard work on this.

Link to comment
Share on other sites

@Azulmar: Not as of yet unfortunately. I've been in contact with Aarik and David on this, and they with Valve (who insists it's been fixed). And am currently awaiting another reply from David (I'm sure they're busy) on this matter.


Thankfully they've been incredibly nice with this whole ordeal, and have gone way above in my opinion. On something that only really benefits them with the appreciation of a couple people who even realized it was happening. It's quite awesome of them.


Hopefully this does eventually get resolved. As I also would hate to miss out on those free DLC.

Link to comment
Share on other sites

  • 6 months later...

Sorry to resurrect such an ancient thread haha. But I figured that I should continue here; since it has legacy, and still directly pertains to it. And also that way anyone that was watching this thread, can see any further developments.


I have continued this problem directly with Steam Support, and have started a Steam forum thread. The thread can be found here:



I would greatly appreciate anybody that feels strongly about this issue, to go over there and post your desires for the removal of this "feature". Or even start your own threads. As the more voices and noise we can make about this, the better and quicker it can get changed. Or whatever way you feel comfortable asking Valve/Steam for this change (twitter, reddit, petition, etc.).


It would be great to have this restriction removed, as it would be a boon for anyone who can be affected by it. And literally imperceptible to anyone who wouldn't be.


Sorry again for the necro'ing of this thread, and thanks a lot for your time. Here's hoping that this can finally be resolved.

Link to comment
Share on other sites

  • 2 weeks later...

Further development on this issue:


I made a reddit thread talking about this a bit. If reddit is more your speed, and you didn't want to post on the Steam forums. I would appreciate any comments there as well.


Really any type of movement on this would be great, as I am not allowed to bump my Steam forum post, and conversation has sort of stopped for the time being seemingly. So if anyone that has experienced this issue (like @Azulmar ), or just wants it fixed. It would be fantastic if you could post in either of these locations.


And if it's not too much trouble, would anyone that does post on either of these locations, please post that they did so here? That way this gets naturally bumped as well. I didn't see anything against bumping in the rules here, but better to not bump artificially regardless if possible. The more activity on this, the more likely it gets picked up by someone with the capacity to do something about it.


Thanks again for your time!

Link to comment
Share on other sites

  • 3 weeks later...
So! Good news everyone! Apparently there is a fix for this issue, or at least potentially if your game falls into a specific category of how a game handles free DLC. According to @DarkStarSword (Steam Username), it's as follows:
It looks like their are two types of "free DLC" - one type that contains files, and one type that does not (presumably some cases may be a combination of both).
The type that only contains files can be made to work by downloading the game while logged into the owner's account, making a copy of it, logging back into the borrower's account and if Steam removes the files just restore them from the copy (there are other ways to achieve the same result, but this seemed the simplest to explain).


The type that does not contain any files, but rather where the game just checks if the player owns the DLC via the Steam API is a bigger problem - because there is no way* to get the Steam API to tell the game that the free DLC is owned by the borrower's account.

* I'm a programmer and I'm sure I could get around this if I really wanted, but that doesn't help anyone else - better to have this issue fixed in Steam itself.
I tried @DarkStarSword's idea, and at least for Pillars of Eternity II: Deadfire, it seems to be working. Thankfully PoEII seems to land in the first column of games, and not the second; I hope that others are as lucky.
And it just goes to show that this isn't a deliberate decision on Valve's part, as it doesn't show that I have the DLC. But the game inside does. I even tried quitting Steam and re-launching it, and it still worked.
For anyone wondering how to exactly do it. This is what I did:
1) Logged onto owner's account and downloaded all free DLC, and launched the game (just to make sure entitlements are applied).
2) Copied the whole game folder (e.g. Pillars of Eternity II)
3) Pasted the whole game folder away from Steam's directory (e.g. from "D:\Steam Games\steamapps\common" to "D:\")
4) Logged onto borrower's account (me)
5) Deleted game folder from "D:\Steam Games\steamapps\common" (replacing takes longer than just pasting)
6) Copied the game folder from 2 (D:\)
7) Pasted that game folder into "D:\Steam Games\steamapps\common"
8) Launched Pillars of Eternity II: Deadfire. Success!
So things seem to be working, as I had access to the Drunk stance, Critical Role portraits, and the game itself said they were installed (little icon in bottom left). Hopefully this is actually a way to "fix" what I consider a bug with Steam's Family Sharing. Unfortunately I assume that any future free DLC, will require this whole process again. But at least it's something.
Thanks again to @DarkStarSword for this find. Once the turn-based update fully releases for PoEII, I'll be able to play with all the free DLC available seemingly. Which is nice.
At least there's a partial light at the end of a tunnel that shouldn't have been dug (meaning Steam, not Pillars).
Hopefully this helps others who read this.
Edited by Drone456
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...