Jump to content

Question

Hopefully, people are still visiting the Pillars 1 forum. I really need some help.

I am trying to replay Pillars of Eternity 1 while I wait for the bugs in 2 to be ironed out and I am suffering from periodic stutters every 30 seconds or so. The framerate's almost locked at 60 everywhere but it still stutters. It's quite annoying. Doesn't matter where I am, it still stutters. 

This and Pillars 2 are the only games I am having issues with on my system. Everything else runs fine.

My system specs:

OS: Windows 7 Professional (64 bit)
CPU: i7 3770K (overclocked or not, it makes no difference)
GPU: Geoforce GTX 1060 6GB (I have tried switching this with an older GTX 780. No change in stutter)
Storage: 1TB SSD
RAM: Kingston HyperX FURY 16GB (2x8GB) 1866MHz DDR3
Motherboard: Asrock Z75 Pro3

I do not have a Gsync Monitor. I have a "Generic PnP 60hz Monitor"
Temps never go above 60 degrees

Things I have tried:

  • Vsync On/Off 
  • Lowered setting to the lowest it was possible to go.
  • Capped framerate to 30
  • Ran game as administrator
  • Tried running the game with each different compatibility setting
  • Verified game cache with steam
  • Updated nviida drivers
  • Complete uninstall and reinstall of the game
  • Tried the different launch parameters (-force-d3d11, -force-opengl)
  • Double checked that the game was using my actual GPU.
  • Temporarily disabled my integrated gpu to force the game to use of my dedicated gpu 
  • Ran with high cpu priority
  • Fiddled with the cpu affinity (disabled and re-enabled the working cores to trick it into using my other cores, which HAS worked for different games before.)
  • Overclocked the GPU
  • Underclocked the GPU
  • Removed any and all overclocking from GPU and CPU
  • Tried to disable any non windows services
  • Made sure everything else was closed with task manager before running the game.
  • Checked to make sure I was using "Maximum Performance" power option.
  • Disabled both Steam Overlay and the in-game telemetry.
  • Turned off all my monitoring software(MSI Afterburner).
  • Temporarily disabled my antivirus
  • disconnected my ethernet cable
  • removed any usb devices
  • removed audio devices (certain older games crash when using certain audio devices) 

I don't know what else to do.

Some people with lesser hardware are getting better performance while others with stronger hardware are getting worse performance.

I am welcome to and appreciate any suggestions you might have.

 

DxDiag.txt

  • Like 2

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Hello PillarsStutterSufferer.

 

I have the exact same problem, periodic stutter every 30 sec or so .

Ive got this problem since release , day one.

 

Like you did , i tried many many things  without succes (everything that you listed i did too) .

I made post about it , read online, a lot ppl actually suffer from this too, ive watched lets play on youtube and i can see stutter too.

I tested the game on 3 different pc , my desktop, gaming laptop and my brother's desktop with the exact same stutter on 3 different computer with different hardware and os.

 

After extensive testing I was able to find out that its related to your framerate and the amount of character you have in your party

If i play at 144 fps i will get stutter every 25 secs (i dont remember the exact number but its close to that)

If i play at 45 fps it get stutter every minute.

The frame time get a huge spike like 255 ms between 2 frame that cause the stutter.

when you remove one compagnon from your party , you gain about 25 seconds each time, so if you do a solo playthrough you will get periodic stutter around every 2mim if you play at 45 fps .

 

This will never be adressed, i get this with deadfire too, but the frametime spike happen  every 3 min or 6 min so its more playable but still annoying.

The only way to fix this bug is on the programmer side. Its probably garbage colllection issue that cause the frame time spiking this way and the fact that it happen more often with high framerate is a proof of that.

 

(sry my english is not so good)

Edited by truths33ker
  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Well, that is farther then I ever got, good job truth, and like truth I have never been successful in getting rid of it since day one.  In POE 1 it is less annoying for some reason...maybe cause it looks worse I do not know and it happens out of combat, where in POE 2 I will get it in combat also from time to time.   I also have this issue in POE 2, and BATTLETECH.  They all use the Unity Engine.  I am not saying it is the engines fault maybe it is the programmers but I am not there so I do not know.  I have tried everything mentioned to no avail and have never ever seen a moderator talk about it in the public forum.  One did talk to me about it in a private message and he/she says they get it to.....  

 

Ps My rig is almost exactly like yours except my CPU is marginally faster.  We should not have any issues.  I love this series and think it is great but its biggest failing I think is in that diabolical stutter issue.  I cannot beat it.

Edited by Torm51
  • Like 1

Have gun will travel.

Share this post


Link to post
Share on other sites
  • 0

Yeah, I was afraid of that. This issue really feels like something I just have to deal with if I want to play either game. It's a shame. The only thing I haven't tried is go through the config files and see if I could find a setting to turn off. The thing is, there is no config file. It's all in the windows registry (In my case, it's found here; "HKEY_CURRENT_USER\Software\Obsidian Entertainment\Pillars of Eternity") and I don't feel comfortable changing anything in the registry unless I need to.

Thank you both, but It looks like we're just stuck with this issue.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

I am sorry :( I have tried SO MUCH to fix this issue.  I am not comfortable at all in windows registry so I am of no use there  Its my biggest gripe with them.

  • Like 1

Have gun will travel.

Share this post


Link to post
Share on other sites
  • 0

Im in the same boat, i still try to debug this ****, at first i gave up on poe 1

I said to myself i will play the second game when it come out and Obsidian will absolutly have fix this bug , they upgraded to unity 5 and i was sure it was not gonna happen in poe 2

 

I WAS SOOOO WRONG

and the thing is that its not the unity engine i play wasteland 2 and shadowrun dragonfall they both use unity and i have zero stutter at all

i have yet to try battletech.

 

and torm51 i am surprise that you were able to talk to someone in a private message about this issue ive never seen any acknowledge or awnser  from obsidian about this issue.

Im not surprise that the guy told you they got this too, im sure everybody get it at different strenght. I have tested this on 3 pcs and they all do it.

 

we need to find a way to fix that, those game will be classic game like baldur agte and i want to play it wihtout suffering stutter every 30 second, when i play i just see that i anticipate the stutters and i cant focus it ruined the game.

I still cant believe that they didnt fix it in poe 2 .

 

I will keep searching I dont know if i find new info of way to understand why we got this i will post it here

but it would be great to have someone at obsidian looking into that and find the cause

  • Like 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...