Jump to content

Windows 32-bit: Crashing occasionally or on specific area transitions

Darren Monahan

9,931 views

Are you running a 32-bit version of Windows and experiencing crashes, sometimes during specific area transitions?

This seems to be caused by the game at certain points needing more available RAM than Windows in 32-bit will allow, so it will crash. In fact, this happens in other Unity-based games, such as Wasteland 2. One workaround customers of Wasteland found was that you could change a setting that would allow applications in Windows to use more RAM on 32-bit Windows.

 

We do recommend setting this flag if you are experiencing these crashes, but please understand that this is a change to your computer that takes it out of its default state, and that we are not responsible for any damage to your computer that may occur. Granted, this sounds scarier than what the actual change is, but our lawyer types make us say things like that. :)

 

If you are interested in trying this, please visit the following thread:

 

http://windows7themes.net/32-bit-use-bcdedit-set-increaseuserva-to-increase-ram-used-by-single-application.html

 

How do I find out if I'm running 32-bit Windows?

http://www.howtogeek.com/howto/21726/how-do-i-know-if-im-running-32-bit-or-64-bit-windows-answers/

 

What's the story with 32-bit Windows versus 64-bit Windows?

The good folks at Lifehacker have a great article that helps explain the difference:

 

http://lifehacker.com/5431284/the-lifehacker-guide-to-64-bit-vs-32-bit-operating-systems



4 Comments


Recommended Comments

For WinXP, edit the boot.ini file in C:\ to add a /3GB switch - see https://support.microsoft.com/en-us/kb/316739 for details. Windows will need to be restarted for this to take effect.

 

Also consider adding /userva=2900 after the /3GB - this will reduce available memory slightly from 3072 to 2900 but should avoid potential issues with reduced Windows kernel memory as noted in the MS article.

Share this comment


Link to comment

What's the process like on Windows Vista?

It's the same as Windows 7 using bcdedit:

 

1) Right-click Command Prompt in the Accessories group in your Start Menu. Click Run as Administrator.

2) At the command prompt, enter "bcdedit /set IncreaseUserVa 3072"

3) Restart the computer.

 

To disable this later, replace step 2 with:

 

bcedit /deletevalue IncreaseUserVa

 

...and reboot your computer.

Share this comment


Link to comment
Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...