Jump to content
  • 0
Sign in to follow this  
Battican

Blow the Man Down quest bug

Question

I'm still very early in the game, trying to do the Blow the Man Down quest at Fort Deadlight. I'm stealthing it, so I found Lamond and decided to go along with his plan of luring out Benweth by stealing his ship. I got to the underground dock, killed everyone, and then went up to the western rampart and rang the bell 3 times like he said to. Nothing happened, so I went back down to the underground docks and the ship was indeed gone...but I had no idea what to do next. My journal hasn't updated since I first heard Lamond's plan. Lamond and his crew are gone from the forge area, but Benweth is still in the command area and hasn't reacted. I'm trying to complete this by killing as few pirates as possible, so did I completely miss something, or is this quest bugged?

  • Like 1

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

Same problem here. Lamond is gone. Rang the bell, the ship is gone, but Benweth stays in his room with his very very powerful guards  :w00t: .

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Seems others have reported the issue is with the bell, and might have something to do with being in stealth mode during the ringing. 

  • Like 2

Share this post


Link to post
Share on other sites
  • 0

I think you might be supposed to go back to Lamond and tell him you've cleared the docks? I did that before ringing the bell and the quest proceeded as it was supposed to.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

I think you might be supposed to go back to Lamond and tell him you've cleared the docks? I did that before ringing the bell and the quest proceeded as it was supposed to.

 

Ah that might explain it. Will probably be starting a new playthrough after some patches anyway. Did you get any journal entries after you cleared the dock?

Share this post


Link to post
Share on other sites
  • 0

Seems others have reported the issue is with the bell, and might have something to do with being in stealth mode during the ringing. 

That's it for me. Same thing as OP when I was in stealth when I rang it, when I reloaded and rang the bell without stealth it all worked.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

You are apparently supposed to not be in stealth mode when ringing the bell - that was the difference for me.

Successful completion was:

  1. Clear the docks.
  2. Inform Lamond.
  3. Ring the bell while not in stealth.

Benweth then runs right up to the bell.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

This bug still persists. I'm not in stealth, I reported back to Lamond and now the ship, Lamond and the others are gone. Bell doesn't do anything. Reloaded. Quit and loaded. Exitted the area and tried again. Nothing.

 

Edit: After reloading 5 times it worked all of a sudden.

Edited by AeonsLegend

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...