Jump to content
  • 0

No tech support


RoiCohen

Question

So, I backed up PoE and I got the game when it got out. Played it on my aging stationary PC, and really enjoyed it. Recently, I got a strong gaming laptop (Lenovo Y700), and I tried running PoE on it, and it kinda stuttered.

 

What I did was post a question on the tech support forum. No answer. Ok, I looked for a way to contact official support. Got directed to Paradox's support, and they told me to contact Obsidian themselves with it, and gave me a techincal support Email (support@obsidian.net). I sent that address a mail more than a week ago, and no answer yet.

 

What gives, man?  :getlost:

Edited by RoiCohen
Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

The tech support forum is not official Obsidian support.

 

This forum is for customers to assist each other with technical questions.

 

If it's been over 5 working days since you emailed Obsidian, email them again.

 

The Lenovo Y700 has up to a 960m GPU, it could have something lower depending on model. The 960m's equivalent discrete GPU is the 750 Ti in the budget range, that card gets quite large frame dips at 1080p in Pillars. Try running the game's graphic quality setting lower and perhaps at 1280x720p.

Link to comment
Share on other sites

  • 0

Hi RoiCohen,

 

I am sorry for the frustration and concern. I have pinged Admin directly about your concern and the email and sincerely hope and suspect you should hear something shortly.

 

with apology,

 

F

  • Like 1

The universe is change;
your life is what our thoughts make it
- Marcus Aurelius (161)

:dragon:

Link to comment
Share on other sites

  • 0

The tech support forum is not official Obsidian support.

 

This forum is for customers to assist each other with technical questions.

 

If it's been over 5 working days since you emailed Obsidian, email them again.

 

The Lenovo Y700 has up to a 960m GPU, it could have something lower depending on model. The 960m's equivalent discrete GPU is the 750 Ti in the budget range, that card gets quite large frame dips at 1080p in Pillars. Try running the game's graphic quality setting lower and perhaps at 1280x720p.

I know it's not the official method, but that's the main one being offered. Both didn't help.

 

I get what you're saying, but it sounds weird, considering games like the new Doom run on Ultra without any problems or slowdowns.

 

 

Hi RoiCohen,

 

I am sorry for the frustration and concern. I have pinged Admin directly about your concern and the email and sincerely hope and suspect you should hear something shortly.

 

with apology,

 

F

 

Thanks a lot! :)

Edited by RoiCohen
Link to comment
Share on other sites

  • 0

considering games like the new Doom run on Ultra without any problems or slowdowns.

You can't maintain 30+fps @ 1080p on a 960m on nightmare graphics in Doom 2016. Doom 2016 is an incredibly well built game, it is very well optimized, the 4GB version of the 960m can run 30+fps @ 1080p on high settings which is incredible. Pillars of Eternity is not very well optimized at all, they've already promised to do all the graphical upgrades while keeping the recommended specs the same for Deadfire, which should tell you all you need to know about that.
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...