Jump to content
  • 0
Sign in to follow this  
DeHavilan

Kana Breaking Party Switching

Question

It seems there has been a return of the issue where Kana breaks the party when you switch him out, and then try to add him back after completion of his quest in the Endless Paths.  I can't seem to ever put him back in my party now, or it just breaks my party.  He has none of the chants he's learned previously, and I'm unable to switch out or in any party members after adding him to the party.  Just wanted someone to be aware that this bug is back.

 

 

Game Save File: https://www.sendspace.com/file/d6sa0t

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Bump for this, also further info:

 

  • I've got WM 1 & 2
  • I started this play-through on 3.03

If anyone responds to this I can try and provide the output logs as well.

Share this post


Link to post
Share on other sites
  • 0

I loaded your savegame and added Kana, there's definitely something off about it. Got the issue you described, as well as a weird glitch with the character drag-selection. There's a whole bunch of index out of range errors in the log file as well. Maybe the savegame got slightly corrupted at some point, somehow.

 

Anyway, I would suggest that you retrain Kana. This seems to fix the issue, he just resets with the standard level 1 stuff he starts with normally, and you can level him back up from there. I did get a slight quirk after that when quicksaving and quickloading that he moved to the second NPC slot and his portrait didn't show in the save game entry, but saving again after that resolved that as well so I think you should be fine from there. 

Share this post


Link to post
Share on other sites
  • 0

Whatever it's causing the UI glitch, once triggered in DeHavilan save it persisted after loading one of my saves, until I returned to the title screen.


I've come to burn your kingdom down

Share this post


Link to post
Share on other sites
  • 0

Odd. For me it disappeared after I quicksaved and quickloaded in his save. Strange that it would carry over to your own save game. Especially since it wasn't technically a UI glitch as such; in the log file I saw a whole host of out of range exceptions, relating to some array containing the companions. Because the drag selection obviously references that array as well it started to glitch. No idea why Kana was so special there though, tried Pallegina as well with no problem. 

Share this post


Link to post
Share on other sites
  • 0

Guess the bug gets mixed up with something else. There is a repetition of the null reference exception when I use the party UI with my other saves.

The work-around is pretty similar anyways. Saving-Title Screen-Loading.


I've come to burn your kingdom down

Share this post


Link to post
Share on other sites
  • 0

Weird, thanks to you both for investigating.  I'm really quite grateful, as I was about to just give up on the play-through until a patch.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...